aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/hat/Makefile5
-rw-r--r--devel/hat/files/patch-configure11
-rw-r--r--devel/hs-hat/Makefile5
-rw-r--r--devel/hs-hat/files/patch-configure11
4 files changed, 26 insertions, 6 deletions
diff --git a/devel/hat/Makefile b/devel/hat/Makefile
index e3a9d7646ffd..0ab89a38c97c 100644
--- a/devel/hat/Makefile
+++ b/devel/hat/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= obraun@informatik.unibw-muenchen.de
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500000
-BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
+BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
.endif
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -32,8 +32,7 @@ CONFIGURE_ARGS+= --buildwith=ghc
CONFIGURE_ARGS+= --docdir=${PREFIX}/share/doc/nhc98 +docs
.endif
-MAN1= harch.1 hmake.1 hp2graph.1 nhc98.1 \
- hat-detect.1 hat-observe.1 hat-stack.1 hat-trail.1
+MAN1= harch.1 hmake.1 hp2graph.1 nhc98.1
post-patch:
@${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|' ${WRKSRC}/Makefile.inc
diff --git a/devel/hat/files/patch-configure b/devel/hat/files/patch-configure
new file mode 100644
index 000000000000..5d5bf381a351
--- /dev/null
+++ b/devel/hat/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Tue Jun 18 20:21:59 2002
++++ configure Tue Jun 18 20:24:20 2002
+@@ -748,7 +748,7 @@
+ then mkdir -p $DESTDIR$MANDIR; echo ' (created)'
+ else echo ' (exists)'
+ fi
+- for file in man/*
++ for file in man/harch.1 man/hmake.1 man/hp2graph.1 man/nhc98.1
+ do
+ echo " `basename $file` "
+ cp $file $DESTDIR$MANDIR
diff --git a/devel/hs-hat/Makefile b/devel/hs-hat/Makefile
index e3a9d7646ffd..0ab89a38c97c 100644
--- a/devel/hs-hat/Makefile
+++ b/devel/hs-hat/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= obraun@informatik.unibw-muenchen.de
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500000
-BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
+BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
.endif
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -32,8 +32,7 @@ CONFIGURE_ARGS+= --buildwith=ghc
CONFIGURE_ARGS+= --docdir=${PREFIX}/share/doc/nhc98 +docs
.endif
-MAN1= harch.1 hmake.1 hp2graph.1 nhc98.1 \
- hat-detect.1 hat-observe.1 hat-stack.1 hat-trail.1
+MAN1= harch.1 hmake.1 hp2graph.1 nhc98.1
post-patch:
@${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|' ${WRKSRC}/Makefile.inc
diff --git a/devel/hs-hat/files/patch-configure b/devel/hs-hat/files/patch-configure
new file mode 100644
index 000000000000..5d5bf381a351
--- /dev/null
+++ b/devel/hs-hat/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Tue Jun 18 20:21:59 2002
++++ configure Tue Jun 18 20:24:20 2002
+@@ -748,7 +748,7 @@
+ then mkdir -p $DESTDIR$MANDIR; echo ' (created)'
+ else echo ' (exists)'
+ fi
+- for file in man/*
++ for file in man/harch.1 man/hmake.1 man/hp2graph.1 man/nhc98.1
+ do
+ echo " `basename $file` "
+ cp $file $DESTDIR$MANDIR