aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Term-ANSIColor/Makefile26
-rw-r--r--devel/p5-Term-ANSIColor/distinfo1
-rw-r--r--devel/p5-Term-ANSIColor/pkg-comment1
-rw-r--r--devel/p5-Term-ANSIColor/pkg-descr16
-rw-r--r--devel/p5-Term-ANSIColor/pkg-plist3
6 files changed, 48 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d18841cb85a8..6a6b2c367e52 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -134,6 +134,7 @@
SUBDIR += p5-Resources
SUBDIR += p5-Sort-Versions
SUBDIR += p5-Storable
+ SUBDIR += p5-Term-ANSIColor
SUBDIR += p5-Term-Query
SUBDIR += p5-Term-ReadKey
SUBDIR += p5-Time
diff --git a/devel/p5-Term-ANSIColor/Makefile b/devel/p5-Term-ANSIColor/Makefile
new file mode 100644
index 000000000000..598c56b8a70d
--- /dev/null
+++ b/devel/p5-Term-ANSIColor/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: ANSIColor
+# Version required: 1.01
+# Date created: 1 December 1999
+# Whom: Denis Shaposhnikov <dsh@vlink.ru>
+#
+# $FreeBSD$
+#
+
+DISTNAME= ANSIColor-1.01
+PKGNAME= p5-Term-ANSIColor-1.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Term
+
+MAINTAINER= dsh@vlink.ru
+
+USE_PERL5= YES
+CONFIGURE_ARGS= PREFIX=${PREFIX}
+
+MAN3= Term::ANSIColor.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL ${CONFIGURE_ARGS}
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Term-ANSIColor/distinfo b/devel/p5-Term-ANSIColor/distinfo
new file mode 100644
index 000000000000..51d970ef1156
--- /dev/null
+++ b/devel/p5-Term-ANSIColor/distinfo
@@ -0,0 +1 @@
+MD5 (ANSIColor-1.01.tar.gz) = e499734e8d1709ae093187eb93ed5bc1
diff --git a/devel/p5-Term-ANSIColor/pkg-comment b/devel/p5-Term-ANSIColor/pkg-comment
new file mode 100644
index 000000000000..83e852dfd188
--- /dev/null
+++ b/devel/p5-Term-ANSIColor/pkg-comment
@@ -0,0 +1 @@
+Color screen output using ANSI escape sequences
diff --git a/devel/p5-Term-ANSIColor/pkg-descr b/devel/p5-Term-ANSIColor/pkg-descr
new file mode 100644
index 000000000000..b95d3b79cf46
--- /dev/null
+++ b/devel/p5-Term-ANSIColor/pkg-descr
@@ -0,0 +1,16 @@
+While ANSI color escape codes are fairly simple, it can be hard to
+remember the codes for all of the attributes and the code resulting
+from hard-coding them into your script is definitely difficult to
+read. This module is designed to fix those problems, as well as
+provide a convenient interface to do a few things for you
+automatically (like resetting attributes after the text you print out
+so that you don't accidentally leave attributes set).
+
+Despite its name, this module can also handle non-color ANSI text
+attributes (bold, underline, reverse video, and blink). It uses either
+of two interfaces, one of which uses "constants" for each different
+attribute and the other of which uses two subs which take strings of
+attributes as arguments.
+
+-- Denis Shaposhnikov
+dsh@vlink.ru
diff --git a/devel/p5-Term-ANSIColor/pkg-plist b/devel/p5-Term-ANSIColor/pkg-plist
new file mode 100644
index 000000000000..e9ac3b82186c
--- /dev/null
+++ b/devel/p5-Term-ANSIColor/pkg-plist
@@ -0,0 +1,3 @@
+lib/perl5/site_perl/%%PERL_VER%%/Term/ANSIColor.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Term/ANSIColor/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Term/ANSIColor