aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile6
-rw-r--r--devel/e_dbus/Makefile56
-rw-r--r--devel/e_dbus/distinfo3
-rw-r--r--devel/e_dbus/pkg-descr3
-rw-r--r--devel/e_dbus/pkg-plist31
-rw-r--r--devel/ecore-file/Makefile64
-rw-r--r--devel/ecore-file/distinfo3
-rw-r--r--devel/ecore-file/pkg-descr5
-rw-r--r--devel/ecore-file/pkg-plist6
-rw-r--r--devel/ecore-ipc/Makefile66
-rw-r--r--devel/ecore-ipc/distinfo3
-rw-r--r--devel/ecore-ipc/files/patch-configure94
-rw-r--r--devel/ecore-ipc/pkg-descr5
-rw-r--r--devel/ecore-ipc/pkg-plist6
-rw-r--r--devel/ecore-job/Makefile53
-rw-r--r--devel/ecore-job/distinfo3
-rw-r--r--devel/ecore-job/pkg-descr5
-rw-r--r--devel/ecore-job/pkg-plist6
-rw-r--r--devel/ecore-main/Makefile40
-rw-r--r--devel/ecore-main/distinfo3
-rw-r--r--devel/ecore-main/pkg-descr5
-rw-r--r--devel/ecore-main/pkg-plist8
-rw-r--r--devel/ecore/Makefile52
-rw-r--r--devel/ecore/pkg-descr5
-rw-r--r--devel/eet/Makefile7
-rw-r--r--devel/eet/distinfo6
-rw-r--r--devel/eet/pkg-plist2
-rw-r--r--devel/engrave/Makefile5
-rw-r--r--devel/engrave/distinfo6
-rw-r--r--devel/engrave/pkg-plist3
-rw-r--r--devel/evfs/Makefile7
-rw-r--r--devel/evfs/distinfo6
-rw-r--r--devel/evfs/pkg-plist27
-rw-r--r--devel/libast/Makefile6
-rw-r--r--devel/ruby-ecore/Makefile10
-rw-r--r--devel/ruby-ecore/distinfo6
-rw-r--r--devel/ruby-ecore/files/patch-Rakefile17
37 files changed, 580 insertions, 59 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2f0c58ac2767..a8bfe2f73b63 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -271,10 +271,16 @@
SUBDIR += duplo
SUBDIR += dwarfdump
SUBDIR += e4graph
+ SUBDIR += e_dbus
SUBDIR += ebnf2yacc
SUBDIR += eboxy
SUBDIR += ecb
SUBDIR += ecgi
+ SUBDIR += ecore
+ SUBDIR += ecore-file
+ SUBDIR += ecore-ipc
+ SUBDIR += ecore-job
+ SUBDIR += ecore-main
SUBDIR += ecos-tools
SUBDIR += eet
SUBDIR += egypt
diff --git a/devel/e_dbus/Makefile b/devel/e_dbus/Makefile
new file mode 100644
index 000000000000..7a5faef3c5bf
--- /dev/null
+++ b/devel/e_dbus/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: e_dbus
+# Date created: 23 February 2008
+# Whom: Stanislav Sedov <stas@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= e_dbus
+PORTVERSION= 20080223
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
+ http://download.enlightenment.org/snapshots/2008-01-25/
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= EFL DBUS connectivity library
+
+LIB_DEPENDS= dbus-1.3:${PORTSDIR}/devel/dbus
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GNOME= gnomehack gnometarget pkgconfig
+USE_EFL= ecore
+USE_LDCONFIG= yes
+
+OPTIONS= EHAL "Build E HAL module" on \
+ ENM "Build E NM module" on \
+ ENOT "Build E notify module" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_EHAL)
+CONFIGURE_ARGS+= --enable-ehal
+PLIST_SUB+= EHAL=""
+.else
+CONFIGURE_ARGS+= --disable-ehal
+PLIST_SUB+= EHAL="@comment "
+.endif
+
+.if !defined(WITHOUT_ENM)
+CONFIGURE_ARGS+= --enable-enm
+PLIST_SUB+= ENM=""
+.else
+CONFIGURE_ARGS+= --disable-enm
+PLIST_SUB+= ENM="@comment "
+.endif
+
+.if !defined(WITHOUT_ENOT)
+CONFIGURE_ARGS+= --enable-enotify
+PLIST_SUB+= ENOT=""
+USE_EFL+= evas
+.else
+CONFIGURE_ARGS+= --disable-enotify
+PLIST_SUB+= ENOT="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/e_dbus/distinfo b/devel/e_dbus/distinfo
new file mode 100644
index 000000000000..486c69fb2ee8
--- /dev/null
+++ b/devel/e_dbus/distinfo
@@ -0,0 +1,3 @@
+MD5 (e_dbus-20080223.tar.bz2) = d709ffed87f71253a62cda1484b0aa64
+SHA256 (e_dbus-20080223.tar.bz2) = f27382a51c16f7d10b3e2757c4b8c3a483b3afc137cafae4321252b3d4cf59c0
+SIZE (e_dbus-20080223.tar.bz2) = 252568
diff --git a/devel/e_dbus/pkg-descr b/devel/e_dbus/pkg-descr
new file mode 100644
index 000000000000..141e4ab49806
--- /dev/null
+++ b/devel/e_dbus/pkg-descr
@@ -0,0 +1,3 @@
+Enlightenment DBUS compatibility layer.
+
+WWW: http://www.enlightenment.org/
diff --git a/devel/e_dbus/pkg-plist b/devel/e_dbus/pkg-plist
new file mode 100644
index 000000000000..5699855209ab
--- /dev/null
+++ b/devel/e_dbus/pkg-plist
@@ -0,0 +1,31 @@
+%%EHAL%%bin/e_dbus_hal
+%%ENM%%bin/e_dbus_nm
+%%ENOT%%bin/e_dbus_notification_daemon
+%%ENOT%%bin/e_dbus_notify
+bin/e_dbus_test
+bin/e_dbus_test_client
+include/E_DBus.h
+%%EHAL%%include/E_Hal.h
+%%ENM%%include/E_Nm.h
+%%ENOT%%include/E_Notification_Daemon.h
+%%ENOT%%include/E_Notify.h
+lib/libedbus.a
+lib/libedbus.la
+lib/libedbus.so
+lib/libedbus.so.1
+%%EHAL%%lib/libehal.a
+%%EHAL%%lib/libehal.la
+%%EHAL%%lib/libehal.so
+%%EHAL%%lib/libehal.so.1
+%%ENM%%lib/libenm.a
+%%ENM%%lib/libenm.la
+%%ENM%%lib/libenm.so
+%%ENM%%lib/libenm.so.1
+%%ENOT%%lib/libenotify.a
+%%ENOT%%lib/libenotify.la
+%%ENOT%%lib/libenotify.so
+%%ENOT%%lib/libenotify.so.1
+libdata/pkgconfig/edbus.pc
+%%EHAL%%libdata/pkgconfig/ehal.pc
+%%ENM%%libdata/pkgconfig/enm.pc
+%%ENOT%%libdata/pkgconfig/enotify.pc
diff --git a/devel/ecore-file/Makefile b/devel/ecore-file/Makefile
new file mode 100644
index 000000000000..49dbff8abac7
--- /dev/null
+++ b/devel/ecore-file/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: ecore-file
+# Date created: 17 September 2007
+# Whom: Stanislav Sedov <stas@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= file
+PORTVERSION= 0.9.9.042
+PORTREVISION= 0
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
+ http://download.enlightenment.org/snapshots/2008-01-25/
+PKGNAMEPREFIX= ecore-
+DISTNAME= ecore-${PORTVERSION}
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= Enlightenment core abstraction library (file module)
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GNOME= gnomehack pkgconfig gnometarget
+USE_LDCONFIG= yes
+USE_GETOPT_LONG=yes
+USE_EFL= ecore
+BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_file
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+CONFIGURE_ARGS= --disable-ecore-con \
+ --disable-ecore-config \
+ --disable-ecore-desktop \
+ --disable-ecore-directfb \
+ --disable-ecore-evas \
+ --enable-ecore-file \
+ --disable-ecore-ipc \
+ --disable-ecore-job \
+ --disable-ecore-sdl \
+ --disable-ecore-txt \
+ --disable-ecore-x \
+ --disable-ecore-imf \
+ --disable-ecore-imf_evas
+
+OPTIONS= CURL "Enable Curl support" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_CURL)
+CONFIGURE_ARGS+= --enable-curl
+LIB_DEPENDS+= curl.4:${PORTSDIR}/ftp/curl
+.else
+CONFIGURE_ARGS+= --disable-curl
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -E -e \
+ 's,\$$\(top_builddir\)/src/lib/ecore/\.libs,${LOCALBASE}/lib,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore/libecore\.la,-lecore,'\
+ ${BUILD_WRKSRC}/Makefile.in
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/ecore-file.pc \
+ ${PREFIX}/libdata/pkgconfig/
+
+.include <bsd.port.post.mk>
diff --git a/devel/ecore-file/distinfo b/devel/ecore-file/distinfo
new file mode 100644
index 000000000000..4672f6a1c167
--- /dev/null
+++ b/devel/ecore-file/distinfo
@@ -0,0 +1,3 @@
+MD5 (ecore-0.9.9.042.tar.bz2) = a66df2b5f0b1a6abc47bb50bf2b26846
+SHA256 (ecore-0.9.9.042.tar.bz2) = 26486fd2c80e4000b673f81ce637aa50c17c767e4c2af8f56de5d110e387d136
+SIZE (ecore-0.9.9.042.tar.bz2) = 5285732
diff --git a/devel/ecore-file/pkg-descr b/devel/ecore-file/pkg-descr
new file mode 100644
index 000000000000..2559668d0e57
--- /dev/null
+++ b/devel/ecore-file/pkg-descr
@@ -0,0 +1,5 @@
+A core event abstracter layer and X abstraction layer that makes doing
+selections, Xdnd, general X stuff, and event loops, timeouts and idle handlers
+fast, optimised, and convenient.
+
+WWW: http://enlightenment.sourceforge.net/Libraries/Ecore/
diff --git a/devel/ecore-file/pkg-plist b/devel/ecore-file/pkg-plist
new file mode 100644
index 000000000000..f007fefe0c41
--- /dev/null
+++ b/devel/ecore-file/pkg-plist
@@ -0,0 +1,6 @@
+include/Ecore_File.h
+lib/libecore_file.a
+lib/libecore_file.la
+lib/libecore_file.so
+lib/libecore_file.so.9
+libdata/pkgconfig/ecore-file.pc
diff --git a/devel/ecore-ipc/Makefile b/devel/ecore-ipc/Makefile
new file mode 100644
index 000000000000..6a7b38940724
--- /dev/null
+++ b/devel/ecore-ipc/Makefile
@@ -0,0 +1,66 @@
+# New ports collection makefile for: ecore-ipc
+# Date created: 17 September 2007
+# Whom: Stanislav Sedov <stas@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ipc
+PORTVERSION= 0.9.9.042
+PORTREVISION= 0
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
+ http://download.enlightenment.org/snapshots/2008-01-25/
+PKGNAMEPREFIX= ecore-
+DISTNAME= ecore-${PORTVERSION}
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= Enlightenment core abstraction library (ipc module)
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GNOME= gnomehack pkgconfig gnometarget
+USE_LDCONFIG= yes
+USE_GETOPT_LONG=yes
+USE_EFL= ecore
+USE_EFL_ECORE= con
+BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_ipc
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+CONFIGURE_ARGS= --enable-ecore-con \
+ --disable-ecore-config \
+ --disable-ecore-desktop \
+ --disable-ecore-directfb \
+ --disable-ecore-evas \
+ --disable-ecore-file \
+ --enable-ecore-ipc \
+ --disable-ecore-job \
+ --disable-ecore-sdl \
+ --disable-ecore-txt \
+ --disable-ecore-x \
+ --disable-ecore-imf \
+ --disable-ecore-imf_evas
+
+OPTIONS= SSL "Enable SSL support" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_SSL)
+CONFIGURE_ARGS+= --enable-openssl
+.else
+CONFIGURE_ARGS+= --disable-openssl
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's,\$$\(top_builddir\)/src/lib/ecore/\.libs,${LOCALBASE}/lib,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore_con/\.libs,${LOCALBASE}/lib,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore/libecore\.la,-lecore,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore_con/libecore_con\.la,-lecore_con,'\
+ ${BUILD_WRKSRC}/Makefile.in
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/ecore-ipc.pc \
+ ${PREFIX}/libdata/pkgconfig/
+
+.include <bsd.port.post.mk>
diff --git a/devel/ecore-ipc/distinfo b/devel/ecore-ipc/distinfo
new file mode 100644
index 000000000000..4672f6a1c167
--- /dev/null
+++ b/devel/ecore-ipc/distinfo
@@ -0,0 +1,3 @@
+MD5 (ecore-0.9.9.042.tar.bz2) = a66df2b5f0b1a6abc47bb50bf2b26846
+SHA256 (ecore-0.9.9.042.tar.bz2) = 26486fd2c80e4000b673f81ce637aa50c17c767e4c2af8f56de5d110e387d136
+SIZE (ecore-0.9.9.042.tar.bz2) = 5285732
diff --git a/devel/ecore-ipc/files/patch-configure b/devel/ecore-ipc/files/patch-configure
new file mode 100644
index 000000000000..aa36db02c97f
--- /dev/null
+++ b/devel/ecore-ipc/files/patch-configure
@@ -0,0 +1,94 @@
+--- configure.orig 2008-02-23 19:32:59.000000000 +0300
++++ configure 2008-02-23 19:33:33.000000000 +0300
+@@ -20543,83 +20543,6 @@
+ if test "${enable_openssl+set}" = set; then
+ enableval=$enable_openssl; want_openssl=$enableval
+
+-fi
+-
+-
+-if test "x$want_openssl" = "xyes"; then
+-
+-pkg_failed=no
+-{ echo "$as_me:$LINENO: checking for SSL" >&5
+-echo $ECHO_N "checking for SSL... $ECHO_C" >&6; }
+-
+-if test -n "$PKG_CONFIG"; then
+- if test -n "$SSL_CFLAGS"; then
+- pkg_cv_SSL_CFLAGS="$SSL_CFLAGS"
+- else
+- if test -n "$PKG_CONFIG" && \
+- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"openssl\"") >&5
+- ($PKG_CONFIG --exists --print-errors "openssl") 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; then
+- pkg_cv_SSL_CFLAGS=`$PKG_CONFIG --cflags "openssl" 2>/dev/null`
+-else
+- pkg_failed=yes
+-fi
+- fi
+-else
+- pkg_failed=untried
+-fi
+-if test -n "$PKG_CONFIG"; then
+- if test -n "$SSL_LIBS"; then
+- pkg_cv_SSL_LIBS="$SSL_LIBS"
+- else
+- if test -n "$PKG_CONFIG" && \
+- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"openssl\"") >&5
+- ($PKG_CONFIG --exists --print-errors "openssl") 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; then
+- pkg_cv_SSL_LIBS=`$PKG_CONFIG --libs "openssl" 2>/dev/null`
+-else
+- pkg_failed=yes
+-fi
+- fi
+-else
+- pkg_failed=untried
+-fi
+-
+-
+-
+-if test $pkg_failed = yes; then
+-
+-if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
+- _pkg_short_errors_supported=yes
+-else
+- _pkg_short_errors_supported=no
+-fi
+- if test $_pkg_short_errors_supported = yes; then
+- SSL_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "openssl"`
+- else
+- SSL_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "openssl"`
+- fi
+- # Put the nasty error message in config.log where it belongs
+- echo "$SSL_PKG_ERRORS" >&5
+-
+- { echo "$as_me:$LINENO: result: no" >&5
+-echo "${ECHO_T}no" >&6; }
+- have_openssl="no"
+-
+-elif test $pkg_failed = untried; then
+- have_openssl="no"
+-
+-else
+- SSL_CFLAGS=$pkg_cv_SSL_CFLAGS
+- SSL_LIBS=$pkg_cv_SSL_LIBS
+- { echo "$as_me:$LINENO: result: yes" >&5
+-echo "${ECHO_T}yes" >&6; }
+-
+-
+ cat >>confdefs.h <<\_ACEOF
+ #define USE_OPENSSL 1
+ _ACEOF
+@@ -20630,7 +20553,6 @@
+ have_openssl="yes"
+
+ fi
+-fi
+
+ want_curl="yes"
+ have_curl="no"
diff --git a/devel/ecore-ipc/pkg-descr b/devel/ecore-ipc/pkg-descr
new file mode 100644
index 000000000000..2559668d0e57
--- /dev/null
+++ b/devel/ecore-ipc/pkg-descr
@@ -0,0 +1,5 @@
+A core event abstracter layer and X abstraction layer that makes doing
+selections, Xdnd, general X stuff, and event loops, timeouts and idle handlers
+fast, optimised, and convenient.
+
+WWW: http://enlightenment.sourceforge.net/Libraries/Ecore/
diff --git a/devel/ecore-ipc/pkg-plist b/devel/ecore-ipc/pkg-plist
new file mode 100644
index 000000000000..3607cfe8c6b6
--- /dev/null
+++ b/devel/ecore-ipc/pkg-plist
@@ -0,0 +1,6 @@
+include/Ecore_Ipc.h
+lib/libecore_ipc.a
+lib/libecore_ipc.la
+lib/libecore_ipc.so
+lib/libecore_ipc.so.9
+libdata/pkgconfig/ecore-ipc.pc
diff --git a/devel/ecore-job/Makefile b/devel/ecore-job/Makefile
new file mode 100644
index 000000000000..411ad40bab16
--- /dev/null
+++ b/devel/ecore-job/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: ecore-job
+# Date created: 22 September 2007
+# Whom: Stanislav Sedov <stas@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= job
+PORTVERSION= 0.9.9.042
+PORTREVISION= 0
+CATEGORIES= converters
+MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
+ http://download.enlightenment.org/snapshots/2008-01-25/
+PKGNAMEPREFIX= ecore-
+DISTNAME= ecore-${PORTVERSION}
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= Enlightenment core abstraction library (job module)
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GNOME= gnomehack pkgconfig gnometarget
+USE_LDCONFIG= yes
+USE_GETOPT_LONG=yes
+USE_EFL= ecore
+BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_job
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+CONFIGURE_ARGS= --disable-ecore-con \
+ --disable-ecore-config \
+ --disable-ecore-desktop \
+ --disable-ecore-directfb \
+ --disable-ecore-evas \
+ --disable-ecore-file \
+ --disable-ecore-ipc \
+ --enable-ecore-job \
+ --disable-ecore-sdl \
+ --disable-ecore-txt \
+ --disable-ecore-x \
+ --disable-ecore-imf \
+ --disable-ecore-imf_evas
+
+post-patch:
+ @${REINPLACE_CMD} -E -e \
+ 's,\$$\(top_builddir\)/src/lib/ecore/\.libs,${LOCALBASE}/lib,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore/libecore\.la,-lecore,'\
+ ${BUILD_WRKSRC}/Makefile.in
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/ecore-job.pc \
+ ${PREFIX}/libdata/pkgconfig/
+
+.include <bsd.port.mk>
diff --git a/devel/ecore-job/distinfo b/devel/ecore-job/distinfo
new file mode 100644
index 000000000000..4672f6a1c167
--- /dev/null
+++ b/devel/ecore-job/distinfo
@@ -0,0 +1,3 @@
+MD5 (ecore-0.9.9.042.tar.bz2) = a66df2b5f0b1a6abc47bb50bf2b26846
+SHA256 (ecore-0.9.9.042.tar.bz2) = 26486fd2c80e4000b673f81ce637aa50c17c767e4c2af8f56de5d110e387d136
+SIZE (ecore-0.9.9.042.tar.bz2) = 5285732
diff --git a/devel/ecore-job/pkg-descr b/devel/ecore-job/pkg-descr
new file mode 100644
index 000000000000..2559668d0e57
--- /dev/null
+++ b/devel/ecore-job/pkg-descr
@@ -0,0 +1,5 @@
+A core event abstracter layer and X abstraction layer that makes doing
+selections, Xdnd, general X stuff, and event loops, timeouts and idle handlers
+fast, optimised, and convenient.
+
+WWW: http://enlightenment.sourceforge.net/Libraries/Ecore/
diff --git a/devel/ecore-job/pkg-plist b/devel/ecore-job/pkg-plist
new file mode 100644
index 000000000000..cd3bec0a6ca3
--- /dev/null
+++ b/devel/ecore-job/pkg-plist
@@ -0,0 +1,6 @@
+include/Ecore_Job.h
+lib/libecore_job.a
+lib/libecore_job.la
+lib/libecore_job.so
+lib/libecore_job.so.9
+libdata/pkgconfig/ecore-job.pc
diff --git a/devel/ecore-main/Makefile b/devel/ecore-main/Makefile
new file mode 100644
index 000000000000..97cfb70b112a
--- /dev/null
+++ b/devel/ecore-main/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: ecore-main
+# Date created: 17 September 2007
+# Whom: Stanislav Sedov <stas@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= main
+PORTVERSION= 0.9.9.042
+PORTREVISION= 0
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
+ http://download.enlightenment.org/snapshots/2008-01-25/
+PKGNAMEPREFIX= ecore-
+DISTNAME= ecore-${PORTVERSION}
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= Enlightenment core abstraction library (main library)
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GNOME= gnomehack pkgconfig gnometarget
+USE_LDCONFIG= yes
+USE_GETOPT_LONG=yes
+
+CONFIGURE_ARGS= --disable-ecore-con \
+ --disable-ecore-config \
+ --disable-ecore-desktop \
+ --disable-ecore-directfb \
+ --disable-ecore-evas \
+ --disable-ecore-file \
+ --disable-ecore-ipc \
+ --disable-ecore-job \
+ --disable-ecore-sdl \
+ --disable-ecore-txt \
+ --disable-ecore-x \
+ --disable-ecore-imf \
+ --disable-ecore-imf_evas
+
+.include <bsd.port.mk>
diff --git a/devel/ecore-main/distinfo b/devel/ecore-main/distinfo
new file mode 100644
index 000000000000..4672f6a1c167
--- /dev/null
+++ b/devel/ecore-main/distinfo
@@ -0,0 +1,3 @@
+MD5 (ecore-0.9.9.042.tar.bz2) = a66df2b5f0b1a6abc47bb50bf2b26846
+SHA256 (ecore-0.9.9.042.tar.bz2) = 26486fd2c80e4000b673f81ce637aa50c17c767e4c2af8f56de5d110e387d136
+SIZE (ecore-0.9.9.042.tar.bz2) = 5285732
diff --git a/devel/ecore-main/pkg-descr b/devel/ecore-main/pkg-descr
new file mode 100644
index 000000000000..2559668d0e57
--- /dev/null
+++ b/devel/ecore-main/pkg-descr
@@ -0,0 +1,5 @@
+A core event abstracter layer and X abstraction layer that makes doing
+selections, Xdnd, general X stuff, and event loops, timeouts and idle handlers
+fast, optimised, and convenient.
+
+WWW: http://enlightenment.sourceforge.net/Libraries/Ecore/
diff --git a/devel/ecore-main/pkg-plist b/devel/ecore-main/pkg-plist
new file mode 100644
index 000000000000..69033dfea741
--- /dev/null
+++ b/devel/ecore-main/pkg-plist
@@ -0,0 +1,8 @@
+include/Ecore.h
+include/Ecore_Data.h
+include/Ecore_Str.h
+lib/libecore.a
+lib/libecore.la
+lib/libecore.so
+lib/libecore.so.9
+libdata/pkgconfig/ecore.pc
diff --git a/devel/ecore/Makefile b/devel/ecore/Makefile
new file mode 100644
index 000000000000..1b5dbf9e204d
--- /dev/null
+++ b/devel/ecore/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: ecore
+# Date created: 22 September 2007
+# Whom: Stanislav Sedov <stas@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ecore
+PORTVERSION= 0.9.9.042
+PORTREVISION= 0
+PORTEPOCH= 2
+CATEGORIES= devel
+MASTER_SITES= # none
+DISTFILES= # none
+EXTRACT_ONLY= # none
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= Enlightenment core abstraction library (meta port)
+
+NO_BUILD= yes
+USE_EFL= ecore
+
+ECORE_MODULES= con config desktop evas file ipc job sdl txt x11 imf imf_evas
+ECORE_sdl_off= yes
+
+.for NODE in ${ECORE_MODULES}
+OPTIONS+= ${NODE:U} "Install ${NODE} ecore module"
+. if !defined(ECORE_${NODE}_off)
+OPTIONS+= on
+. else
+OPTIONS+= off
+. endif
+.endfor
+
+.include <bsd.port.pre.mk>
+
+.for NODE in ${ECORE_MODULES}
+. if !defined(ECORE_${NODE}_off)
+. if !defined(WITHOUT_${NODE:U})
+USE_EFL_ECORE+= ${NODE}
+. endif
+. else
+. if defined(WITH_${NODE:U})
+USE_EFL_ECORE+= ${NODE}
+. endif
+. endif
+.endfor
+
+do-install:
+ ${DO_NADA}
+
+.include <bsd.port.post.mk>
diff --git a/devel/ecore/pkg-descr b/devel/ecore/pkg-descr
new file mode 100644
index 000000000000..2559668d0e57
--- /dev/null
+++ b/devel/ecore/pkg-descr
@@ -0,0 +1,5 @@
+A core event abstracter layer and X abstraction layer that makes doing
+selections, Xdnd, general X stuff, and event loops, timeouts and idle handlers
+fast, optimised, and convenient.
+
+WWW: http://enlightenment.sourceforge.net/Libraries/Ecore/
diff --git a/devel/eet/Makefile b/devel/eet/Makefile
index cc99460ad506..2a5f2be3030b 100644
--- a/devel/eet/Makefile
+++ b/devel/eet/Makefile
@@ -6,11 +6,12 @@
#
PORTNAME= eet
-PORTVERSION= 20070223
+PORTVERSION= 0.9.10.042
PORTREVISION= 0
-PORTEPOCH= 1
+PORTEPOCH= 2
CATEGORIES= devel
-MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/
+MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
+ http://download.enlightenment.org/snapshots/2008-01-25/
MAINTAINER= stas@FreeBSD.org
COMMENT= Enlightenment Data Handling Library
diff --git a/devel/eet/distinfo b/devel/eet/distinfo
index 2f2d36f810e4..d76b0f17d26a 100644
--- a/devel/eet/distinfo
+++ b/devel/eet/distinfo
@@ -1,3 +1,3 @@
-MD5 (eet-20070223.tar.bz2) = c8c83f8704d9caea8604456c1e154d0c
-SHA256 (eet-20070223.tar.bz2) = 6b3da808d3a3b9858fa196bd46d8e035f9ea965fb68c02436ca711e160621bf9
-SIZE (eet-20070223.tar.bz2) = 1279064
+MD5 (eet-0.9.10.042.tar.bz2) = af0f46c29dcdc4725f4de491b7350bbb
+SHA256 (eet-0.9.10.042.tar.bz2) = c96643666ca8c70c71884affc4f3dc8b4cdb7c745d5f2a9c9366ad76aac8a38a
+SIZE (eet-0.9.10.042.tar.bz2) = 1497375
diff --git a/devel/eet/pkg-plist b/devel/eet/pkg-plist
index 4f3b2a864ec0..b5e86bdaeaf9 100644
--- a/devel/eet/pkg-plist
+++ b/devel/eet/pkg-plist
@@ -1,4 +1,4 @@
-bin/eet-config
+bin/eet
include/Eet.h
lib/libeet.a
lib/libeet.la
diff --git a/devel/engrave/Makefile b/devel/engrave/Makefile
index a7a1a0ab708a..83a3f90d4415 100644
--- a/devel/engrave/Makefile
+++ b/devel/engrave/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= engrave
-PORTVERSION= 20070223
-PORTREVISION= 1
+PORTVERSION= 20080223
+PORTREVISION= 0
CATEGORIES= devel
MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/
@@ -18,6 +18,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnometarget pkgconfig gnomehack
USE_EFL= ecore evas
+USE_EFL_ECORE= evas
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/devel/engrave/distinfo b/devel/engrave/distinfo
index 8272f9d6c19f..9e7d6f81dddf 100644
--- a/devel/engrave/distinfo
+++ b/devel/engrave/distinfo
@@ -1,3 +1,3 @@
-MD5 (engrave-20070223.tar.bz2) = a447eb6fe13f68c3f0300390fa3bf255
-SHA256 (engrave-20070223.tar.bz2) = 1d7c1e3daec69e7ff449b38e0f9d04fa0a0112056bf94828b0f69788735c0c9f
-SIZE (engrave-20070223.tar.bz2) = 252725
+MD5 (engrave-20080223.tar.bz2) = 643ef3b7be302f07abb7b87060c7837f
+SHA256 (engrave-20080223.tar.bz2) = c126f3128a53dd9aa152e2364d6ce220f14742fa2f0902b0c4debe3633ac4c2f
+SIZE (engrave-20080223.tar.bz2) = 485659
diff --git a/devel/engrave/pkg-plist b/devel/engrave/pkg-plist
index 9f8ba905f3ec..578e0298bb68 100644
--- a/devel/engrave/pkg-plist
+++ b/devel/engrave/pkg-plist
@@ -1,8 +1,8 @@
-bin/engrave-config
bin/engrave_canvas_test
bin/engrave_test
include/engrave/Engrave.h
include/engrave/engrave_canvas.h
+include/engrave/engrave_color_class.h
include/engrave/engrave_data.h
include/engrave/engrave_enums.h
include/engrave/engrave_file.h
@@ -22,4 +22,5 @@ lib/libengrave.a
lib/libengrave.la
lib/libengrave.so
lib/libengrave.so.1
+libdata/pkgconfig/engrave.pc
@dirrm include/engrave
diff --git a/devel/evfs/Makefile b/devel/evfs/Makefile
index 8ab9a8a88470..5c8e976cff98 100644
--- a/devel/evfs/Makefile
+++ b/devel/evfs/Makefile
@@ -7,8 +7,8 @@
#
PORTNAME= evfs
-PORTVERSION= 20070223
-PORTREVISION= 1
+PORTVERSION= 20080223
+PORTREVISION= 0
CATEGORIES= devel
MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/
@@ -19,7 +19,8 @@ GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomehack pkgconfig gnometarget libxml2
-USE_EFL= ecore eet
+USE_EFL= ecore eet efreet evas
+USE_EFL_ECORE= desktop ipc
USE_LDCONFIG= yes
USE_SQLITE= 3
diff --git a/devel/evfs/distinfo b/devel/evfs/distinfo
index 4faf956f1961..3a0e4cfc32d3 100644
--- a/devel/evfs/distinfo
+++ b/devel/evfs/distinfo
@@ -1,3 +1,3 @@
-MD5 (evfs-20070223.tar.bz2) = 3e8435d41ce695b709260bc949fae5f4
-SHA256 (evfs-20070223.tar.bz2) = d7bdabebcdf67d346df26d7ed38cf104fe3cd933eb3a4b418f261f676ee04518
-SIZE (evfs-20070223.tar.bz2) = 305383
+MD5 (evfs-20080223.tar.bz2) = 17af54ac25c9911f429178fd81d098f3
+SHA256 (evfs-20080223.tar.bz2) = 1724b0b632dd56f7ca3aa4cb5606180fcd1a3a17e6a1e4be4fc6691c9d3ff958
+SIZE (evfs-20080223.tar.bz2) = 319214
diff --git a/devel/evfs/pkg-plist b/devel/evfs/pkg-plist
index 656ad17ebbd1..827b5366aaf8 100644
--- a/devel/evfs/pkg-plist
+++ b/devel/evfs/pkg-plist
@@ -1,9 +1,10 @@
bin/evfs
-bin/evfs-config
bin/evfscat
bin/evfscopy
bin/evfsdemo
+bin/evfsworker
include/evfs/evfs.h
+include/evfs/evfs_auth.h
include/evfs/evfs_cleanup.h
include/evfs/evfs_client.h
include/evfs/evfs_command.h
@@ -38,9 +39,6 @@ lib/evfs/plugins/file/gzip.so
lib/evfs/plugins/file/posix.a
lib/evfs/plugins/file/posix.la
lib/evfs/plugins/file/posix.so
-lib/evfs/plugins/file/trash.a
-lib/evfs/plugins/file/trash.la
-lib/evfs/plugins/file/trash.so
%%SAMBA%%lib/evfs/plugins/file/samba.a
%%SAMBA%%lib/evfs/plugins/file/samba.la
%%SAMBA%%lib/evfs/plugins/file/samba.so
@@ -50,28 +48,35 @@ lib/evfs/plugins/file/sftp.so
lib/evfs/plugins/file/tar.a
lib/evfs/plugins/file/tar.la
lib/evfs/plugins/file/tar.so
+lib/evfs/plugins/file/trash.a
+lib/evfs/plugins/file/trash.la
+lib/evfs/plugins/file/trash.so
lib/evfs/plugins/file/vfolder.a
lib/evfs/plugins/file/vfolder.la
lib/evfs/plugins/file/vfolder.so
-lib/evfs/plugins/vfolder/group.a
-lib/evfs/plugins/vfolder/group.la
-lib/evfs/plugins/vfolder/group.so
-lib/evfs/plugins/vfolder/trash.a
-lib/evfs/plugins/vfolder/trash.la
-lib/evfs/plugins/vfolder/trash.so
%%TAGLIB%%lib/evfs/plugins/meta/audio_tagger.a
%%TAGLIB%%lib/evfs/plugins/meta/audio_tagger.la
%%TAGLIB%%lib/evfs/plugins/meta/audio_tagger.so
%%XTRACT%%lib/evfs/plugins/meta/extractor_tagger.a
%%XTRACT%%lib/evfs/plugins/meta/extractor_tagger.la
%%XTRACT%%lib/evfs/plugins/meta/extractor_tagger.so
+lib/evfs/plugins/vfolder/efolder.a
+lib/evfs/plugins/vfolder/efolder.la
+lib/evfs/plugins/vfolder/efolder.so
+lib/evfs/plugins/vfolder/group.a
+lib/evfs/plugins/vfolder/group.la
+lib/evfs/plugins/vfolder/group.so
+lib/evfs/plugins/vfolder/trash.a
+lib/evfs/plugins/vfolder/trash.la
+lib/evfs/plugins/vfolder/trash.so
lib/libevfs.a
lib/libevfs.la
lib/libevfs.so
lib/libevfs.so.0
+libdata/pkgconfig/evfs.pc
+@dirrm lib/evfs/plugins/vfolder
@dirrm lib/evfs/plugins/meta
@dirrm lib/evfs/plugins/file
-@dirrm lib/evfs/plugins/vfolder
@dirrm lib/evfs/plugins
@dirrm lib/evfs
@dirrm include/evfs
diff --git a/devel/libast/Makefile b/devel/libast/Makefile
index 0572b10f6994..ff0bb7b318c3 100644
--- a/devel/libast/Makefile
+++ b/devel/libast/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libast
PORTVERSION= 0.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= http://critical.ch/distfiles/ \
http://www.eterm.org/download/
@@ -15,12 +15,12 @@ MASTER_SITES= http://critical.ch/distfiles/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= A library of assorted spiffy things
-LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
- Imlib2.4:${PORTSDIR}/graphics/imlib2
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
USE_AUTOTOOLS= libtool:15
USE_X_PREFIX= yes
USE_GNOME= gnomehack
+USE_EFL= imlib2
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/devel/ruby-ecore/Makefile b/devel/ruby-ecore/Makefile
index 46d3a98781ae..95ed9dc5d393 100644
--- a/devel/ruby-ecore/Makefile
+++ b/devel/ruby-ecore/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= ecore
-PORTVERSION= 20061008
-PORTREVISION= 1
+PORTVERSION= 20080302
+PORTREVISION= 0
CATEGORIES= devel ruby
-MASTER_SITES= http://sunner.elcomnet.ru/~stas/
+MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ruby-ecore-${PORTVERSION}
@@ -22,14 +22,12 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/rake:${PORTSDIR}/devel/rubygem-rake \
USE_BZIP2= yes
USE_RUBY= yes
USE_EFL= ecore
+USE_EFL_ECORE= x11 con job evas
RUBY_SA= ${RUBY_SITEARCHLIBDIR}
.include <bsd.port.pre.mk>
-post-patch:
- @${REINPLACE_CMD} "s#%%X11BASE%%#${X11BASE}#g" ${WRKSRC}/Rakefile
-
do-build:
@(cd ${WRKSRC}; ${SETENV} ECORE_PREFIX=${LOCALBASE} \
${LOCALBASE}/bin/rake)
diff --git a/devel/ruby-ecore/distinfo b/devel/ruby-ecore/distinfo
index 66380ad14d36..9b72a2f4a6bb 100644
--- a/devel/ruby-ecore/distinfo
+++ b/devel/ruby-ecore/distinfo
@@ -1,3 +1,3 @@
-MD5 (ruby-ecore-20061008.tar.bz2) = a54661c6c9ff982a80f231fb5456fa37
-SHA256 (ruby-ecore-20061008.tar.bz2) = de3477d05c25cba51345b8dca9564e751262452cd9fe775fc9b0583336d8e24b
-SIZE (ruby-ecore-20061008.tar.bz2) = 24053
+MD5 (ruby-ecore-20080302.tar.bz2) = 7df2d66a2140ab18455ce0f1467db265
+SHA256 (ruby-ecore-20080302.tar.bz2) = 6a04b4fb31fd81481319be9a7f583fb64cb252b3471501d96f7d79bb973cc3e9
+SIZE (ruby-ecore-20080302.tar.bz2) = 27641
diff --git a/devel/ruby-ecore/files/patch-Rakefile b/devel/ruby-ecore/files/patch-Rakefile
deleted file mode 100644
index d5c309404789..000000000000
--- a/devel/ruby-ecore/files/patch-Rakefile
+++ /dev/null
@@ -1,17 +0,0 @@
---- Rakefile.orig Sun Oct 8 11:05:35 2006
-+++ Rakefile Sun Oct 8 11:06:20 2006
-@@ -18,12 +18,12 @@
-
- ext_libs.each do |lib|
- file lib.so => lib.objects do |t|
-- sh "cc #{lib.ldflags} #{t.prerequisites.join(" ")} -o #{t.name}"
-+ sh "cc -L%%X11BASE%%/lib #{lib.ldflags} #{t.prerequisites.join(" ")} -o #{t.name}"
- end
-
- lib.objects.each do |object|
- file object => object.sub(/\.[^.]+$/, ".c") do |t|
-- sh "cc #{lib.cflags} #{t.prerequisites.first} " +
-+ sh "cc -I%%X11BASE%%/include #{lib.cflags} #{t.prerequisites.first} " +
- "-c -o #{t.name}"
- end
- end