aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/cl-alexandria-sbcl/Makefile24
-rw-r--r--devel/cl-alexandria-sbcl/pkg-descr9
-rw-r--r--devel/cl-alexandria-sbcl/pkg-plist18
4 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ea4403cd0e1c..3b261a3929af 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -167,6 +167,7 @@
SUBDIR += cil
SUBDIR += cl-alexandria
SUBDIR += cl-alexandria-clisp
+ SUBDIR += cl-alexandria-sbcl
SUBDIR += cl-asdf
SUBDIR += cl-asdf-clisp
SUBDIR += cl-infix
diff --git a/devel/cl-alexandria-sbcl/Makefile b/devel/cl-alexandria-sbcl/Makefile
new file mode 100644
index 000000000000..fae2c5df649e
--- /dev/null
+++ b/devel/cl-alexandria-sbcl/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: cl-alexandria-sbcl
+# Date created: 16 January 2010
+# Whom: Jimmy Olgeni <olgeni@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= alexandria
+PORTVERSION= 2010.01.16
+CATEGORIES= devel lisp
+PKGNAMEPREFIX= cl-
+DISTFILES= # none
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= A collection of portable public domain utilities for Common Lisp
+
+BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/alexandria/alexandria.asd:${PORTSDIR}/devel/cl-alexandria
+RUN_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/alexandria/alexandria.asd:${PORTSDIR}/devel/cl-alexandria
+
+USE_ASDF_FASL= yes
+FASL_TARGET= sbcl
+FASL_BUILD= yes
+
+.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
+.include <bsd.port.mk>
diff --git a/devel/cl-alexandria-sbcl/pkg-descr b/devel/cl-alexandria-sbcl/pkg-descr
new file mode 100644
index 000000000000..5403f671acbd
--- /dev/null
+++ b/devel/cl-alexandria-sbcl/pkg-descr
@@ -0,0 +1,9 @@
+As a project Alexandria's goal is to reduce duplication of effort
+and improve portability of Common Lisp code according to its own
+idiosyncratic and rather conservative aesthetic. What this actually
+means is open to debate, but each project member has a veto on all
+project activities, so a degree of conservativism is inevitable.
+
+This package is compiled with SBCL.
+
+WWW: http://common-lisp.net/project/alexandria/
diff --git a/devel/cl-alexandria-sbcl/pkg-plist b/devel/cl-alexandria-sbcl/pkg-plist
new file mode 100644
index 000000000000..bc7fb0db0a1f
--- /dev/null
+++ b/devel/cl-alexandria-sbcl/pkg-plist
@@ -0,0 +1,18 @@
+%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/arrays.fasl
+%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/binding.fasl
+%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/conditions.fasl
+%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/control-flow.fasl
+%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/definitions.fasl
+%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/features.fasl
+%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/functions.fasl
+%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/hash-tables.fasl
+%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/io.fasl
+%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/lists.fasl
+%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/macros.fasl
+%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/numbers.fasl
+%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/package.fasl
+%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/sequences.fasl
+%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/strings.fasl
+%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/symbols.fasl
+%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/types.fasl
+@dirrm %%LIB32DIR%%/common-lisp/alexandria/sbclfasl