aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/cxxtools/Makefile4
-rw-r--r--devel/giggle/Makefile8
-rw-r--r--devel/ice/Makefile4
-rw-r--r--devel/ioncube/Makefile3
-rw-r--r--devel/lasi/Makefile8
-rw-r--r--devel/libbobcat/Makefile8
-rw-r--r--devel/libdsp/Makefile4
-rw-r--r--devel/libdwarf/Makefile8
-rw-r--r--devel/libgsf/Makefile10
-rw-r--r--devel/libiqxmlrpc/Makefile8
-rw-r--r--devel/libopkele/Makefile3
-rw-r--r--devel/libpthread-stubs/Makefile8
-rw-r--r--devel/linux-js/Makefile2
-rw-r--r--devel/linux-kmod-compat/Makefile8
-rw-r--r--devel/llvm-etoile/Makefile4
-rw-r--r--devel/pecl-gearman/Makefile8
-rw-r--r--devel/py-freebsd/Makefile3
-rw-r--r--devel/py-freebsd/files/freebsd7_patch-src-netstat.c10
-rw-r--r--devel/py-ncurses/Makefile2
-rw-r--r--devel/rsvndump/Makefile4
-rw-r--r--devel/subcommander2/Makefile8
-rw-r--r--devel/uppaal/Makefile4
-rw-r--r--devel/ustl/Makefile3
23 files changed, 14 insertions, 118 deletions
diff --git a/devel/cxxtools/Makefile b/devel/cxxtools/Makefile
index 08660fec2851..c7067e0b19ec 100644
--- a/devel/cxxtools/Makefile
+++ b/devel/cxxtools/Makefile
@@ -24,10 +24,6 @@ MAKE_JOBS_SAFE= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700042
-LIB_DEPENDS+= boost_thread:${PORTSDIR}/devel/boost-libs
-.endif
-
.if ${ARCH} == "sparc64"
BROKEN= Does not configure on sparc64
.endif
diff --git a/devel/giggle/Makefile b/devel/giggle/Makefile
index bdc7531056ac..573fb6590da8 100644
--- a/devel/giggle/Makefile
+++ b/devel/giggle/Makefile
@@ -47,13 +47,7 @@ CONFIGURE_ARGS+= --disable-terminal
PLIST_SUB+= VTE="@comment "
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-BROKEN= does not build
-.endif
-
post-install:
@-update-desktop-database
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/ice/Makefile b/devel/ice/Makefile
index 6f2ccf345b8c..d6616f9e0ec0 100644
--- a/devel/ice/Makefile
+++ b/devel/ice/Makefile
@@ -68,9 +68,5 @@ post-patch:
${WRKSRC}/cpp/src/ca/Makefile
${REINPLACE_CMD} '/LICENSE/s/prefix/install_slicedir/' \
${WRKSRC}/config/Make.common.rules
-.if ${OSVERSION} < 700000
- ${REINPLACE_CMD} 's|__APPLE__|__FreeBSD__|' \
- ${WRKSRC}/cpp/src/IceUtil/Cond.cpp
-.endif
.include <bsd.port.post.mk>
diff --git a/devel/ioncube/Makefile b/devel/ioncube/Makefile
index 3a925df373ea..ed9eb33a4b1f 100644
--- a/devel/ioncube/Makefile
+++ b/devel/ioncube/Makefile
@@ -28,8 +28,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
# Detect OS Version
.if ${OSVERSION} >= 800000
VER= 8
-.endif
-.if (${OSVERSION} >= 700000 && ${OSVERSION} < 800000)
+.else
VER= 7
.endif
diff --git a/devel/lasi/Makefile b/devel/lasi/Makefile
index a481e50a454c..fa613065769d 100644
--- a/devel/lasi/Makefile
+++ b/devel/lasi/Makefile
@@ -33,12 +33,6 @@ BUILD_DEPENDS+= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-cmake+modules+lasi.cmake
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-BROKEN= does not compile on 6.X
-.endif
-
pre-install:
.if defined(NOPORTEXAMPLES)
@${REINPLACE_CMD} 's/^\(add_subdirectory(examples)\)/#\1/' ${WRKSRC}/CMakeLists.txt
@@ -61,4 +55,4 @@ post-install:
.endif
@${TEST} -d ${DATADIR} && ${RMDIR} ${DATADIR} || ${TRUE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/libbobcat/Makefile b/devel/libbobcat/Makefile
index 9173df5ca384..09025e02e1bb 100644
--- a/devel/libbobcat/Makefile
+++ b/devel/libbobcat/Makefile
@@ -60,12 +60,6 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}"
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/bobcat-${PORTVERSION}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-BUILD_DEPENDS+= openssl>=0.9.8:${PORTSDIR}/security/openssl
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|"/usr"|"${PREFIX}"| ; \
s|"/share/doc/libbobcat2"|"/share/doc/${PORTNAME}-${PORTVERSION}"| ; \
@@ -96,4 +90,4 @@ do-build:
do-install:
@cd ${WRKSRC} && ./build install
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/libdsp/Makefile b/devel/libdsp/Makefile
index 7c327bd34884..e0f43d37313e 100644
--- a/devel/libdsp/Makefile
+++ b/devel/libdsp/Makefile
@@ -35,8 +35,4 @@ do-configure:
CFLAGS+= -DDSP_X86
.endif
-.if ${OSVERSION} < 700000
-BROKEN= Unable to build
-.endif
-
.include <bsd.port.post.mk>
diff --git a/devel/libdwarf/Makefile b/devel/libdwarf/Makefile
index b426d20c9d89..50860201c43d 100644
--- a/devel/libdwarf/Makefile
+++ b/devel/libdwarf/Makefile
@@ -16,12 +16,6 @@ COMMENT= A library to analyze DWARF debugging information in ELF files
INSTALL_CONFLICT= bsdlibdwarf*
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libelf.so.0:${PORTSDIR}/devel/libelf
-.endif
-
WRKSRC= ${WRKDIR}/dwarf-${PORTVERSION}/libdwarf
GNU_CONFIGURE= yes
@@ -41,4 +35,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/$$f ${PREFIX}/share/doc/libdwarf ; \
done
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/libgsf/Makefile b/devel/libgsf/Makefile
index 9bef7963aa5a..51a54afb68ad 100644
--- a/devel/libgsf/Makefile
+++ b/devel/libgsf/Makefile
@@ -45,12 +45,4 @@ GCONF_SCHEMAS= gsf-office-thumbnailer.schemas
PLIST_SUB+= THUMB="@comment "
.endif
-.include <bsd.port.pre.mk>
-
-.if defined(GSF_SLAVE)
-.if ${OSVERSION} < 700000
-BROKEN= does not configure on 6.X
-.endif
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/libiqxmlrpc/Makefile b/devel/libiqxmlrpc/Makefile
index f6c7e9e90b69..3d6506a92cd6 100644
--- a/devel/libiqxmlrpc/Makefile
+++ b/devel/libiqxmlrpc/Makefile
@@ -20,14 +20,8 @@ LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs\
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
-.endif
-
post-patch:
@${REINPLACE_CMD} 's,libxml++-1.0,libxml++-2.6,g' ${WRKSRC}/configure
@${REINPLACE_CMD} 's,{libdir}/pkgconfig,{prefix}/libdata/pkgconfig,' ${WRKSRC}/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/libopkele/Makefile b/devel/libopkele/Makefile
index e4d7ea0037b9..515ed128da80 100644
--- a/devel/libopkele/Makefile
+++ b/devel/libopkele/Makefile
@@ -35,9 +35,6 @@ LDFLAGS+= -L${LOCALBASE}/lib
# This port needs OpenSSL 0.9.8b which is present in 7.0 and up
USE_OPENSSL= yes
-.if ${OSVERSION} < 700000
-WITH_OPENSSL_PORT= yes
-.endif
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
# If we use the base OpenSSL either by default or
diff --git a/devel/libpthread-stubs/Makefile b/devel/libpthread-stubs/Makefile
index 6b5ed8d8a756..aa4eac192a08 100644
--- a/devel/libpthread-stubs/Makefile
+++ b/devel/libpthread-stubs/Makefile
@@ -22,10 +22,4 @@ WITH_FBSD10_FIX= yes
GNU_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-LDFLAGS+= -lpthread
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/linux-js/Makefile b/devel/linux-js/Makefile
index 6ef0646113cb..9850c63c45b8 100644
--- a/devel/linux-js/Makefile
+++ b/devel/linux-js/Makefile
@@ -51,10 +51,8 @@ MAKE_ENV+= WITHOUT_UHID=yes
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' ${WRKSRC}/linux_js.4
-.if ${OSVERSION} >= 700000
@${REINPLACE_CMD} -e 's|FILEDESC_UNLOCK|FILEDESC_SUNLOCK|' ${WRKSRC}/linux_js.c
@${REINPLACE_CMD} -e 's|FILEDESC_LOCK|FILEDESC_SLOCK|' ${WRKSRC}/linux_js.c
-.endif
post-install:
${MKDIR} ${PREFIX}/include/linux
diff --git a/devel/linux-kmod-compat/Makefile b/devel/linux-kmod-compat/Makefile
index c413f9bf2ed3..b12d7f35d4ca 100644
--- a/devel/linux-kmod-compat/Makefile
+++ b/devel/linux-kmod-compat/Makefile
@@ -16,12 +16,6 @@ COMMENT= Adaptation layer to build linux drivers on FreeBSD
WRKSRC= ${WRKDIR}/linux_compat
NO_BUILD= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 602100
-IGNORE= requires a recent USB stack, not present in ${OSVERSION}
-.endif
-
# Here is where install most things except the .mk file
MY_DST= ${DATADIR}/linux_compat
MY_MK= bsd.linux_kmod.mk
@@ -53,4 +47,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/llvm-etoile/Makefile b/devel/llvm-etoile/Makefile
index cb01d00c18df..a55fcac42fcb 100644
--- a/devel/llvm-etoile/Makefile
+++ b/devel/llvm-etoile/Makefile
@@ -52,9 +52,7 @@ SVN_REV!= svn info http://llvm.org/svn/llvm-project/ | ${GREP} Revision | cut -d
.include "Makefile.svn_rev"
.endif
-.if ${OSVERSION} < 700000 && ${ARCH} == "amd64"
-BROKEN= does not compile
-.elif ${ARCH} == "sparc64"
+.if ${ARCH} == "sparc64"
BROKEN= Does not compile on sparc64
.endif
diff --git a/devel/pecl-gearman/Makefile b/devel/pecl-gearman/Makefile
index 131d07fbddc3..ae5f0d310dc7 100644
--- a/devel/pecl-gearman/Makefile
+++ b/devel/pecl-gearman/Makefile
@@ -26,10 +26,4 @@ USE_PHP= yes
USE_PHPEXT= yes
IGNORE_WITH_PHP=4
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} <= 700000
-BROKEN= does not compile
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/py-freebsd/Makefile b/devel/py-freebsd/Makefile
index c7c9cc41a37e..86f52f6ebd64 100644
--- a/devel/py-freebsd/Makefile
+++ b/devel/py-freebsd/Makefile
@@ -29,9 +29,6 @@ PLIST_FILES= %%PYTHON_SITELIBDIR%%/freebsd.so \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700000
-EXTRA_PATCHES+= ${FILESDIR}/freebsd7_patch-src-netstat.c
-.endif
# Multi-IPv4/v6/no-IP jails.
.if ${OSVERSION} >= 800056 || \
(${OSVERSION} < 800000 && ${OSVERSION} >= 701103)
diff --git a/devel/py-freebsd/files/freebsd7_patch-src-netstat.c b/devel/py-freebsd/files/freebsd7_patch-src-netstat.c
deleted file mode 100644
index 11ae01cc4d6c..000000000000
--- a/devel/py-freebsd/files/freebsd7_patch-src-netstat.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/netstat.c.orig 2007-08-17 13:07:10.654911645 -0500
-+++ src/netstat.c 2007-08-17 13:07:19.496912514 -0500
-@@ -243,7 +243,6 @@
- Py_DECREF(t);
- p_int(type); p_int(physical);
- p_int(addrlen); p_int(hdrlen);
-- p_int(recvquota); p_int(xmitquota);
- p_long(mtu); p_long(metric);
- p_long(baudrate); p_long(ipackets);
- p_long(ierrors); p_long(opackets);
diff --git a/devel/py-ncurses/Makefile b/devel/py-ncurses/Makefile
index 55189a55f011..853949f2ccb9 100644
--- a/devel/py-ncurses/Makefile
+++ b/devel/py-ncurses/Makefile
@@ -27,7 +27,7 @@ post-patch:
@${REINPLACE_CMD} -e '45s,^.*$$,#include "py_curses.h",' \
${WRKSRC}/ncurses/${f}
.endfor
-.if ${OSVERSION} > 700033 || (${OSVERSION} < 700000)
+.if ${OSVERSION} > 700033
@${REINPLACE_CMD} -e '/^extern int define_key(/d' \
${WRKSRC}/ncurses/_curses_wrap.c
.endif
diff --git a/devel/rsvndump/Makefile b/devel/rsvndump/Makefile
index daf025a41ca4..671edea9e870 100644
--- a/devel/rsvndump/Makefile
+++ b/devel/rsvndump/Makefile
@@ -31,10 +31,6 @@ PLIST_FILES+= bin/rsvndump
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700041
-LDFLAGS+= ${PTHREAD_LIBS}
-.endif
-
.if !defined(NOPORTDOCS)
BUILD_DEPENDS+= asciidoc:${PORTSDIR}/textproc/asciidoc \
xmlto:${PORTSDIR}/textproc/xmlto
diff --git a/devel/subcommander2/Makefile b/devel/subcommander2/Makefile
index eb68530b3f1f..fd7961cc8ad3 100644
--- a/devel/subcommander2/Makefile
+++ b/devel/subcommander2/Makefile
@@ -44,10 +44,4 @@ LDFLAGS+= -L${LOCALBASE}/lib -L${LOCALBASE}/lib/qt4 ${PTHREAD_LIBS}
post-extract:
@${CHMOD} +x ${WRKSRC}/configure
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-BROKEN= Does not compile on 6.x
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/uppaal/Makefile b/devel/uppaal/Makefile
index 4e3de150a53d..b87a4f0ffac1 100644
--- a/devel/uppaal/Makefile
+++ b/devel/uppaal/Makefile
@@ -35,10 +35,6 @@ RESTRICTED= Downloading requires completion of a license agreement
LINUX_OSRELEASE!= ${ECHO_CMD} `${SYSCTL} -n compat.linux.osrelease 2>/dev/null`
-.if ${LINUX_OSRELEASE} == "2.4.2" || ${OSVERSION} < 700000
-IGNORE=requires compat.linux.osrelease of at least 2.6.16 (needs 7.0 or later)
-.endif
-
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
ECHO_MSG=/usr/bin/printf
IGNORE=Please download ${DISTNAME}${EXTRACT_SUFX} into\
diff --git a/devel/ustl/Makefile b/devel/ustl/Makefile
index 0caf2e7e2b05..a154e132333c 100644
--- a/devel/ustl/Makefile
+++ b/devel/ustl/Makefile
@@ -31,9 +31,8 @@ PLIST_FILES= lib/libustl.so lib/libustl.so.1 lib/libustl.so.1.0.0
.if ${ARCH} != "i386"
BROKEN= Does not compile on !i386
-.elif ${OSVERSION} >= 700000
-MANUAL_PACKAGE_BUILD= yes
.endif
+MANUAL_PACKAGE_BUILD= yes
post-patch:
@${REINPLACE_CMD} -e "s,/bin/bash,/bin/sh," ${WRKSRC}/configure