aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/allegro-devel/Makefile3
-rw-r--r--devel/clanlib/Makefile5
-rw-r--r--devel/clanlib1/Makefile5
-rw-r--r--devel/clanlib22/Makefile5
-rw-r--r--devel/dcmtk/Makefile5
-rw-r--r--devel/directfb/Makefile5
-rw-r--r--devel/efl/Makefile5
-rw-r--r--devel/kyra/Makefile5
-rw-r--r--devel/libclaw/Makefile5
-rw-r--r--devel/p5-SDL/Makefile3
-rw-r--r--devel/py-game_sdl2/Makefile5
-rw-r--r--devel/sfml/Makefile3
-rw-r--r--devel/sfml1/Makefile3
-rw-r--r--devel/simgear/Makefile5
-rw-r--r--devel/synfig/Makefile3
15 files changed, 25 insertions, 40 deletions
diff --git a/devel/allegro-devel/Makefile b/devel/allegro-devel/Makefile
index 4ccecc9ed6ea..f4acb6073ddb 100644
--- a/devel/allegro-devel/Makefile
+++ b/devel/allegro-devel/Makefile
@@ -19,12 +19,11 @@ LICENSE_COMB= dual
LIB_DEPENDS+= libjack.so:${PORTSDIR}/audio/jack \
libpng.so:${PORTSDIR}/graphics/png \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libvorbis.so:${PORTSDIR}/audio/libvorbis \
libFLAC.so:${PORTSDIR}/audio/flac \
libphysfs.so:${PORTSDIR}/devel/physfs
-USES= gmake cmake openal:soft pkgconfig
+USES= cmake gmake jpeg openal:soft pkgconfig
USE_XORG= x11 xpm xext xcursor xxf86vm xxf86dga
USE_GL= glu
USE_GNOME= gtk20
diff --git a/devel/clanlib/Makefile b/devel/clanlib/Makefile
index 66038443e554..c6311016dc98 100644
--- a/devel/clanlib/Makefile
+++ b/devel/clanlib/Makefile
@@ -14,14 +14,13 @@ COMMENT= Cross-platform game SDK
LICENSE= ZLIB
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng.so:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
libmikmod.so:${PORTSDIR}/audio/libmikmod \
libvorbis.so:${PORTSDIR}/audio/libvorbis \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
libpcre.so:${PORTSDIR}/devel/pcre
-USES= execinfo gmake libtool pathfix pkgconfig tar:tgz
+USES= execinfo gmake jpeg libtool pathfix pkgconfig tar:tgz
USE_GCC= yes
USE_XORG= x11
USE_LDCONFIG= yes
diff --git a/devel/clanlib1/Makefile b/devel/clanlib1/Makefile
index bfd4f5838458..f6ff00307a49 100644
--- a/devel/clanlib1/Makefile
+++ b/devel/clanlib1/Makefile
@@ -14,12 +14,11 @@ COMMENT= Cross-platform game SDK
LICENSE= ZLIB
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng.so:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
libmikmod.so:${PORTSDIR}/audio/libmikmod \
libvorbis.so:${PORTSDIR}/audio/libvorbis
-USES= gmake libtool pathfix pkgconfig tar:tgz
+USES= gmake jpeg libtool pathfix pkgconfig tar:tgz
USE_XORG= x11 xi
USE_LDCONFIG= yes
USE_SDL= gfx
diff --git a/devel/clanlib22/Makefile b/devel/clanlib22/Makefile
index 95159cdffc45..2cb4882a07a9 100644
--- a/devel/clanlib22/Makefile
+++ b/devel/clanlib22/Makefile
@@ -14,14 +14,13 @@ COMMENT= Cross-platform game SDK
LICENSE= ZLIB
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng.so:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
libmikmod.so:${PORTSDIR}/audio/libmikmod \
libvorbis.so:${PORTSDIR}/audio/libvorbis \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
libpcre.so:${PORTSDIR}/devel/pcre
-USES= gmake libtool pathfix pkgconfig tar:tgz
+USES= gmake jpeg libtool pathfix pkgconfig tar:tgz
USE_XORG= x11
USE_LDCONFIG= yes
USE_GL= yes
diff --git a/devel/dcmtk/Makefile b/devel/dcmtk/Makefile
index 4902f68b7b7b..de84388a4638 100644
--- a/devel/dcmtk/Makefile
+++ b/devel/dcmtk/Makefile
@@ -11,13 +11,12 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Toolkit to work with DICOM objects
LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
- libpng.so:${PORTSDIR}/graphics/png \
- libjpeg.so:${PORTSDIR}/graphics/jpeg
+ libpng.so:${PORTSDIR}/graphics/png
USE_GNOME= libxml2
USE_LDCONFIG= yes
USE_OPENSSL= yes
-USES= cmake:outsource
+USES= cmake:outsource jpeg
CMAKE_ARGS+= -DDCMTK_WITH_DOXYGEN:BOOL=OFF \
-DDCMTK_WITH_OPENSSL:BOOL=ON
diff --git a/devel/directfb/Makefile b/devel/directfb/Makefile
index a30fb36c574a..74b9b6f74914 100644
--- a/devel/directfb/Makefile
+++ b/devel/directfb/Makefile
@@ -13,8 +13,7 @@ COMMENT= Graphic development lightweight API
LICENSE= LGPL21
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng.so:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
OPTIONS_DEFINE= FREETYPE X11 SDL UNIQUE TEST DOCS
UNIQUE_DESC= Unique (WM Module)
@@ -25,7 +24,7 @@ OPTIONS_SUB= yes
CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= cpe gmake libtool ncurses pathfix perl5 pkgconfig
+USES= cpe gmake jpeg libtool ncurses pathfix perl5 pkgconfig
USE_LDCONFIG= yes
USE_PERL5= build
PORTDOCS= *
diff --git a/devel/efl/Makefile b/devel/efl/Makefile
index b685a09bd870..ce14dfedeeac 100644
--- a/devel/efl/Makefile
+++ b/devel/efl/Makefile
@@ -12,8 +12,7 @@ COMMENT= Enlightenment Foundation Libraries
LICENSE= BSD2CLAUSE LGPL21
LICENSE_COMB= multi
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libgif.so:${PORTSDIR}/graphics/giflib \
+LIB_DEPENDS= libgif.so:${PORTSDIR}/graphics/giflib \
libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff \
libfreetype.so:${PORTSDIR}/print/freetype2 \
@@ -23,7 +22,7 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
DIST_SUBDIR= enlightenment
GNU_CONFIGURE= yes
-USES= autoreconf compiler:c++11-lib gettext-tools gmake libtool \
+USES= autoreconf compiler:c++11-lib gettext-tools gmake jpeg libtool \
pathfix pkgconfig shared-mime-info tar:xz
USE_XORG= x11 xcursor xcomposite xdamage xext xinerama xp xrandr xtst xscrnsaver
USE_LDCONFIG= yes
diff --git a/devel/kyra/Makefile b/devel/kyra/Makefile
index fb210882e1ee..673b942f52e4 100644
--- a/devel/kyra/Makefile
+++ b/devel/kyra/Makefile
@@ -13,13 +13,12 @@ COMMENT= Simple Sprite engine written in C++
LICENSE= GPLv2
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng.so:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff
WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= gmake zip
+USES= gmake jpeg zip
USE_GL= gl
USE_SDL= image sdl
MAKEFILE= MakefileKyra
diff --git a/devel/libclaw/Makefile b/devel/libclaw/Makefile
index 813bbf359374..60b5f58144f4 100644
--- a/devel/libclaw/Makefile
+++ b/devel/libclaw/Makefile
@@ -10,11 +10,10 @@ MASTER_SITES= SF
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= C++ Library Absolutely Wonderful
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng.so:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
BUILD_DEPENDS= ${LOCALBASE}/include/boost/bind.hpp:${PORTSDIR}/devel/boost-libs
-USES= cmake gettext
+USES= cmake gettext jpeg
CMAKE_ARGS= -DCLAW_CMAKE_MODULES_INSTALL_PATH="${DATADIR}/cmake"
USE_LDCONFIG= yes
diff --git a/devel/p5-SDL/Makefile b/devel/p5-SDL/Makefile
index bf223e455102..05e7db9f21c7 100644
--- a/devel/p5-SDL/Makefile
+++ b/devel/p5-SDL/Makefile
@@ -15,13 +15,12 @@ LICENSE= GPLv2
BUILD_DEPENDS= p5-Alien-SDL>=1.426:${PORTSDIR}/devel/p5-Alien-SDL
LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libtiff.so:${PORTSDIR}/graphics/tiff \
libsmpeg.so:${PORTSDIR}/multimedia/smpeg
RUN_DEPENDS= p5-Alien-SDL>=1.426:${PORTSDIR}/devel/p5-Alien-SDL \
p5-Tie-Simple>=0:${PORTSDIR}/devel/p5-Tie-Simple
-USES= perl5
+USES= jpeg perl5
USE_GL= glu
USE_PERL5= modbuild
USE_SDL= gfx image mixer pango sdl ttf
diff --git a/devel/py-game_sdl2/Makefile b/devel/py-game_sdl2/Makefile
index 98f26bce8355..6b2c2ac83255 100644
--- a/devel/py-game_sdl2/Makefile
+++ b/devel/py-game_sdl2/Makefile
@@ -15,13 +15,12 @@ LICENSE= LGPL21 ZLIB
LICENSE_COMB= multi
BUILD_DEPENDS= cython:${PORTSDIR}/lang/cython
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng.so:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
# Upstream tends to reroll distfiles before moving under /release/
PORTSCOUT= site:http://www.renpy.org/dl/release/
-USES= python tar:bz2
+USES= jpeg python tar:bz2
USE_SDL= image2 mixer2 ttf2
USE_PYTHON= autoplist distutils
WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
diff --git a/devel/sfml/Makefile b/devel/sfml/Makefile
index afc7cd25edfb..8d63ea5a66bd 100644
--- a/devel/sfml/Makefile
+++ b/devel/sfml/Makefile
@@ -12,11 +12,10 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Simple and Fast Multimedia Library
LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libGLEW.so:${PORTSDIR}/graphics/glew
-USES= cmake zip:infozip openal:al dos2unix
+USES= cmake dos2unix jpeg openal:al zip:infozip
DOS2UNIX_FILES= CMakeLists.txt
USE_XORG= x11 xrandr
USE_GL= gl
diff --git a/devel/sfml1/Makefile b/devel/sfml1/Makefile
index bbcc39ddf70e..4f6726162364 100644
--- a/devel/sfml1/Makefile
+++ b/devel/sfml1/Makefile
@@ -16,11 +16,10 @@ LICENSE= ZLIB
LICENSE_FILE= ${WRKSRC}/license.txt
LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libpng.so:${PORTSDIR}/graphics/png \
libfreetype.so:${PORTSDIR}/print/freetype2
-USES= gmake openal:al pkgconfig dos2unix
+USES= gmake jpeg openal:al pkgconfig dos2unix
DOS2UNIX_GLOB= Makefile ResourcePtr.inl
USE_XORG= x11 xrandr
USE_GL= gl glu
diff --git a/devel/simgear/Makefile b/devel/simgear/Makefile
index 865d8bf1b48c..7fb3cce0c57f 100644
--- a/devel/simgear/Makefile
+++ b/devel/simgear/Makefile
@@ -15,13 +15,12 @@ LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
libosg.so:${PORTSDIR}/graphics/osg
USE_XORG= ice sm x11 xext xi xt xmu
USE_GL= gl glu glut
-USES= cmake compiler cpe openal:al,alut tar:bzip2
+USES= cmake compiler cpe jpeg openal:al,alut tar:bzip2
.include <bsd.port.pre.mk>
diff --git a/devel/synfig/Makefile b/devel/synfig/Makefile
index 6857951c4b0d..6cc1070cdb0c 100644
--- a/devel/synfig/Makefile
+++ b/devel/synfig/Makefile
@@ -16,14 +16,13 @@ LIB_DEPENDS= libboost_program_options.so:${PORTSDIR}/devel/boost-libs \
libltdl.so:${PORTSDIR}/devel/libltdl \
libMagickWand-6.so:${PORTSDIR}/graphics/ImageMagick \
libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libmng.so:${PORTSDIR}/graphics/libmng \
libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff \
libavcodec.so:${PORTSDIR}/multimedia/ffmpeg \
libdv.so:${PORTSDIR}/multimedia/libdv
-USES= gettext iconv libtool pathfix pkgconfig
+USES= gettext iconv jpeg libtool pathfix pkgconfig
USE_GNOME= cairo glibmm libxml++26
GNU_CONFIGURE= yes
CONFIGURE_ARGS= ${ICONV_CONFIGURE_ARG}