aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/dcmtk/Makefile3
-rw-r--r--devel/gdcm/Makefile3
-rw-r--r--devel/gnome-vfs/Makefile3
-rw-r--r--devel/libepp-nicbr/Makefile2
-rw-r--r--devel/libewf/Makefile3
-rw-r--r--devel/libgit2/Makefile3
-rw-r--r--devel/libiqxmlrpc/Makefile3
-rw-r--r--devel/libmowgli2/Makefile3
-rw-r--r--devel/libsmraw/Makefile3
-rw-r--r--devel/mico/Makefile3
-rw-r--r--devel/omniORB-4.1/Makefile3
-rw-r--r--devel/omniORB/Makefile3
-rw-r--r--devel/pecl-event/Makefile3
-rw-r--r--devel/poco-ssl/Makefile3
-rw-r--r--devel/pwlib/Makefile3
-rw-r--r--devel/py-omniorb-3/Makefile3
-rw-r--r--devel/py-omniorb/Makefile3
-rw-r--r--devel/subcommander2/Makefile3
-rw-r--r--devel/tcltls/Makefile3
-rw-r--r--devel/uatraits/Makefile3
-rw-r--r--devel/ucommon/Makefile3
-rw-r--r--devel/xmltooling/Makefile3
22 files changed, 22 insertions, 43 deletions
diff --git a/devel/dcmtk/Makefile b/devel/dcmtk/Makefile
index d498a1c1cc2b..6b5586d614de 100644
--- a/devel/dcmtk/Makefile
+++ b/devel/dcmtk/Makefile
@@ -15,8 +15,7 @@ LIB_DEPENDS= libtiff.so:graphics/tiff \
USE_GNOME= libxml2
USE_LDCONFIG= yes
-USE_OPENSSL= yes
-USES= cmake:outsource jpeg
+USES= cmake:outsource jpeg ssl
CMAKE_ARGS+= -DDCMTK_WITH_DOXYGEN:BOOL=OFF \
-DDCMTK_WITH_OPENSSL:BOOL=ON
diff --git a/devel/gdcm/Makefile b/devel/gdcm/Makefile
index 97a0e08a01f8..23e111da5fca 100644
--- a/devel/gdcm/Makefile
+++ b/devel/gdcm/Makefile
@@ -48,8 +48,7 @@ GDCM_PATCH= 3
VTK5_VERSION= 5.10
VTK6_VERSION= 6.2
-USES= alias cmake:outsource tar:bzip2
-USE_OPENSSL= yes
+USES= alias cmake:outsource tar:bzip2 ssl
USE_LDCONFIG= yes
CFLAGS+= -I${LOCALBASE}/include
CMAKE_ARGS= -DGDCM_USE_SYSTEM_OPENSSL:BOOL=ON \
diff --git a/devel/gnome-vfs/Makefile b/devel/gnome-vfs/Makefile
index df1615f94237..dc180a32707e 100644
--- a/devel/gnome-vfs/Makefile
+++ b/devel/gnome-vfs/Makefile
@@ -17,10 +17,9 @@ USES= tar:bzip2
RUN_DEPENDS= update-mime-database:misc/shared-mime-info
-USES+= gettext gmake libtool:keepla pathfix pkgconfig
+USES+= gettext gmake libtool:keepla pathfix pkgconfig ssl
USE_GNOME= gconf2 gnomemimedata intlhack referencehack
INSTALL_TARGET= install-strip
-USE_OPENSSL= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-openssl \
diff --git a/devel/libepp-nicbr/Makefile b/devel/libepp-nicbr/Makefile
index 8662275621bf..b8c0ea008a68 100644
--- a/devel/libepp-nicbr/Makefile
+++ b/devel/libepp-nicbr/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libxerces-c.so:textproc/xerces-c3
-USE_OPENSSL= yes
+USES= ssl
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_header_cppunit_TestRunner_h=no
CONFIGURE_ARGS= --with-xerces-c=${LOCALBASE} \
diff --git a/devel/libewf/Makefile b/devel/libewf/Makefile
index 5ed3a77c039f..da477f31bd4d 100644
--- a/devel/libewf/Makefile
+++ b/devel/libewf/Makefile
@@ -16,9 +16,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libuuid.so:misc/e2fsprogs-libuuid
-USES= fuse gettext iconv libtool:keepla pathfix pkgconfig python:2
+USES= fuse gettext iconv libtool:keepla pathfix pkgconfig python:2 ssl
USE_LDCONFIG= yes
-USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-python --with-libintl-prefix=${LOCALBASE} --with-libuuid=${LOCALBASE} ${ICONV_CONFIGURE_ARG} --with-libsmdev=no
diff --git a/devel/libgit2/Makefile b/devel/libgit2/Makefile
index b6eb909dd09a..446eeda18887 100644
--- a/devel/libgit2/Makefile
+++ b/devel/libgit2/Makefile
@@ -13,9 +13,8 @@ LICENSE= GPLv2
USE_GITHUB= yes
GH_ACCOUNT= libgit2
-USES= cmake pathfix pkgconfig python:build
+USES= cmake pathfix pkgconfig python:build ssl
USE_LDCONFIG= yes
-USE_OPENSSL= yes
PLIST_SUB= PORTVERSION=${PORTVERSION} SHLIB_VER=${PORTVERSION:R:E}
diff --git a/devel/libiqxmlrpc/Makefile b/devel/libiqxmlrpc/Makefile
index c7707d7565c2..674ad8f014bf 100644
--- a/devel/libiqxmlrpc/Makefile
+++ b/devel/libiqxmlrpc/Makefile
@@ -21,10 +21,9 @@ DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
DOXYGEN_CMAKE_OFF= -Dbuild_docs=off
USE_GNOME= libxml2
-USES= cmake tar:bzip2
+USES= cmake tar:bzip2 ssl
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
-USE_OPENSSL= yes
PORTDOCS= *
diff --git a/devel/libmowgli2/Makefile b/devel/libmowgli2/Makefile
index 42e0b422dd91..6aba99760a4d 100644
--- a/devel/libmowgli2/Makefile
+++ b/devel/libmowgli2/Makefile
@@ -14,9 +14,8 @@ GH_ACCOUNT= atheme
GH_PROJECT= libmowgli-2
GNU_CONFIGURE= yes
-USES= gmake pathfix
+USES= gmake pathfix ssl
PATHFIX_MAKEFILEIN= Makefile
USE_LDCONFIG= yes
-USE_OPENSSL= yes
.include <bsd.port.mk>
diff --git a/devel/libsmraw/Makefile b/devel/libsmraw/Makefile
index 20d5d2e62d29..fc3d7d3d7002 100644
--- a/devel/libsmraw/Makefile
+++ b/devel/libsmraw/Makefile
@@ -14,8 +14,7 @@ LICENSE= LGPL3+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-python --with-libintl-prefix=${LOCALBASE}
-USES= fuse gettext libtool pathfix pkgconfig python
-USE_OPENSSL= yes
+USES= fuse gettext libtool pathfix pkgconfig python ssl
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
LIBS+= -L${OPENSSLLIB}
diff --git a/devel/mico/Makefile b/devel/mico/Makefile
index e18c419532c7..a323a458c5e3 100644
--- a/devel/mico/Makefile
+++ b/devel/mico/Makefile
@@ -18,9 +18,8 @@ LICENSE_FILE_LGPL20= ${WRKSRC}/LICENSE-LGPL
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-optimize --with-ssl=${OPENSSLBASE}
MAKE_ARGS= INSTDIR=${STAGEDIR}${PREFIX} SHARED_INSTDIR=${STAGEDIR}${PREFIX}
-USES= gmake ncurses readline
+USES= gmake ncurses readline ssl
USE_LDCONFIG= yes
-USE_OPENSSL= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
OPTIONS_DEFINE= DEBUG DOCS EXAMPLES GTK1 TCL X11
diff --git a/devel/omniORB-4.1/Makefile b/devel/omniORB-4.1/Makefile
index 9337c07558ea..2687c1f9792d 100644
--- a/devel/omniORB-4.1/Makefile
+++ b/devel/omniORB-4.1/Makefile
@@ -18,8 +18,7 @@ CONFLICTS= omniORB-4.2.*
PLIST_SUB+= SONUM=${PORTVERSION:C/.*\.//}
GNU_CONFIGURE= yes
-USE_OPENSSL= yes
-USES= gmake pkgconfig python tar:bzip2
+USES= gmake pkgconfig python tar:bzip2 ssl
USE_LDCONFIG= yes
MAKEFILE= GNUmakefile
CONFIGURE_ENV+= PYTHON=${PYTHON_CMD}
diff --git a/devel/omniORB/Makefile b/devel/omniORB/Makefile
index e0ef9151f0ac..f492de78b095 100644
--- a/devel/omniORB/Makefile
+++ b/devel/omniORB/Makefile
@@ -14,8 +14,7 @@ LICENSE= GPLv2
CONFLICTS= omniORB41-4.1.*
PLIST_SUB+= SONUM=1
GNU_CONFIGURE= yes
-USE_OPENSSL= yes
-USES= gmake pkgconfig python tar:bzip2
+USES= gmake pkgconfig python tar:bzip2 ssl
USE_LDCONFIG= yes
MAKEFILE= GNUmakefile
CONFIGURE_ENV+= PYTHON=${PYTHON_CMD}
diff --git a/devel/pecl-event/Makefile b/devel/pecl-event/Makefile
index 14b9f5ac584c..156c73dbe80e 100644
--- a/devel/pecl-event/Makefile
+++ b/devel/pecl-event/Makefile
@@ -17,8 +17,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libevent.so:devel/libevent
-USES= php:ext tar:tgz
-USE_OPENSSL= yes
+USES= php:ext tar:tgz ssl
CONFIGURE_ARGS= --with-openssl-dir=${OPENSSLBASE}
USE_PHP= sockets:build
diff --git a/devel/poco-ssl/Makefile b/devel/poco-ssl/Makefile
index 530b0d3d0edb..7a8fe55e9c90 100644
--- a/devel/poco-ssl/Makefile
+++ b/devel/poco-ssl/Makefile
@@ -18,11 +18,10 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
CONFLICTS= poco-[0-9]*
-USES= gmake tar:bzip2
+USES= gmake tar:bzip2 ssl
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --config=FreeBSD
USE_LDCONFIG= yes
-USE_OPENSSL= yes
OPTIONS_DEFINE= TEST SAMPLES MYSQL SQLITE ODBC
OPTIONS_DEFAULT=MYSQL SQLITE
diff --git a/devel/pwlib/Makefile b/devel/pwlib/Makefile
index 221a2a20c9f4..83236de86f74 100644
--- a/devel/pwlib/Makefile
+++ b/devel/pwlib/Makefile
@@ -19,11 +19,10 @@ CONFLICTS= ptlib-2.*
WRKSRC= ${WRKDIR}/ptlib_v${PORTVERSION:S/./_/g}
-USES= bison gmake
+USES= bison gmake ssl
USE_GCC= any
USE_AUTOTOOLS= autoconf
WANT_GNOME= yes
-USE_OPENSSL= yes
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/devel/py-omniorb-3/Makefile b/devel/py-omniorb-3/Makefile
index b71c7bea620c..438c529be56c 100644
--- a/devel/py-omniorb-3/Makefile
+++ b/devel/py-omniorb-3/Makefile
@@ -29,12 +29,11 @@ PLIST_SUB= SONUM=${PORTVERSION:C/.*\.//}
OMNIORB_WRKSRC!= cd ${.CURDIR}/../omniORB-4.1 && ${MAKE} -V WRKSRC
-USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_OUTSOURCE= yes
MAKEFILE= GNUmakefile
USE_LDCONFIG= yes
-USES= gmake python tar:bzip2
+USES= gmake python tar:bzip2 ssl
CONFIGURE_ENV+= PYTHON=${PYTHON_CMD}
CONFIGURE_ARGS= --with-openssl=${OPENSSLBASE} --with-omniorb=${LOCALBASE}
diff --git a/devel/py-omniorb/Makefile b/devel/py-omniorb/Makefile
index 041ec7450718..d8efc99f81f6 100644
--- a/devel/py-omniorb/Makefile
+++ b/devel/py-omniorb/Makefile
@@ -28,12 +28,11 @@ PLIST_SUB= SONUM=2
WRKSRC= ${WRKDIR}/${DISTNAME:S/-2//}
OMNIORB_WRKSRC!= cd ${.CURDIR}/../omniORB && ${MAKE} -V WRKSRC
-USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_OUTSOURCE= yes
MAKEFILE= GNUmakefile
USE_LDCONFIG= yes
-USES= gmake python tar:bzip2
+USES= gmake python tar:bzip2 ssl
CONFIGURE_ENV+= PYTHON=${PYTHON_CMD}
CONFIGURE_ARGS= --with-openssl=${OPENSSLBASE} --with-omniorb=${LOCALBASE}
diff --git a/devel/subcommander2/Makefile b/devel/subcommander2/Makefile
index 4127c1cbc4e5..7b3fbfba5d07 100644
--- a/devel/subcommander2/Makefile
+++ b/devel/subcommander2/Makefile
@@ -20,11 +20,10 @@ CONFLICTS= subcommander-1.*
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R:S,.b,b,}p${PORTVERSION:E}
-USES= autoreconf gmake dos2unix
+USES= autoreconf gmake dos2unix ssl
DOS2UNIX_GLOB= *.cpp *.h
USE_QT4= corelib gui network qt3support moc_build rcc_build uic_build
QT_NONSTANDARD= yes
-USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-boost=${LOCALBASE}/include \
--with-subversion=${LOCALBASE} --with-qt=${PREFIX} \
diff --git a/devel/tcltls/Makefile b/devel/tcltls/Makefile
index 8eb40cce80a2..d088cfdf3c68 100644
--- a/devel/tcltls/Makefile
+++ b/devel/tcltls/Makefile
@@ -18,8 +18,7 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
OPTIONS_DEFINE= DOCS
-USES+= tcl:tea
-USE_OPENSSL= yes
+USES+= tcl:tea ssl
CONFIGURE_ARGS+=--with-ssl-dir=${OPENSSLBASE}
WRKSRC= ${WRKDIR}/${TCL_PKG}
diff --git a/devel/uatraits/Makefile b/devel/uatraits/Makefile
index 7578dc181aac..989981be105e 100644
--- a/devel/uatraits/Makefile
+++ b/devel/uatraits/Makefile
@@ -16,9 +16,8 @@ LIB_DEPENDS= libboost_python.so:devel/boost-python-libs \
libpcre.so:devel/pcre \
libxml2.so:textproc/libxml2
-USES= autoreconf libtool pkgconfig python
+USES= autoreconf libtool pkgconfig python ssl
GNU_CONFIGURE= yes
-USE_OPENSSL= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-boost-prefix=${LOCALBASE} \
diff --git a/devel/ucommon/Makefile b/devel/ucommon/Makefile
index 0ef2e0fc80af..de5fa742cc0c 100644
--- a/devel/ucommon/Makefile
+++ b/devel/ucommon/Makefile
@@ -12,11 +12,10 @@ COMMENT= Very lightweight C++ design pattern library
LICENSE= LGPL3
LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
-USES= compiler:c++11-lib cmake:outsource pathfix pkgconfig
+USES= compiler:c++11-lib cmake:outsource pathfix pkgconfig ssl
CMAKE_ARGS= -DBUILD_TESTING:BOOL=ON \
-DCMAKE_INSTALL_BINDIR:STRING=bin/${PORTNAME}
USE_LDCONFIG= yes
-USE_OPENSSL= yes
TEST_TARGET= test
post-install:
diff --git a/devel/xmltooling/Makefile b/devel/xmltooling/Makefile
index 1ec58a32826e..d61192194999 100644
--- a/devel/xmltooling/Makefile
+++ b/devel/xmltooling/Makefile
@@ -19,9 +19,8 @@ BUILD_DEPENDS= boost-libs>=0:devel/boost-libs
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-log4shib=${LOCALBASE} --with-openssl=${OPENSSLBASE} --with-curl=${LOCALBASE} --disable-doxygen-doc
-USES= gmake libtool pkgconfig tar:bzip2
+USES= gmake libtool pkgconfig tar:bzip2 ssl
USE_LDCONFIG= yes
-USE_OPENSSL= yes
PORTDOCS= *