aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/gitg/Makefile3
-rw-r--r--devel/gnome-vfs-monikers/Makefile7
-rw-r--r--devel/gnome-vfsmm/Makefile8
-rw-r--r--devel/guiloader-c++/Makefile2
-rw-r--r--devel/libglademm/Makefile8
-rw-r--r--devel/libglademm24/Makefile8
-rw-r--r--devel/libsigcx/Makefile3
7 files changed, 11 insertions, 28 deletions
diff --git a/devel/gitg/Makefile b/devel/gitg/Makefile
index 32d85acca714..55405380fa50 100644
--- a/devel/gitg/Makefile
+++ b/devel/gitg/Makefile
@@ -17,9 +17,8 @@ RUN_DEPENDS= git>=1.7.0.2:${PORTSDIR}/devel/git
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_GNOME= gconf2 gtk20 gtksourceview2 gnomehack
-USES= gettext
+USES= gettext gmake pkgconfig
INSTALLS_ICONS= yes
GCONF_SCHEMAS= gitg.schemas
diff --git a/devel/gnome-vfs-monikers/Makefile b/devel/gnome-vfs-monikers/Makefile
index f0039e617f0e..9d73570a5355 100644
--- a/devel/gnome-vfs-monikers/Makefile
+++ b/devel/gnome-vfs-monikers/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: gnome-vfs-monikers
-# Date created: 2006-07-11
-# Whom: Michael Johnson <ahze@FreeBSD.org>
-#
+# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/devel/gnome-vfs-monikers/Makefile,v 1.4 2006/07/18 11:37:57 ahze Exp $
@@ -15,7 +12,7 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Gnome-vfs monikers module
USE_GNOME= gnomevfs2 libbonobo
-USE_GMAKE= yes
+USES= gmake pkgconfig
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib #-pthread
diff --git a/devel/gnome-vfsmm/Makefile b/devel/gnome-vfsmm/Makefile
index bc0fb36f9cc7..e8bb36a32454 100644
--- a/devel/gnome-vfsmm/Makefile
+++ b/devel/gnome-vfsmm/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: gnome-vfsmm
-# Date created: 22 May 2003
-# Whom: Alexander Nedotsukov <bland@mail.ru>
-#
+# Created by: Alexander Nedotsukov <bland@mail.ru>
# $FreeBSD$
# $MCom: ports/devel/gnome-vfsmm/Makefile,v 1.31 2009/03/17 15:22:21 kwm Exp $
-#
PORTNAME= gnome-vfsmm
PORTVERSION= 2.26.0
@@ -20,7 +16,7 @@ LIB_DEPENDS= glibmm-2.4.1:${PORTSDIR}/devel/glibmm
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_GNOME= gnomehack gnomevfs2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/devel/guiloader-c++/Makefile b/devel/guiloader-c++/Makefile
index ebb2b55eb945..5ffecc2ab7c0 100644
--- a/devel/guiloader-c++/Makefile
+++ b/devel/guiloader-c++/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= guiloader.1:${PORTSDIR}/devel/guiloader \
PROJECTHOST= nothing-personal
USE_BZIP2= yes
-USES= pathfix gettext
+USES= pathfix gettext pkgconfig
USE_GNOME= gtk20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-hidden-visibility
diff --git a/devel/libglademm/Makefile b/devel/libglademm/Makefile
index 52ea2fec021d..2c884f97d1fc 100644
--- a/devel/libglademm/Makefile
+++ b/devel/libglademm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libglademm
-# Date created: 22 May 2003
-# Whom: Alexander Nedotsukov <bland@mail.ru>
-#
+# Created by: Alexander Nedotsukov <bland@mail.ru>
# $FreeBSD$
-#
PORTNAME= libglademm
PORTVERSION= 2.1.3
@@ -19,7 +15,7 @@ LIB_DEPENDS= gtkmm-2.0:${PORTSDIR}/x11-toolkits/gtkmm20
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_XORG= x11 sm
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_GNOME= gnomehack libglade2
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
diff --git a/devel/libglademm24/Makefile b/devel/libglademm24/Makefile
index 1c85d5eeeb60..e5f7a292a8c8 100644
--- a/devel/libglademm24/Makefile
+++ b/devel/libglademm24/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: libglademm
-# Date created: 22 May 2003
-# Whom: Alexander Nedotsukov <bland@mail.ru>
-#
+# Created by: Alexander Nedotsukov <bland@mail.ru>
# $FreeBSD$
# $MCom: ports/devel/libglademm24/Makefile,v 1.10 2008/09/22 11:42:53 kwm Exp $
-#
PORTNAME= libglademm
PORTVERSION= 2.6.7
@@ -23,7 +19,7 @@ LATEST_LINK= libglademm24
USE_BZIP2= yes
USE_XORG= x11 ice
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_GNOME= gnomehack libglade2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/devel/libsigcx/Makefile b/devel/libsigcx/Makefile
index 0082d2b59994..457d6de13ccd 100644
--- a/devel/libsigcx/Makefile
+++ b/devel/libsigcx/Makefile
@@ -13,9 +13,8 @@ COMMENT= An extension of libSigC++
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
LIB_DEPENDS= sigc-1.2.5:${PORTSDIR}/devel/libsigc++12
-USES= pathfix
+USES= pathfix gmake pkgconfig
USE_GNOME= gtk20
-USE_GMAKE= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ENV= ac_cv_path_DOXYGEN=""
USE_LDCONFIG= yes