aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/apr1/Makefile4
-rw-r--r--devel/apr2/Makefile4
2 files changed, 6 insertions, 2 deletions
diff --git a/devel/apr1/Makefile b/devel/apr1/Makefile
index 11f8eb68abd6..a5061d27e703 100644
--- a/devel/apr1/Makefile
+++ b/devel/apr1/Makefile
@@ -36,7 +36,7 @@ APU_VERSION= 1.3.9
USE_ICONV= yes
USE_AUTOTOOLS= automake:19 autoconf:262 libtool:22:env
USE_PERL5_BUILD= yes
-USE_PYTHON_BUILD= yes
+USE_PYTHON_BUILD= -2.6
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -216,6 +216,8 @@ post-patch:
${REINPLACE_CMD} -e 's,-lpthread,${PTHREAD_LIBS},g' \
${APR_WRKDIR}/build/apr_threads.m4 ${APR_WRKDIR}/build/apr_hints.m4 \
${APU_WRKDIR}/build/apu-conf.m4
+ ${REINPLACE_CMD} -e '1 s/python/${PYTHON_VERSION}/' \
+ ${APR_WRKDIR}/build/gen-build.py
run-autotools::
cd ${APR_WRKDIR} ; \
diff --git a/devel/apr2/Makefile b/devel/apr2/Makefile
index 11f8eb68abd6..a5061d27e703 100644
--- a/devel/apr2/Makefile
+++ b/devel/apr2/Makefile
@@ -36,7 +36,7 @@ APU_VERSION= 1.3.9
USE_ICONV= yes
USE_AUTOTOOLS= automake:19 autoconf:262 libtool:22:env
USE_PERL5_BUILD= yes
-USE_PYTHON_BUILD= yes
+USE_PYTHON_BUILD= -2.6
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -216,6 +216,8 @@ post-patch:
${REINPLACE_CMD} -e 's,-lpthread,${PTHREAD_LIBS},g' \
${APR_WRKDIR}/build/apr_threads.m4 ${APR_WRKDIR}/build/apr_hints.m4 \
${APU_WRKDIR}/build/apu-conf.m4
+ ${REINPLACE_CMD} -e '1 s/python/${PYTHON_VERSION}/' \
+ ${APR_WRKDIR}/build/gen-build.py
run-autotools::
cd ${APR_WRKDIR} ; \