aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pythontidy/Makefile35
-rw-r--r--devel/pythontidy/distinfo3
-rw-r--r--devel/pythontidy/pkg-descr11
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index cdaa22fd3f84..2e4be6e77878 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1820,6 +1820,7 @@
SUBDIR += pymacs
SUBDIR += pypersrc
SUBDIR += pyrex
+ SUBDIR += pythontidy
SUBDIR += qca
SUBDIR += qextmdi
SUBDIR += qmake
diff --git a/devel/pythontidy/Makefile b/devel/pythontidy/Makefile
new file mode 100644
index 000000000000..3dececdf81e2
--- /dev/null
+++ b/devel/pythontidy/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: pythontidy
+# Date created: Jan. 16 ,2007
+# Whom: Li-Wen Hsu <lwhsu@lwhsu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pythontidy
+PORTVERSION= 1.10
+CATEGORIES= devel python
+MASTER_SITES= http://www.lacusveris.com/PythonTidy/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PythonTidy-${PORTVERSION}.python
+EXTRACT_SUFX= #
+DIST_SUBDIR= python
+
+MAINTAINER= lwhsu@lwhsu.org
+COMMENT= Cleans up, regularizes, and reformats the text of Python scripts
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/pythontidy
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @${CP} ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES} ${WRKDIR}
+
+do-patch:
+ ${REINPLACE_CMD} -e s,/usr/bin/python,${PYTHON_CMD}, ${WRKDIR}/${DISTFILES}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${DISTFILES} ${TARGETDIR}/bin/pythontidy
+
+.include <bsd.port.mk>
diff --git a/devel/pythontidy/distinfo b/devel/pythontidy/distinfo
new file mode 100644
index 000000000000..05f5f59c5caa
--- /dev/null
+++ b/devel/pythontidy/distinfo
@@ -0,0 +1,3 @@
+MD5 (python/PythonTidy-1.10.python) = 675550dbf22afc4527f584a1b735df92
+SHA256 (python/PythonTidy-1.10.python) = ab6c5d98b9eeadd4c911b445e4e628ab2de554eed52fb085ff204932ffbf2037
+SIZE (python/PythonTidy-1.10.python) = 116894
diff --git a/devel/pythontidy/pkg-descr b/devel/pythontidy/pkg-descr
new file mode 100644
index 000000000000..1847ead6fdc1
--- /dev/null
+++ b/devel/pythontidy/pkg-descr
@@ -0,0 +1,11 @@
+This script reads Python code from standard input and writes a revised
+version to standard output.
+
+Alternatively, it may be invoked with file names as arguments:
+
+ python PythonTidy.py input output
+
+Suffice it to say that input defaults to '-', the standard input, and output
+defaults to '-', the standard output.
+
+WWW: http://www.python.org/pypi/PythonTidy/