aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/fastcrc/Makefile5
-rw-r--r--devel/fastcrc/pkg-plist2
-rw-r--r--devel/flux/Makefile1
-rw-r--r--devel/flux/pkg-plist2
-rw-r--r--devel/freelibiberty/Makefile5
-rw-r--r--devel/freelibiberty/pkg-plist2
-rw-r--r--devel/gettext-devel/Makefile1
-rw-r--r--devel/gettext-devel/pkg-plist2
-rw-r--r--devel/gettext-old/Makefile1
-rw-r--r--devel/gettext-old/pkg-plist2
-rw-r--r--devel/gettext/Makefile1
-rw-r--r--devel/gettext/pkg-plist2
-rw-r--r--devel/glib12/Makefile1
-rw-r--r--devel/glib12/pkg-plist2
-rw-r--r--devel/glib13/Makefile1
-rw-r--r--devel/glib13/pkg-plist2
-rw-r--r--devel/glib20/Makefile1
-rw-r--r--devel/glib20/pkg-plist2
18 files changed, 11 insertions, 24 deletions
diff --git a/devel/fastcrc/Makefile b/devel/fastcrc/Makefile
index 96aff86e998b..7a5cf83c01b4 100644
--- a/devel/fastcrc/Makefile
+++ b/devel/fastcrc/Makefile
@@ -16,6 +16,8 @@ BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
ONLY_FOR_ARCHS= i386
+INSTALLS_SHLIBS= yes
+
do-install:
${INSTALL_DATA} ${WRKSRC}/libfcrc.so.1 ${PREFIX}/lib
${LN} -fs ${PREFIX}/lib/libfcrc.so.1 ${PREFIX}/lib/libfcrc.so
@@ -24,7 +26,4 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/index.html ${PREFIX}/share/doc/fastcrc
${INSTALL_PROGRAM} ${WRKSRC}/fc ${PREFIX}/bin
-post-install:
- ${SETENV} OBFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
-
.include <bsd.port.mk>
diff --git a/devel/fastcrc/pkg-plist b/devel/fastcrc/pkg-plist
index 5ae0642fd358..8efefcfe70c5 100644
--- a/devel/fastcrc/pkg-plist
+++ b/devel/fastcrc/pkg-plist
@@ -2,7 +2,5 @@ bin/fc
include/fastcrc.h
lib/libfcrc.so
lib/libfcrc.so.1
-@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %D/lib
-@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
share/doc/fastcrc/index.html
@dirrm share/doc/fastcrc
diff --git a/devel/flux/Makefile b/devel/flux/Makefile
index ae35ec176099..5f3fa5733e99 100644
--- a/devel/flux/Makefile
+++ b/devel/flux/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= ftp://ftp.styx.net/projects/flux/
MAINTAINER= will@FreeBSD.org
USE_LIBTOOL= yes
+INSTALLS_SHLIBS= yes
USE_GMAKE= yes
post-install:
diff --git a/devel/flux/pkg-plist b/devel/flux/pkg-plist
index 2f372e0e8d3f..1a657aa02c6a 100644
--- a/devel/flux/pkg-plist
+++ b/devel/flux/pkg-plist
@@ -19,8 +19,6 @@ include/flux/url.h
include/flux/xml.h
lib/libflux.a
lib/libflux.so.0
-@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
-@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
share/flux/AUTHORS
share/flux/NEWS
share/flux/README
diff --git a/devel/freelibiberty/Makefile b/devel/freelibiberty/Makefile
index bc57fb19f9ed..88b5f8d08161 100644
--- a/devel/freelibiberty/Makefile
+++ b/devel/freelibiberty/Makefile
@@ -15,6 +15,8 @@ DISTNAME= libiberty-${PORTVERSION}
MAINTAINER= howardjp@wam.umd.edu
+INSTALLS_SHLIBS= yes
+
do-install:
${INSTALL_DATA} ${WRKSRC}/libiberty.a ${PREFIX}/lib
${INSTALL_DATA} ${WRKSRC}/libiberty.so.1 ${PREFIX}/lib
@@ -22,7 +24,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/libiberty.h ${PREFIX}/include
${INSTALL_DATA} ${WRKSRC}/getopt.h ${PREFIX}/include
-post-install:
- @${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
-
.include <bsd.port.mk>
diff --git a/devel/freelibiberty/pkg-plist b/devel/freelibiberty/pkg-plist
index 07df3cfe0300..62438530d70b 100644
--- a/devel/freelibiberty/pkg-plist
+++ b/devel/freelibiberty/pkg-plist
@@ -3,5 +3,3 @@ include/getopt.h
lib/libiberty.a
lib/libiberty.so
lib/libiberty.so.1
-@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
-@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
diff --git a/devel/gettext-devel/Makefile b/devel/gettext-devel/Makefile
index 9510fc6085d4..c66dce587751 100644
--- a/devel/gettext-devel/Makefile
+++ b/devel/gettext-devel/Makefile
@@ -14,6 +14,7 @@ MASTER_SITE_SUBDIR= gettext
MAINTAINER= reg@FreeBSD.org
USE_LIBTOOL= yes
+INSTALLS_SHLIBS= yes
PLIST_SUB= LOCALBASE=${LOCALBASE} X11BASE=${X11BASE}
diff --git a/devel/gettext-devel/pkg-plist b/devel/gettext-devel/pkg-plist
index ad24b701e017..9e23936a2dbd 100644
--- a/devel/gettext-devel/pkg-plist
+++ b/devel/gettext-devel/pkg-plist
@@ -13,8 +13,6 @@ include/libintl.h
lib/libintl.a
lib/libintl.so
lib/libintl.so.1
-@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
-@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
share/aclocal/gettext.m4
share/aclocal/lcmessage.m4
share/aclocal/progtest.m4
diff --git a/devel/gettext-old/Makefile b/devel/gettext-old/Makefile
index 9510fc6085d4..c66dce587751 100644
--- a/devel/gettext-old/Makefile
+++ b/devel/gettext-old/Makefile
@@ -14,6 +14,7 @@ MASTER_SITE_SUBDIR= gettext
MAINTAINER= reg@FreeBSD.org
USE_LIBTOOL= yes
+INSTALLS_SHLIBS= yes
PLIST_SUB= LOCALBASE=${LOCALBASE} X11BASE=${X11BASE}
diff --git a/devel/gettext-old/pkg-plist b/devel/gettext-old/pkg-plist
index ad24b701e017..9e23936a2dbd 100644
--- a/devel/gettext-old/pkg-plist
+++ b/devel/gettext-old/pkg-plist
@@ -13,8 +13,6 @@ include/libintl.h
lib/libintl.a
lib/libintl.so
lib/libintl.so.1
-@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
-@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
share/aclocal/gettext.m4
share/aclocal/lcmessage.m4
share/aclocal/progtest.m4
diff --git a/devel/gettext/Makefile b/devel/gettext/Makefile
index 9510fc6085d4..c66dce587751 100644
--- a/devel/gettext/Makefile
+++ b/devel/gettext/Makefile
@@ -14,6 +14,7 @@ MASTER_SITE_SUBDIR= gettext
MAINTAINER= reg@FreeBSD.org
USE_LIBTOOL= yes
+INSTALLS_SHLIBS= yes
PLIST_SUB= LOCALBASE=${LOCALBASE} X11BASE=${X11BASE}
diff --git a/devel/gettext/pkg-plist b/devel/gettext/pkg-plist
index ad24b701e017..9e23936a2dbd 100644
--- a/devel/gettext/pkg-plist
+++ b/devel/gettext/pkg-plist
@@ -13,8 +13,6 @@ include/libintl.h
lib/libintl.a
lib/libintl.so
lib/libintl.so.1
-@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
-@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
share/aclocal/gettext.m4
share/aclocal/lcmessage.m4
share/aclocal/progtest.m4
diff --git a/devel/glib12/Makefile b/devel/glib12/Makefile
index 5dee993308e2..5856940bfc1e 100644
--- a/devel/glib12/Makefile
+++ b/devel/glib12/Makefile
@@ -15,6 +15,7 @@ MASTER_SITES= ftp://ftp.gimp.org/pub/gtk/v1.2/ \
MAINTAINER= vanilla@FreeBSD.org
USE_LIBTOOL= yes
+INSTALLS_SHLIBS= yes
LIBTOOLFLAGS= --disable-ltlibs --release-suffix
CONFIGURE_ARGS= --includedir=${PREFIX}/include/glib12
diff --git a/devel/glib12/pkg-plist b/devel/glib12/pkg-plist
index 5b01f3b5218f..86054550259d 100644
--- a/devel/glib12/pkg-plist
+++ b/devel/glib12/pkg-plist
@@ -14,7 +14,5 @@ lib/libgmodule12.so.3
lib/libgthread12.a
lib/libgthread12.so
lib/libgthread12.so.3
-@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
-@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
share/aclocal/glib.m4
@dirrm include/glib12
diff --git a/devel/glib13/Makefile b/devel/glib13/Makefile
index 5dee993308e2..5856940bfc1e 100644
--- a/devel/glib13/Makefile
+++ b/devel/glib13/Makefile
@@ -15,6 +15,7 @@ MASTER_SITES= ftp://ftp.gimp.org/pub/gtk/v1.2/ \
MAINTAINER= vanilla@FreeBSD.org
USE_LIBTOOL= yes
+INSTALLS_SHLIBS= yes
LIBTOOLFLAGS= --disable-ltlibs --release-suffix
CONFIGURE_ARGS= --includedir=${PREFIX}/include/glib12
diff --git a/devel/glib13/pkg-plist b/devel/glib13/pkg-plist
index 5b01f3b5218f..86054550259d 100644
--- a/devel/glib13/pkg-plist
+++ b/devel/glib13/pkg-plist
@@ -14,7 +14,5 @@ lib/libgmodule12.so.3
lib/libgthread12.a
lib/libgthread12.so
lib/libgthread12.so.3
-@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
-@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
share/aclocal/glib.m4
@dirrm include/glib12
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index 5dee993308e2..5856940bfc1e 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -15,6 +15,7 @@ MASTER_SITES= ftp://ftp.gimp.org/pub/gtk/v1.2/ \
MAINTAINER= vanilla@FreeBSD.org
USE_LIBTOOL= yes
+INSTALLS_SHLIBS= yes
LIBTOOLFLAGS= --disable-ltlibs --release-suffix
CONFIGURE_ARGS= --includedir=${PREFIX}/include/glib12
diff --git a/devel/glib20/pkg-plist b/devel/glib20/pkg-plist
index 5b01f3b5218f..86054550259d 100644
--- a/devel/glib20/pkg-plist
+++ b/devel/glib20/pkg-plist
@@ -14,7 +14,5 @@ lib/libgmodule12.so.3
lib/libgthread12.a
lib/libgthread12.so
lib/libgthread12.so.3
-@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
-@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
share/aclocal/glib.m4
@dirrm include/glib12