aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Alzabo-GUI-Mason/Makefile2
-rw-r--r--devel/p5-Class-AlzaboWrapper/Makefile2
-rw-r--r--devel/p5-Coro/Makefile4
-rw-r--r--devel/p5-Data-Dump/Makefile2
-rw-r--r--devel/p5-DateTime-Calendar-Pataphysical/Makefile2
-rw-r--r--devel/p5-DateTime-Event-Recurrence/Makefile2
-rw-r--r--devel/p5-DateTime-Format-Builder/Makefile4
-rw-r--r--devel/p5-DateTime-Format-Epoch/Makefile2
-rw-r--r--devel/p5-DateTime-Incomplete/Makefile2
-rw-r--r--devel/p5-DateTime-Locale/Makefile2
-rw-r--r--devel/p5-DateTime-Set/Makefile2
-rw-r--r--devel/p5-DateTime/Makefile2
-rw-r--r--devel/p5-Devel-Cover/Makefile2
-rw-r--r--devel/p5-Devel-PPPort/Makefile2
-rw-r--r--devel/p5-Event/Makefile2
-rw-r--r--devel/p5-ExtUtils-CBuilder/Makefile2
-rw-r--r--devel/p5-File-Modified/Makefile4
-rw-r--r--devel/p5-Locale-Maketext-Gettext/Makefile2
-rw-r--r--devel/p5-Locale-Maketext-Lexicon/Makefile2
-rw-r--r--devel/p5-Log-Dispatch/Makefile2
-rw-r--r--devel/p5-Module-Build/Makefile2
-rw-r--r--devel/p5-POE-Component-Daemon/Makefile4
-rw-r--r--devel/p5-Params-Check/Makefile2
-rw-r--r--devel/p5-Path-Class/Makefile2
-rw-r--r--devel/p5-Pod-Coverage/Makefile8
-rw-r--r--devel/p5-Proc-ProcessTable/Makefile8
-rw-r--r--devel/p5-SVN-Web/Makefile2
-rw-r--r--devel/p5-Set-Infinite/Makefile2
-rw-r--r--devel/p5-Set-Object/Makefile2
-rw-r--r--devel/p5-Spiffy/Makefile2
-rw-r--r--devel/p5-Spoon/Makefile2
-rw-r--r--devel/p5-Term-ProgressBar/Makefile2
-rw-r--r--devel/p5-Test-Tester/Makefile2
-rw-r--r--devel/p5-TheSchwartz/Makefile2
-rw-r--r--devel/p5-Time-Local/Makefile2
35 files changed, 44 insertions, 46 deletions
diff --git a/devel/p5-Alzabo-GUI-Mason/Makefile b/devel/p5-Alzabo-GUI-Mason/Makefile
index 74fd7375db51..126aaf3dc17f 100644
--- a/devel/p5-Alzabo-GUI-Mason/Makefile
+++ b/devel/p5-Alzabo-GUI-Mason/Makefile
@@ -29,7 +29,7 @@ PORTDOCS= Changes README
post-install:
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/devel/p5-Class-AlzaboWrapper/Makefile b/devel/p5-Class-AlzaboWrapper/Makefile
index 955a0aa4461b..2ac53b12f4dd 100644
--- a/devel/p5-Class-AlzaboWrapper/Makefile
+++ b/devel/p5-Class-AlzaboWrapper/Makefile
@@ -26,7 +26,7 @@ PORTDOCS= Changes README
post-install:
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/devel/p5-Coro/Makefile b/devel/p5-Coro/Makefile
index 211e728affbf..96b7c44873f7 100644
--- a/devel/p5-Coro/Makefile
+++ b/devel/p5-Coro/Makefile
@@ -52,11 +52,11 @@ MAN3= Coro.3 \
NO_STAGE= yes
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}/
+ @${MKDIR} ${DOCSDIR}/
${INSTALL_DATA} ${WRKSRC}/doc/cede-vs-schedule ${DOCSDIR}/
.endif
.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}/
+ @${MKDIR} ${EXAMPLESDIR}/
${INSTALL_SCRIPT} ${WRKSRC}/eg/* ${EXAMPLESDIR}/
.endif
diff --git a/devel/p5-Data-Dump/Makefile b/devel/p5-Data-Dump/Makefile
index 192d4dc17001..dba5b7d4d95c 100644
--- a/devel/p5-Data-Dump/Makefile
+++ b/devel/p5-Data-Dump/Makefile
@@ -21,7 +21,7 @@ PORTDOCS= Changes README
post-install:
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/devel/p5-DateTime-Calendar-Pataphysical/Makefile b/devel/p5-DateTime-Calendar-Pataphysical/Makefile
index 68d6fee5f095..1e4a51926042 100644
--- a/devel/p5-DateTime-Calendar-Pataphysical/Makefile
+++ b/devel/p5-DateTime-Calendar-Pataphysical/Makefile
@@ -24,7 +24,7 @@ PORTDOCS= Changes README
post-install:
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/devel/p5-DateTime-Event-Recurrence/Makefile b/devel/p5-DateTime-Event-Recurrence/Makefile
index ca8b087cb5cb..57ac1a2a26aa 100644
--- a/devel/p5-DateTime-Event-Recurrence/Makefile
+++ b/devel/p5-DateTime-Event-Recurrence/Makefile
@@ -27,7 +27,7 @@ NO_STAGE= yes
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}/
+ @${MKDIR} ${DOCSDIR}/
cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/devel/p5-DateTime-Format-Builder/Makefile b/devel/p5-DateTime-Format-Builder/Makefile
index 698793922084..3c68376c9d44 100644
--- a/devel/p5-DateTime-Format-Builder/Makefile
+++ b/devel/p5-DateTime-Format-Builder/Makefile
@@ -40,12 +40,12 @@ NO_STAGE= yes
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}/
+ @${MKDIR} ${DOCSDIR}/
cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
- ${MKDIR} ${EXAMPLESDIR}/
+ @${MKDIR} ${EXAMPLESDIR}/
cd ${WRKSRC}/examples/ && ${INSTALL_DATA} ${PORTEXAMPLES} ${EXAMPLESDIR}/
@${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
.endif
diff --git a/devel/p5-DateTime-Format-Epoch/Makefile b/devel/p5-DateTime-Format-Epoch/Makefile
index 86d91afa8cec..9e1db26d21b6 100644
--- a/devel/p5-DateTime-Format-Epoch/Makefile
+++ b/devel/p5-DateTime-Format-Epoch/Makefile
@@ -39,7 +39,7 @@ PORTDOCS= Changes README TODO
post-install:
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/devel/p5-DateTime-Incomplete/Makefile b/devel/p5-DateTime-Incomplete/Makefile
index 92005deff9c4..c1c990b37fea 100644
--- a/devel/p5-DateTime-Incomplete/Makefile
+++ b/devel/p5-DateTime-Incomplete/Makefile
@@ -30,7 +30,7 @@ PORTDOCS= Changes LICENSE MANIFEST README TODO
post-install:
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/devel/p5-DateTime-Locale/Makefile b/devel/p5-DateTime-Locale/Makefile
index df6e9bc66656..d40cf5654ae0 100644
--- a/devel/p5-DateTime-Locale/Makefile
+++ b/devel/p5-DateTime-Locale/Makefile
@@ -500,7 +500,7 @@ PORTDOCS= Changes
post-install:
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/devel/p5-DateTime-Set/Makefile b/devel/p5-DateTime-Set/Makefile
index 9ce2e32449ec..089aa5f89bc0 100644
--- a/devel/p5-DateTime-Set/Makefile
+++ b/devel/p5-DateTime-Set/Makefile
@@ -27,7 +27,7 @@ PORTDOCS= Changes README TODO
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}/
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/
cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/devel/p5-DateTime/Makefile b/devel/p5-DateTime/Makefile
index 5f7c535c6c62..0ee3acca85b6 100644
--- a/devel/p5-DateTime/Makefile
+++ b/devel/p5-DateTime/Makefile
@@ -36,7 +36,7 @@ NO_STAGE= yes
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}/
+ @${MKDIR} ${DOCSDIR}/
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}/
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/devel/p5-Devel-Cover/Makefile b/devel/p5-Devel-Cover/Makefile
index 4cf2c4e5ac97..1792d300f44f 100644
--- a/devel/p5-Devel-Cover/Makefile
+++ b/devel/p5-Devel-Cover/Makefile
@@ -72,7 +72,7 @@ NO_STAGE= yes
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}/
+ @${MKDIR} ${DOCSDIR}/
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}/
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/devel/p5-Devel-PPPort/Makefile b/devel/p5-Devel-PPPort/Makefile
index 9194313a9722..4f9747833928 100644
--- a/devel/p5-Devel-PPPort/Makefile
+++ b/devel/p5-Devel-PPPort/Makefile
@@ -24,7 +24,7 @@ PORTDOCS= Changes README HACKERS TODO
post-install:
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/devel/p5-Event/Makefile b/devel/p5-Event/Makefile
index 9c0469a5775c..f64aac019b36 100644
--- a/devel/p5-Event/Makefile
+++ b/devel/p5-Event/Makefile
@@ -24,7 +24,7 @@ NO_STAGE= yes
post-install:
.if ${PORT_OPTIONS:MDOCS}
@${ECHO_MSG} "===> Installing documentation for ${PKGNAME}"
- ${MKDIR} ${DOCSDIR}/
+ @${MKDIR} ${DOCSDIR}/
cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
.endif
diff --git a/devel/p5-ExtUtils-CBuilder/Makefile b/devel/p5-ExtUtils-CBuilder/Makefile
index 4bd786e93563..d44de938cc25 100644
--- a/devel/p5-ExtUtils-CBuilder/Makefile
+++ b/devel/p5-ExtUtils-CBuilder/Makefile
@@ -24,7 +24,7 @@ PORTDOCS= Changes
post-install:
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/devel/p5-File-Modified/Makefile b/devel/p5-File-Modified/Makefile
index 8ba1639000ca..5e8bc6e219fc 100644
--- a/devel/p5-File-Modified/Makefile
+++ b/devel/p5-File-Modified/Makefile
@@ -26,9 +26,9 @@ EXAMPLES= example/1.pl example/Export.cfg example/Import.cfg
post-install:
@${MKDIR} ${DOCSDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
- @${INSTALL_DATA} ${EXAMPLES:S|^|${WRKSRC}/|} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${EXAMPLES:S|^|${WRKSRC}/|} ${EXAMPLESDIR}
@${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
.endif
diff --git a/devel/p5-Locale-Maketext-Gettext/Makefile b/devel/p5-Locale-Maketext-Gettext/Makefile
index e790374d25ee..fbaa830fbf75 100644
--- a/devel/p5-Locale-Maketext-Gettext/Makefile
+++ b/devel/p5-Locale-Maketext-Gettext/Makefile
@@ -24,7 +24,7 @@ PORTDOCS= BUGS Changes README THANKS
post-install:
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/devel/p5-Locale-Maketext-Lexicon/Makefile b/devel/p5-Locale-Maketext-Lexicon/Makefile
index dee3ee2988a2..a6cb5d950642 100644
--- a/devel/p5-Locale-Maketext-Lexicon/Makefile
+++ b/devel/p5-Locale-Maketext-Lexicon/Makefile
@@ -45,7 +45,7 @@ PORTDOCS= AUTHORS Changes README
post-install:
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/devel/p5-Log-Dispatch/Makefile b/devel/p5-Log-Dispatch/Makefile
index 049d6cbca2c3..d7471d1c50fb 100644
--- a/devel/p5-Log-Dispatch/Makefile
+++ b/devel/p5-Log-Dispatch/Makefile
@@ -73,7 +73,7 @@ RUN_DEPENDS+= p5-Mail-Sendmail>=0:${PORTSDIR}/mail/p5-Mail-Sendmail
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}/
+ @${MKDIR} ${DOCSDIR}/
cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/devel/p5-Module-Build/Makefile b/devel/p5-Module-Build/Makefile
index 9196af1758ab..26c605425f98 100644
--- a/devel/p5-Module-Build/Makefile
+++ b/devel/p5-Module-Build/Makefile
@@ -49,7 +49,7 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}/
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/
cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/devel/p5-POE-Component-Daemon/Makefile b/devel/p5-POE-Component-Daemon/Makefile
index 7583ffa89f7c..cabcb262f1de 100644
--- a/devel/p5-POE-Component-Daemon/Makefile
+++ b/devel/p5-POE-Component-Daemon/Makefile
@@ -26,7 +26,7 @@ PORTDOCS= *
NO_STAGE= yes
post-install:
@${MKDIR} ${EXAMPLESDIR}
- @for i in ${WRKSRC}/eg/*forking; do \
+ for i in ${WRKSRC}/eg/*forking; do \
${PERL} -pi -e '$$_ = undef if m{use FindBin}o;' \
-e 's{.FindBin::Dir(.+)$$}{/tmp$$1\nwarn "Logging to \$$logfile\\n";}o' $${i}; \
${INSTALL_SCRIPT} $${i} ${EXAMPLESDIR}; \
@@ -34,7 +34,7 @@ post-install:
.ifndef(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @for i in ${WRKSRC}/eg/*.png ${WRKSRC}/eg/*.dot; do \
+ for i in ${WRKSRC}/eg/*.png ${WRKSRC}/eg/*.dot; do \
${INSTALL_DATA} $${i} ${DOCSDIR}; \
done
.endif
diff --git a/devel/p5-Params-Check/Makefile b/devel/p5-Params-Check/Makefile
index ce75659d39ce..cbd2926b6401 100644
--- a/devel/p5-Params-Check/Makefile
+++ b/devel/p5-Params-Check/Makefile
@@ -24,7 +24,7 @@ NO_STAGE= yes
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}/
+ @${MKDIR} ${DOCSDIR}/
cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/devel/p5-Path-Class/Makefile b/devel/p5-Path-Class/Makefile
index 7ddebbb4b383..ad4fedae6aaa 100644
--- a/devel/p5-Path-Class/Makefile
+++ b/devel/p5-Path-Class/Makefile
@@ -30,7 +30,7 @@ NO_STAGE= yes
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/devel/p5-Pod-Coverage/Makefile b/devel/p5-Pod-Coverage/Makefile
index 17913a09f9ab..5a6b5399f875 100644
--- a/devel/p5-Pod-Coverage/Makefile
+++ b/devel/p5-Pod-Coverage/Makefile
@@ -29,14 +29,14 @@ PORTEXAMPLES= check_installed script-covered
NO_STAGE= yes
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}/
+ @${MKDIR} ${DOCSDIR}/
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}/
- ${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}/
+ @${MKDIR} ${EXAMPLESDIR}/
${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/examples/|} ${EXAMPLESDIR}/
- ${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
+ @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
.endif
.include <bsd.port.mk>
diff --git a/devel/p5-Proc-ProcessTable/Makefile b/devel/p5-Proc-ProcessTable/Makefile
index 189ce7f84656..ab5a1248f814 100644
--- a/devel/p5-Proc-ProcessTable/Makefile
+++ b/devel/p5-Proc-ProcessTable/Makefile
@@ -21,12 +21,10 @@ MAN3= Proc::ProcessTable::Process.3 \
PORTDOCS= README README.freebsd-kvm README.freebsd-procfs
NO_STAGE= yes
-post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/devel/p5-SVN-Web/Makefile b/devel/p5-SVN-Web/Makefile
index 9675d5a03f18..c9d13977ee99 100644
--- a/devel/p5-SVN-Web/Makefile
+++ b/devel/p5-SVN-Web/Makefile
@@ -61,7 +61,7 @@ MAN3= SVN::CHANGES.3 \
NO_STAGE= yes
post-install:
@${MKDIR} -p ${WWWDIR}
- @${CP} -r ${WRKSRC}/SVN-Web.psgi ${WRKSRC}/template ${WRKSRC}/css ${WWWDIR}
+ ${CP} -R ${WRKSRC}/SVN-Web.psgi ${WRKSRC}/template ${WRKSRC}/css ${WWWDIR}
${INSTALL_SCRIPT} ${WRKSRC}/bin/svnweb-install ${PREFIX}/bin
@${ECHO}
@${CAT} ${PKGMESSAGE}
diff --git a/devel/p5-Set-Infinite/Makefile b/devel/p5-Set-Infinite/Makefile
index fd8c22562cd2..666ba5163142 100644
--- a/devel/p5-Set-Infinite/Makefile
+++ b/devel/p5-Set-Infinite/Makefile
@@ -23,7 +23,7 @@ NO_STAGE= yes
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}/
+ @${MKDIR} ${DOCSDIR}/
cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/devel/p5-Set-Object/Makefile b/devel/p5-Set-Object/Makefile
index 67a2f4a241e4..53ef9c83a322 100644
--- a/devel/p5-Set-Object/Makefile
+++ b/devel/p5-Set-Object/Makefile
@@ -26,7 +26,7 @@ NO_STAGE= yes
post-install:
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/devel/p5-Spiffy/Makefile b/devel/p5-Spiffy/Makefile
index b700cf8e1fbe..0bb716afbdf5 100644
--- a/devel/p5-Spiffy/Makefile
+++ b/devel/p5-Spiffy/Makefile
@@ -27,7 +27,7 @@ NO_STAGE= yes
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}/
+ @${MKDIR} ${DOCSDIR}/
cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/devel/p5-Spoon/Makefile b/devel/p5-Spoon/Makefile
index 9c3136cc8687..d9069c8346b8 100644
--- a/devel/p5-Spoon/Makefile
+++ b/devel/p5-Spoon/Makefile
@@ -46,7 +46,7 @@ PORTDOCS= Changes README
post-install:
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/devel/p5-Term-ProgressBar/Makefile b/devel/p5-Term-ProgressBar/Makefile
index e36dbd11b346..7151a900630f 100644
--- a/devel/p5-Term-ProgressBar/Makefile
+++ b/devel/p5-Term-ProgressBar/Makefile
@@ -32,7 +32,7 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MEXAMPLES}
- ${MKDIR} ${EXAMPLESDIR}/
+ @${MKDIR} ${EXAMPLESDIR}/
${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}/
.endif
diff --git a/devel/p5-Test-Tester/Makefile b/devel/p5-Test-Tester/Makefile
index 64458ad1701b..104a4c07cfd6 100644
--- a/devel/p5-Test-Tester/Makefile
+++ b/devel/p5-Test-Tester/Makefile
@@ -25,7 +25,7 @@ PORTDOCS= CHANGES
post-install:
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/devel/p5-TheSchwartz/Makefile b/devel/p5-TheSchwartz/Makefile
index 749ab05b9efc..a8b66fac6a33 100644
--- a/devel/p5-TheSchwartz/Makefile
+++ b/devel/p5-TheSchwartz/Makefile
@@ -26,7 +26,7 @@ post-install:
${INSTALL_SCRIPT} ${WRKSRC}/extras/check_schwartz ${PREFIX}/bin/
${INSTALL_SCRIPT} ${WRKSRC}/extras/thetop ${PREFIX}/bin/
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}/
.endif
diff --git a/devel/p5-Time-Local/Makefile b/devel/p5-Time-Local/Makefile
index 0a687e2638f0..3d8e211afe22 100644
--- a/devel/p5-Time-Local/Makefile
+++ b/devel/p5-Time-Local/Makefile
@@ -27,7 +27,7 @@ NO_STAGE= yes
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}/
+ @${MKDIR} ${DOCSDIR}/
cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif