aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/mingw32-openssl/Makefile44
-rw-r--r--devel/mingw32-openssl/distinfo8
-rw-r--r--devel/mingw32-openssl/pkg-descr4
-rw-r--r--devel/mingw32-openssl/pkg-plist93
5 files changed, 150 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c04b64d3cebb..9e9f54640422 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1038,6 +1038,7 @@
SUBDIR += mingw32-gcc
SUBDIR += mingw32-libffi
SUBDIR += mingw32-libyaml
+ SUBDIR += mingw32-openssl
SUBDIR += mingw32-pdcurses
SUBDIR += mingw32-pthreads
SUBDIR += mingw32-zlib
diff --git a/devel/mingw32-openssl/Makefile b/devel/mingw32-openssl/Makefile
new file mode 100644
index 000000000000..efc8d5b6f0b6
--- /dev/null
+++ b/devel/mingw32-openssl/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: mingw32-openssl
+# Date created: 5 December 2011
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openssl
+PORTVERSION= 1.0.0e
+CATEGORIES= devel security
+MASTER_SITES= http://www.openssl.org/%SUBDIR%/ \
+ ftp://ftp.openssl.org/%SUBDIR%/ \
+ ftp://ftp.cert.dfn.de/pub/tools/net/openssl/%SUBDIR%/
+MASTER_SITE_SUBDIR= source
+PKGNAMEPREFIX= mingw32-
+DIST_SUBDIR= ${DISTNAME}2
+
+PATCH_SITES= http://sctp.fh-muenster.de/dtls/
+PATCHFILES= dtls-manual-mtu-bug-1.0.0.patch \
+ dtls-ecc-key-bug-1.0.0.patch \
+ dtls-fragment-assert-bug-1.0.0.patch
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= The OpenSSL library cross-compiled for MinGW32
+
+BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend \
+ ${PKGNAMEPREFIX}gcc:${PORTSDIR}/devel/${PKGNAMEPREFIX}gcc \
+ ${LOCALBASE}/mingw32/lib/libz.a:${PORTSDIR}/devel/mingw32-zlib
+
+USE_PERL5_BUILD= yes
+MAKE_JOBS_UNSAFE= yes
+CONFIGURE_PREFIX= ${PREFIX}/mingw32
+OPENSSLDIR= ${CONFIGURE_PREFIX}/openssl
+INSTALL_TARGET= install_sw
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|m4 -B 8192|m4|g' \
+ ${WRKSRC}/crypto/des/Makefile
+
+do-configure:
+ cd ${WRKSRC} && ${SETENV} PERL="${PERL}" CROSS_COMPILE="${PKGNAMEPREFIX}" \
+ ./Configure mingw --prefix="${CONFIGURE_PREFIX}" --openssldir="${OPENSSLDIR}"
+
+.include <bsd.port.mk>
diff --git a/devel/mingw32-openssl/distinfo b/devel/mingw32-openssl/distinfo
new file mode 100644
index 000000000000..ea6e8e7daeba
--- /dev/null
+++ b/devel/mingw32-openssl/distinfo
@@ -0,0 +1,8 @@
+SHA256 (openssl-1.0.0e2/openssl-1.0.0e.tar.gz) = e361dc2775733fb84de7b5bf7b504778b772869e8f7bfac0b28b935cbf7380f7
+SIZE (openssl-1.0.0e2/openssl-1.0.0e.tar.gz) = 4040229
+SHA256 (openssl-1.0.0e2/dtls-manual-mtu-bug-1.0.0.patch) = b28d5810bc6aad1427c0d1464ae4d652befac818e72e50f8ca4f16028ea1d720
+SIZE (openssl-1.0.0e2/dtls-manual-mtu-bug-1.0.0.patch) = 2513
+SHA256 (openssl-1.0.0e2/dtls-ecc-key-bug-1.0.0.patch) = 92c1659fa92308107bee95dadc9f0a8a05fddd02b7b3d0b620b5337f41245b5d
+SIZE (openssl-1.0.0e2/dtls-ecc-key-bug-1.0.0.patch) = 500
+SHA256 (openssl-1.0.0e2/dtls-fragment-assert-bug-1.0.0.patch) = ee95a8a3c1b2d331f0774930dd9faeb48b940886fb764724daee6045ff7c5714
+SIZE (openssl-1.0.0e2/dtls-fragment-assert-bug-1.0.0.patch) = 835
diff --git a/devel/mingw32-openssl/pkg-descr b/devel/mingw32-openssl/pkg-descr
new file mode 100644
index 000000000000..8dea4be85495
--- /dev/null
+++ b/devel/mingw32-openssl/pkg-descr
@@ -0,0 +1,4 @@
+This is the OpenSSL library cross-compiled for MinGW32.
+
+WWW: http://www.openssl.org/
+WWW: http://sctp.fh-muenster.de/dtls-patches.html
diff --git a/devel/mingw32-openssl/pkg-plist b/devel/mingw32-openssl/pkg-plist
new file mode 100644
index 000000000000..4f8f6e3877b0
--- /dev/null
+++ b/devel/mingw32-openssl/pkg-plist
@@ -0,0 +1,93 @@
+mingw32/bin/c_rehash
+mingw32/bin/openssl.exe
+mingw32/include/openssl/aes.h
+mingw32/include/openssl/asn1.h
+mingw32/include/openssl/asn1_mac.h
+mingw32/include/openssl/asn1t.h
+mingw32/include/openssl/bio.h
+mingw32/include/openssl/blowfish.h
+mingw32/include/openssl/bn.h
+mingw32/include/openssl/buffer.h
+mingw32/include/openssl/camellia.h
+mingw32/include/openssl/cast.h
+mingw32/include/openssl/cms.h
+mingw32/include/openssl/comp.h
+mingw32/include/openssl/conf.h
+mingw32/include/openssl/conf_api.h
+mingw32/include/openssl/crypto.h
+mingw32/include/openssl/des.h
+mingw32/include/openssl/des_old.h
+mingw32/include/openssl/dh.h
+mingw32/include/openssl/dsa.h
+mingw32/include/openssl/dso.h
+mingw32/include/openssl/dtls1.h
+mingw32/include/openssl/e_os2.h
+mingw32/include/openssl/ebcdic.h
+mingw32/include/openssl/ec.h
+mingw32/include/openssl/ecdh.h
+mingw32/include/openssl/ecdsa.h
+mingw32/include/openssl/engine.h
+mingw32/include/openssl/err.h
+mingw32/include/openssl/evp.h
+mingw32/include/openssl/hmac.h
+mingw32/include/openssl/idea.h
+mingw32/include/openssl/krb5_asn.h
+mingw32/include/openssl/kssl.h
+mingw32/include/openssl/lhash.h
+mingw32/include/openssl/md4.h
+mingw32/include/openssl/md5.h
+mingw32/include/openssl/mdc2.h
+mingw32/include/openssl/modes.h
+mingw32/include/openssl/obj_mac.h
+mingw32/include/openssl/objects.h
+mingw32/include/openssl/ocsp.h
+mingw32/include/openssl/opensslconf.h
+mingw32/include/openssl/opensslv.h
+mingw32/include/openssl/ossl_typ.h
+mingw32/include/openssl/pem.h
+mingw32/include/openssl/pem2.h
+mingw32/include/openssl/pkcs12.h
+mingw32/include/openssl/pkcs7.h
+mingw32/include/openssl/pqueue.h
+mingw32/include/openssl/rand.h
+mingw32/include/openssl/rc2.h
+mingw32/include/openssl/rc4.h
+mingw32/include/openssl/ripemd.h
+mingw32/include/openssl/rsa.h
+mingw32/include/openssl/safestack.h
+mingw32/include/openssl/seed.h
+mingw32/include/openssl/sha.h
+mingw32/include/openssl/ssl.h
+mingw32/include/openssl/ssl2.h
+mingw32/include/openssl/ssl23.h
+mingw32/include/openssl/ssl3.h
+mingw32/include/openssl/stack.h
+mingw32/include/openssl/symhacks.h
+mingw32/include/openssl/tls1.h
+mingw32/include/openssl/ts.h
+mingw32/include/openssl/txt_db.h
+mingw32/include/openssl/ui.h
+mingw32/include/openssl/ui_compat.h
+mingw32/include/openssl/whrlpool.h
+mingw32/include/openssl/x509.h
+mingw32/include/openssl/x509_vfy.h
+mingw32/include/openssl/x509v3.h
+mingw32/lib/libcrypto.a
+mingw32/lib/libssl.a
+mingw32/lib/pkgconfig/libcrypto.pc
+mingw32/lib/pkgconfig/libssl.pc
+mingw32/lib/pkgconfig/openssl.pc
+mingw32/openssl/misc/CA.pl
+mingw32/openssl/misc/CA.sh
+mingw32/openssl/misc/c_hash
+mingw32/openssl/misc/c_info
+mingw32/openssl/misc/c_issuer
+mingw32/openssl/misc/c_name
+mingw32/openssl/misc/tsget
+mingw32/openssl/openssl.cnf
+@dirrm mingw32/include/openssl
+@dirrm mingw32/lib/engines
+@dirrmtry mingw32/openssl/certs
+@dirrm mingw32/openssl/misc
+@dirrmtry mingw32/openssl/private
+@dirrm mingw32/openssl