aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-crc32c/Makefile15
-rw-r--r--devel/py-crc32c/distinfo3
-rw-r--r--devel/py-crc32c/pkg-descr7
4 files changed, 26 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5552c81d79a2..767056ae5859 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4355,6 +4355,7 @@
SUBDIR += py-coverage
SUBDIR += py-crank
SUBDIR += py-crcmod
+ SUBDIR += py-crc32c
SUBDIR += py-ctags
SUBDIR += py-cuisine
SUBDIR += py-cursive
diff --git a/devel/py-crc32c/Makefile b/devel/py-crc32c/Makefile
new file mode 100644
index 000000000000..06b744f93e1e
--- /dev/null
+++ b/devel/py-crc32c/Makefile
@@ -0,0 +1,15 @@
+# $FreeBSD$
+
+PORTNAME= crc32c
+PORTVERSION= 1.7
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Python package exposing the intel sse4.2 crc32c instruction
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/devel/py-crc32c/distinfo b/devel/py-crc32c/distinfo
new file mode 100644
index 000000000000..3cf67b92fafb
--- /dev/null
+++ b/devel/py-crc32c/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1570799287
+SHA256 (crc32c-1.7.tar.gz) = bdcd28f26b62838919480d465a0d166207a36c4f104102a0b6edf5b498544d36
+SIZE (crc32c-1.7.tar.gz) = 24620
diff --git a/devel/py-crc32c/pkg-descr b/devel/py-crc32c/pkg-descr
new file mode 100644
index 000000000000..912697c7a8fd
--- /dev/null
+++ b/devel/py-crc32c/pkg-descr
@@ -0,0 +1,7 @@
+This package exposes to Python the crc32c algorithm implemented in the SSE 4.2
+instruction set of Intel CPUs.
+
+By default, if your CPU doesn't support this instruction, the package will fail
+to load with an ImportError. If you still need to use the crc32c checksum
+algorithm this package comes with a software implementation that can be loaded
+instead.