aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/pcre/Makefile11
-rw-r--r--devel/pcre/distinfo2
-rw-r--r--devel/pcre/files/patch-aa73
-rw-r--r--devel/pcre/pkg-plist2
4 files changed, 57 insertions, 31 deletions
diff --git a/devel/pcre/Makefile b/devel/pcre/Makefile
index 94ea234ff93e..40b7632ca68b 100644
--- a/devel/pcre/Makefile
+++ b/devel/pcre/Makefile
@@ -6,21 +6,16 @@
#
PORTNAME= pcre
-PORTVERSION= 3.1
+PORTVERSION= 3.4
CATEGORIES= devel
MASTER_SITES= ftp://ftp.cus.cam.ac.uk/pub/software/programs/pcre/
MAINTAINER= dom@myrddin.demon.co.uk
-# Implies GNU_CONFIGURE.
+USE_BZIP2= yes
USE_LIBTOOL= yes
MAN3= pcre.3 pcreposix.3
-MAN1= pgrep.1
-
-# Otherwise we get a broken pgrep shell script installed
-# instead of the binary we really want.
-pre-install:
- @${LN} -f ${WRKSRC}/.libs/pgrep ${WRKSRC}/pgrep
+MAN1= pcregrep.1
.include <bsd.port.mk>
diff --git a/devel/pcre/distinfo b/devel/pcre/distinfo
index 7725c99048df..53b017368c24 100644
--- a/devel/pcre/distinfo
+++ b/devel/pcre/distinfo
@@ -1 +1 @@
-MD5 (pcre-3.1.tar.gz) = e24369e30177e2580dac9fe655dd8ad8
+MD5 (pcre-3.4.tar.bz2) = 477c8e7fda57dd0a1a4b9d226b386812
diff --git a/devel/pcre/files/patch-aa b/devel/pcre/files/patch-aa
index 1ea9b24fb684..d657d547ed7e 100644
--- a/devel/pcre/files/patch-aa
+++ b/devel/pcre/files/patch-aa
@@ -1,7 +1,7 @@
---- Makefile.in.orig Wed Feb 9 10:44:58 2000
-+++ Makefile.in Thu Mar 9 22:32:11 2000
-@@ -42,7 +42,7 @@
- # is set to "la" instead of "a", which causes the shared libraries to be
+--- Makefile.in.orig Tue Aug 22 05:05:43 2000
++++ Makefile.in Sun Dec 3 19:27:54 2000
+@@ -43,7 +43,7 @@
+ # is set to "a" instead of "la", which causes the shared libraries not to be
# installed.
-LIBTOOL = @LIBTOOL@
@@ -9,36 +9,67 @@
LIBSUFFIX = @LIBSUFFIX@
# These are the version numbers for the shared libraries
-@@ -76,13 +76,7 @@
+@@ -56,8 +56,10 @@
+ # A copy of install-sh is in this distribution and is used by default. #
+ #---------------------------------------------------------------------------#
+
+-INSTALL = ./install-sh -c
+-INSTALL_DATA = ${INSTALL} -m 644
++INSTALL_PROGRAM = ${BSD_INSTALL_PROGRAM}
++INSTALL_SCRIPT = ${BSD_INSTALL_SCRIPT}
++INSTALL_DATA = ${BSD_INSTALL_DATA}
++INSTALL_MAN = ${BSD_INSTALL_MAN}
+
+
+ #---------------------------------------------------------------------------#
+@@ -78,7 +80,7 @@
OBJ = maketables.o get.o study.o pcre.o
LOBJ = maketables.lo get.lo study.lo pcre.lo
--all: libtool libpcre.$(LIBSUFFIX) libpcreposix.$(LIBSUFFIX) pcretest pgrep
--
--libtool: config.guess config.sub ltconfig ltmain.sh
-- @if test "$(LIBTOOL)" = "libtool"; then \
-- echo '--- Building libtool ---'; \
-- ./ltconfig ./ltmain.sh; \
-- echo '--- Built libtool ---'; fi
-+all: libpcre.$(LIBSUFFIX) libpcreposix.$(LIBSUFFIX) pcretest pgrep
-
- pgrep: libpcre.$(LIBSUFFIX) pgrep.o
- @echo ' '
-@@ -110,7 +104,7 @@
+-all: libtool libpcre.$(LIBSUFFIX) libpcreposix.$(LIBSUFFIX) pcretest pcregrep
++all: libpcre.$(LIBSUFFIX) libpcreposix.$(LIBSUFFIX) pcretest pcregrep
+
+ libtool: config.guess config.sub ltconfig ltmain.sh
+ @if test "$(LIBTOOL)" = "./libtool"; then \
+@@ -112,7 +114,7 @@
@echo '--- Building shared library: libpcre'
@echo ' '
-rm -f libpcre.la
-- libtool $(CC) -version-info '$(PCRELIBVERSION)' -o libpcre.la -rpath $(LIBDIR) $(LOBJ)
+- ./libtool $(CC) -version-info '$(PCRELIBVERSION)' -o libpcre.la -rpath $(LIBDIR) $(LOBJ)
+ $(LIBTOOL) $(CC) -version-info '$(PCRELIBVERSION)' -o libpcre.la -rpath $(LIBDIR) $(LOBJ)
libpcreposix.a: pcreposix.o
@echo ' '
-@@ -125,7 +119,7 @@
+@@ -127,7 +129,7 @@
@echo '--- Building shared library: libpcreposix'
@echo ' '
-rm -f libpcreposix.la
-- libtool $(CC) -version-info '$(PCREPOSIXLIBVERSION)' -o libpcreposix.la -rpath $(LIBDIR) pcreposix.lo
+- ./libtool $(CC) -version-info '$(PCREPOSIXLIBVERSION)' -o libpcreposix.la -rpath $(LIBDIR) pcreposix.lo
+ $(LIBTOOL) $(CC) -version-info '$(PCREPOSIXLIBVERSION)' -o libpcreposix.la -rpath $(LIBDIR) pcreposix.lo
pcre.o: chartables.c pcre.c pcre.h internal.h config.h Makefile
- $(LIBTOOL) $(CC) -c $(CFLAGS) pcre.c
+ $(LIBTOOL) $(CC) -c $(CFLAGS) $(UTF8) pcre.c
+@@ -163,9 +165,9 @@
+ $(LIBTOOL) $(INSTALL_DATA) libpcreposix.$(LIBSUFFIX) $(DESTDIR)/$(LIBDIR)/libpcreposix.$(LIBSUFFIX)
+ $(INSTALL_DATA) pcre.h $(DESTDIR)/$(INCDIR)/pcre.h
+ $(INSTALL_DATA) pcreposix.h $(DESTDIR)/$(INCDIR)/pcreposix.h
+- $(INSTALL_DATA) doc/pcre.3 $(DESTDIR)/$(MANDIR)/man3/pcre.3
+- $(INSTALL_DATA) doc/pcreposix.3 $(DESTDIR)/$(MANDIR)/man3/pcreposix.3
+- $(INSTALL_DATA) doc/pcregrep.1 $(DESTDIR)/$(MANDIR)/man1/pcregrep.1
++ $(INSTALL_MAN) doc/pcre.3 $(DESTDIR)/$(MANDIR)/man3/pcre.3
++ $(INSTALL_MAN) doc/pcreposix.3 $(DESTDIR)/$(MANDIR)/man3/pcreposix.3
++ $(INSTALL_MAN) doc/pcregrep.1 $(DESTDIR)/$(MANDIR)/man1/pcregrep.1
+ @if test "$(LIBTOOL)" = "./libtool"; then \
+ echo ' '; \
+ echo '--- Rebuilding pcregrep to use installed shared library ---'; \
+@@ -175,8 +177,8 @@
+ echo $(CC) $(CFLAGS) -o pcretest pcretest.o -L$(DESTDIR)/$(LIBDIR) -lpcre -lpcreposix; \
+ $(CC) $(CFLAGS) -o pcretest pcretest.o -L$(DESTDIR)/$(LIBDIR) -lpcre -lpcreposix; \
+ fi
+- $(INSTALL) pcregrep $(DESTDIR)/$(BINDIR)/pcregrep
+- $(INSTALL) pcre-config $(DESTDIR)/$(BINDIR)/pcre-config
++ $(INSTALL_PROGRAM) .libs/pcregrep $(DESTDIR)/$(BINDIR)/pcregrep
++ $(INSTALL_SCRIPT) pcre-config $(DESTDIR)/$(BINDIR)/pcre-config
+
+ # We deliberately omit dftables and chartables.c from 'make clean'; once made
+ # chartables.c shouldn't change, and if people have edited the tables by hand,
diff --git a/devel/pcre/pkg-plist b/devel/pcre/pkg-plist
index e88b5c371c28..08057291f780 100644
--- a/devel/pcre/pkg-plist
+++ b/devel/pcre/pkg-plist
@@ -1,5 +1,5 @@
bin/pcre-config
-bin/pgrep
+bin/pcregrep
include/pcre.h
include/pcreposix.h
lib/libpcre.a