aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/bugzilla/Makefile3
-rw-r--r--devel/bugzilla3/Makefile3
-rw-r--r--devel/bugzilla42/Makefile3
-rw-r--r--devel/bugzilla44/Makefile3
-rw-r--r--devel/cvsmonitor/Makefile3
-rw-r--r--devel/p5-Clone/Makefile3
-rw-r--r--devel/p5-ExtUtils-AutoInstall/Makefile3
-rw-r--r--devel/p5-MRO-Compat/Makefile3
-rw-r--r--devel/p5-Moose/Makefile3
-rw-r--r--devel/p5-Package-DeprecationManager/Makefile9
10 files changed, 21 insertions, 15 deletions
diff --git a/devel/bugzilla/Makefile b/devel/bugzilla/Makefile
index 915d973d5768..fd01b36e5518 100644
--- a/devel/bugzilla/Makefile
+++ b/devel/bugzilla/Makefile
@@ -24,7 +24,8 @@ RUN_DEPENDS= \
p5-TimeDate>=1.19:${PORTSDIR}/devel/p5-TimeDate \
p5-URI>=0:${PORTSDIR}/net/p5-URI
-USE_PERL5= yes
+USES= perl5
+USE_PERL5= patch run build
BINMODE= 700
diff --git a/devel/bugzilla3/Makefile b/devel/bugzilla3/Makefile
index 8e6d8648d9a4..0912eeb12503 100644
--- a/devel/bugzilla3/Makefile
+++ b/devel/bugzilla3/Makefile
@@ -24,7 +24,8 @@ RUN_DEPENDS= \
LATEST_LINK= bugzilla3
-USE_PERL5= yes
+USES= perl5
+USE_PERL5= patch run build
BINMODE= 700
diff --git a/devel/bugzilla42/Makefile b/devel/bugzilla42/Makefile
index 669b86307688..89d0f8c3ec40 100644
--- a/devel/bugzilla42/Makefile
+++ b/devel/bugzilla42/Makefile
@@ -27,7 +27,8 @@ RUN_DEPENDS= \
LATEST_LINK= bugzilla42
-USE_PERL5= yes
+USES= perl5
+USE_PERL5= patch run build
BINMODE= 700
diff --git a/devel/bugzilla44/Makefile b/devel/bugzilla44/Makefile
index b301ad94bdae..ab08c85eb527 100644
--- a/devel/bugzilla44/Makefile
+++ b/devel/bugzilla44/Makefile
@@ -27,7 +27,8 @@ RUN_DEPENDS= \
LATEST_LINK= bugzilla44
-USE_PERL5= yes
+USES= perl5
+USE_PERL5= patch build run
BINMODE= 700
diff --git a/devel/cvsmonitor/Makefile b/devel/cvsmonitor/Makefile
index 3ad818a43341..d978dbd94979 100644
--- a/devel/cvsmonitor/Makefile
+++ b/devel/cvsmonitor/Makefile
@@ -43,7 +43,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
+USE_PERL5= patch run build
# stolen from cvsweb
.if !exists(${PREFIX}/www) && exists(${PREFIX}/share/apache)
diff --git a/devel/p5-Clone/Makefile b/devel/p5-Clone/Makefile
index 49a3f3c4a25c..d53c0a3892a5 100644
--- a/devel/p5-Clone/Makefile
+++ b/devel/p5-Clone/Makefile
@@ -9,7 +9,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Clone - recursively copy Perl datatypes
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= patch configure
MAN3= Clone.3
diff --git a/devel/p5-ExtUtils-AutoInstall/Makefile b/devel/p5-ExtUtils-AutoInstall/Makefile
index 4d8135ff917d..94e16dff9818 100644
--- a/devel/p5-ExtUtils-AutoInstall/Makefile
+++ b/devel/p5-ExtUtils-AutoInstall/Makefile
@@ -14,7 +14,8 @@ COMMENT= Automatic install of dependencies via CPAN
BUILD_DEPENDS= p5-version>=0.28:${PORTSDIR}/devel/p5-version
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= extract configure
MAN3= ExtUtils::AutoInstall.3
diff --git a/devel/p5-MRO-Compat/Makefile b/devel/p5-MRO-Compat/Makefile
index 3b106848ee98..d5c7b6b6b523 100644
--- a/devel/p5-MRO-Compat/Makefile
+++ b/devel/p5-MRO-Compat/Makefile
@@ -14,7 +14,8 @@ COMMENT= Add mro::* interface compatibility for Perls < 5.9.5
BUILD_DEPENDS= p5-Class-C3>=0.19:${PORTSDIR}/devel/p5-Class-C3
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= extract configure
MAN3= MRO::Compat.3
diff --git a/devel/p5-Moose/Makefile b/devel/p5-Moose/Makefile
index 8d8675a5ed70..aa0860cc31a3 100644
--- a/devel/p5-Moose/Makefile
+++ b/devel/p5-Moose/Makefile
@@ -41,7 +41,8 @@ TEST_DEPENDS= \
CFLAGS+= -I. # mop.h
MAKE_JOBS_UNSAFE= yes
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure extract
MAN3= Class::MOP.3 \
Class::MOP::Attribute.3 \
diff --git a/devel/p5-Package-DeprecationManager/Makefile b/devel/p5-Package-DeprecationManager/Makefile
index 06730713a95a..b38a43908d75 100644
--- a/devel/p5-Package-DeprecationManager/Makefile
+++ b/devel/p5-Package-DeprecationManager/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Package-DeprecationManager
-# Date created: 05 August 2010
-# Whom: Frederic Culot <frederic@culot.org>
-#
+# Created by: Frederic Culot <frederic@culot.org>
# $FreeBSD$
-#
PORTNAME= Package-DeprecationManager
PORTVERSION= 0.13
@@ -26,7 +22,8 @@ RUN_DEPENDS= p5-Params-Util>=0:${PORTSDIR}/devel/p5-Params-Util \
TEST_DEPENDS= p5-Test-Fatal>=0:${PORTSDIR}/devel/p5-Test-Fatal \
p5-Test-Requires>=0:${PORTSDIR}/devel/p5-Test-Requires
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure extract
MAN3= Package::DeprecationManager.3