aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/boost-libs/Makefile2
-rw-r--r--devel/dee/Makefile2
-rw-r--r--devel/glib20/Makefile2
-rw-r--r--devel/hs-text-icu/Makefile2
-rw-r--r--devel/icu/Makefile2
-rw-r--r--devel/icu/distinfo6
-rw-r--r--devel/icu/files/patch-layout_Makefile.in11
-rw-r--r--devel/icu/files/patch-r39484148
-rw-r--r--devel/icu/pkg-plist26
-rw-r--r--devel/objecthash/Makefile2
-rw-r--r--devel/pecl-intl/Makefile2
-rw-r--r--devel/php70-intl/Makefile1
-rw-r--r--devel/py-pyicu/Makefile6
-rw-r--r--devel/qt4-corelib/Makefile2
-rw-r--r--devel/qt5-core/Makefile1
15 files changed, 168 insertions, 47 deletions
diff --git a/devel/boost-libs/Makefile b/devel/boost-libs/Makefile
index ed404574195d..0547b9bf16b2 100644
--- a/devel/boost-libs/Makefile
+++ b/devel/boost-libs/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= boost-libs
-PORTREVISION= 13
+PORTREVISION= 14
COMMENT= Free portable C++ libraries (without Boost.Python)
diff --git a/devel/dee/Makefile b/devel/dee/Makefile
index 327b6b835ce9..8c1b11b1ad75 100644
--- a/devel/dee/Makefile
+++ b/devel/dee/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dee
PORTVERSION= 1.2.7
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= devel
MASTER_SITES= https://launchpadlibrarian.net/151383425/ \
https://launchpad.net/${PORTNAME}/1.0/${PORTVERSION}/+download/
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index 95e17742600c..27ccb65c7e3b 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -3,7 +3,7 @@
PORTNAME= glib
PORTVERSION= 2.46.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/devel/hs-text-icu/Makefile b/devel/hs-text-icu/Makefile
index 6be718ab0c04..9406d8649efc 100644
--- a/devel/hs-text-icu/Makefile
+++ b/devel/hs-text-icu/Makefile
@@ -2,7 +2,7 @@
PORTNAME= text-icu
PORTVERSION= 0.7.0.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/devel/icu/Makefile b/devel/icu/Makefile
index 5e4ab3da709d..232784f39960 100644
--- a/devel/icu/Makefile
+++ b/devel/icu/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= icu
-DISTVERSION= 57_1
+DISTVERSION= 58_1
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= http://download.icu-project.org/files/icu4c/${PORTVERSION}/
diff --git a/devel/icu/distinfo b/devel/icu/distinfo
index 26b29c40a625..c32b0fdfa7f5 100644
--- a/devel/icu/distinfo
+++ b/devel/icu/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1464596691
-SHA256 (icu4c-57_1-src.tgz) = ff8c67cb65949b1e7808f2359f2b80f722697048e90e7cfc382ec1fe229e9581
-SIZE (icu4c-57_1-src.tgz) = 22360664
+TIMESTAMP = 1478684146
+SHA256 (icu4c-58_1-src.tgz) = 0eb46ba3746a9c2092c8ad347a29b1a1b4941144772d13a88667a7b11ea30309
+SIZE (icu4c-58_1-src.tgz) = 23366443
diff --git a/devel/icu/files/patch-layout_Makefile.in b/devel/icu/files/patch-layout_Makefile.in
deleted file mode 100644
index d5c881287eb5..000000000000
--- a/devel/icu/files/patch-layout_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- layout/Makefile.in.orig 2016-03-23 20:56:48 UTC
-+++ layout/Makefile.in
-@@ -180,7 +180,7 @@ install-local: install-headers install-l
- install-library: all-local
- $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
- ifneq ($(ENABLE_STATIC),)
-- $(INSTALL-L) $(TARGET) $(DESTDIR)$(libdir)
-+ $(INSTALL_DATA) $(TARGET) $(DESTDIR)$(libdir)
- endif
- ifneq ($(ENABLE_SHARED),)
- $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(libdir)
diff --git a/devel/icu/files/patch-r39484 b/devel/icu/files/patch-r39484
new file mode 100644
index 000000000000..9a2ffabbebe6
--- /dev/null
+++ b/devel/icu/files/patch-r39484
@@ -0,0 +1,148 @@
+https://ssl.icu-project.org/trac/ticket/12827
+
+Index: test/intltest/apicoll.h
+===================================================================
+--- test/intltest/apicoll.h (revision 39483)
++++ test/intltest/apicoll.h (revision 39484)
+@@ -35,6 +35,7 @@ class CollationAPITest: public IntlTestCollator {
+ * - displayable name in the desired locale
+ */
+ void TestProperty(/* char* par */);
++ void TestKeywordValues();
+
+ /**
+ * This tests the RuleBasedCollator
+Index: test/intltest/apicoll.cpp
+===================================================================
+--- test/intltest/apicoll.cpp (revision 39483)
++++ test/intltest/apicoll.cpp (revision 39484)
+@@ -81,17 +81,10 @@ CollationAPITest::TestProperty(/* char* par */)
+ logln("Test ctors : ");
+ col = Collator::createInstance(Locale::getEnglish(), success);
+ if (U_FAILURE(success)){
+- errcheckln(success, "Default Collator creation failed. - %s", u_errorName(success));
++ errcheckln(success, "English Collator creation failed. - %s", u_errorName(success));
+ return;
+ }
+
+- StringEnumeration* kwEnum = col->getKeywordValuesForLocale("", Locale::getEnglish(),true,success);
+- if (U_FAILURE(success)){
+- errcheckln(success, "Get Keyword Values for Locale failed. - %s", u_errorName(success));
+- return;
+- }
+- delete kwEnum;
+-
+ col->getVersion(versionArray);
+ // Check for a version greater than some value rather than equality
+ // so that we need not update the expected version each time.
+@@ -231,6 +224,29 @@ CollationAPITest::TestProperty(/* char* par */)
+ delete junk;
+ }
+
++void CollationAPITest::TestKeywordValues() {
++ IcuTestErrorCode errorCode(*this, "TestKeywordValues");
++ LocalPointer<Collator> col(Collator::createInstance(Locale::getEnglish(), errorCode));
++ if (errorCode.logIfFailureAndReset("English Collator creation failed")) {
++ return;
++ }
++
++ LocalPointer<StringEnumeration> kwEnum(
++ col->getKeywordValuesForLocale("collation", Locale::getEnglish(), TRUE, errorCode));
++ if (errorCode.logIfFailureAndReset("Get Keyword Values for English Collator failed")) {
++ return;
++ }
++ assertTrue("expect at least one collation tailoring for English", kwEnum->count(errorCode) > 0);
++ const char *kw;
++ UBool hasStandard = FALSE;
++ while ((kw = kwEnum->next(NULL, errorCode)) != NULL) {
++ if (strcmp(kw, "standard") == 0) {
++ hasStandard = TRUE;
++ }
++ }
++ assertTrue("expect at least the 'standard' collation tailoring for English", hasStandard);
++}
++
+ void
+ CollationAPITest::TestRuleBasedColl()
+ {
+@@ -2466,6 +2482,7 @@ void CollationAPITest::runIndexedTest( int32_t ind
+ if (exec) logln("TestSuite CollationAPITest: ");
+ TESTCASE_AUTO_BEGIN;
+ TESTCASE_AUTO(TestProperty);
++ TESTCASE_AUTO(TestKeywordValues);
+ TESTCASE_AUTO(TestOperators);
+ TESTCASE_AUTO(TestDuplicate);
+ TESTCASE_AUTO(TestCompare);
+Index: i18n/ucol_res.cpp
+===================================================================
+--- i18n/ucol_res.cpp (revision 39483)
++++ i18n/ucol_res.cpp (revision 39484)
+@@ -680,6 +680,7 @@ ucol_getKeywordValuesForLocale(const char* /*key*/
+ return NULL;
+ }
+ memcpy(en, &defaultKeywordValues, sizeof(UEnumeration));
++ ulist_resetList(sink.values); // Initialize the iterator.
+ en->context = sink.values;
+ sink.values = NULL; // Avoid deletion in the sink destructor.
+ return en;
+Index: common/ulist.c
+===================================================================
+--- common/ulist.c (revision 39483)
++++ common/ulist.c (revision 39484)
+@@ -29,7 +29,6 @@ struct UList {
+ UListNode *tail;
+
+ int32_t size;
+- int32_t currentIndex;
+ };
+
+ static void ulist_addFirstItem(UList *list, UListNode *newItem);
+@@ -51,7 +50,6 @@ U_CAPI UList *U_EXPORT2 ulist_createEmptyList(UErr
+ newList->head = NULL;
+ newList->tail = NULL;
+ newList->size = 0;
+- newList->currentIndex = -1;
+
+ return newList;
+ }
+@@ -80,8 +78,9 @@ static void ulist_removeItem(UList *list, UListNod
+ } else {
+ p->next->previous = p->previous;
+ }
+- list->curr = NULL;
+- list->currentIndex = 0;
++ if (p == list->curr) {
++ list->curr = p->next;
++ }
+ --list->size;
+ if (p->forceDelete) {
+ uprv_free(p->data);
+@@ -150,7 +149,6 @@ U_CAPI void U_EXPORT2 ulist_addItemBeginList(UList
+ newItem->next = list->head;
+ list->head->previous = newItem;
+ list->head = newItem;
+- list->currentIndex++;
+ }
+
+ list->size++;
+@@ -193,7 +191,6 @@ U_CAPI void *U_EXPORT2 ulist_getNext(UList *list)
+
+ curr = list->curr;
+ list->curr = curr->next;
+- list->currentIndex++;
+
+ return curr->data;
+ }
+@@ -209,7 +206,6 @@ U_CAPI int32_t U_EXPORT2 ulist_getListSize(const U
+ U_CAPI void U_EXPORT2 ulist_resetList(UList *list) {
+ if (list != NULL) {
+ list->curr = list->head;
+- list->currentIndex = 0;
+ }
+ }
+
+@@ -272,4 +268,3 @@ U_CAPI void U_EXPORT2 ulist_reset_keyword_values_i
+ U_CAPI UList * U_EXPORT2 ulist_getListFromEnum(UEnumeration *en) {
+ return (UList *)(en->context);
+ }
+-
diff --git a/devel/icu/pkg-plist b/devel/icu/pkg-plist
index ba1c6ac0b102..b4d1e7191688 100644
--- a/devel/icu/pkg-plist
+++ b/devel/icu/pkg-plist
@@ -15,14 +15,6 @@ lib/libicuio.a
lib/libicuio.so
lib/libicuio.so.%%ICUMAJOR%%
lib/libicuio.so.%%ICUVER%%
-lib/libicule.a
-lib/libicule.so
-lib/libicule.so.%%ICUMAJOR%%
-lib/libicule.so.%%ICUVER%%
-lib/libiculx.a
-lib/libiculx.so
-lib/libiculx.so.%%ICUMAJOR%%
-lib/libiculx.so.%%ICUVER%%
lib/libicutest.a
lib/libicutest.so
lib/libicutest.so.%%ICUMAJOR%%
@@ -41,25 +33,8 @@ lib/icu/Makefile.inc
lib/icu/%%ICUVER%%/pkgdata.inc
lib/icu/%%ICUVER%%/Makefile.inc
libdata/pkgconfig/icu-io.pc
-libdata/pkgconfig/icu-le.pc
libdata/pkgconfig/icu-i18n.pc
-libdata/pkgconfig/icu-lx.pc
libdata/pkgconfig/icu-uc.pc
-include/layout/LEFontInstance.h
-include/layout/LEGlyphFilter.h
-include/layout/LEGlyphStorage.h
-include/layout/LEInsertionList.h
-include/layout/LELanguages.h
-include/layout/LEScripts.h
-include/layout/LESwaps.h
-include/layout/LETableReference.h
-include/layout/LETypes.h
-include/layout/LayoutEngine.h
-include/layout/ParagraphLayout.h
-include/layout/RunArrays.h
-include/layout/loengine.h
-include/layout/playout.h
-include/layout/plruns.h
include/unicode/alphaindex.h
include/unicode/appendable.h
include/unicode/basictz.h
@@ -153,6 +128,7 @@ include/unicode/tznames.h
include/unicode/tzrule.h
include/unicode/tztrans.h
include/unicode/ubidi.h
+include/unicode/ubiditransform.h
include/unicode/ubrk.h
include/unicode/ucal.h
include/unicode/ucasemap.h
diff --git a/devel/objecthash/Makefile b/devel/objecthash/Makefile
index e27ac18900b1..8d1e8047f7b0 100644
--- a/devel/objecthash/Makefile
+++ b/devel/objecthash/Makefile
@@ -3,7 +3,7 @@
PORTNAME= objecthash
PORTVERSION= 20160121
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel
MAINTAINER= ports@FreeBSD.org
diff --git a/devel/pecl-intl/Makefile b/devel/pecl-intl/Makefile
index c1f3f6ef7b6b..e48bad6d07f6 100644
--- a/devel/pecl-intl/Makefile
+++ b/devel/pecl-intl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= intl
PORTVERSION= 3.0.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= devel pear
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
diff --git a/devel/php70-intl/Makefile b/devel/php70-intl/Makefile
index 7fbefd3675e5..b54eb5e69759 100644
--- a/devel/php70-intl/Makefile
+++ b/devel/php70-intl/Makefile
@@ -1,6 +1,7 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
+PORTREVISION= 1
CATEGORIES= devel
MASTERDIR= ${.CURDIR}/../../lang/php70
diff --git a/devel/py-pyicu/Makefile b/devel/py-pyicu/Makefile
index 0a578f4c116d..6db074739352 100644
--- a/devel/py-pyicu/Makefile
+++ b/devel/py-pyicu/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pyicu
PORTVERSION= 1.9.4
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -23,4 +24,9 @@ MAKE_ENV+= PYICU_INCLUDES="${PREFIX}/include" \
LIB_DEPENDS+= libicudata.so:devel/icu
+pre-configure:
+ @if [ ! -e ${LOCALBASE}/lib/libicule.so ]; then \
+ ${REINPLACE_CMD} "s/, 'icule'//" ${WRKSRC}/${PYSETUP}; \
+ fi
+
.include <bsd.port.mk>
diff --git a/devel/qt4-corelib/Makefile b/devel/qt4-corelib/Makefile
index 215edaa2c324..3654aa8e7d80 100644
--- a/devel/qt4-corelib/Makefile
+++ b/devel/qt4-corelib/Makefile
@@ -3,7 +3,7 @@
PORTNAME= corelib
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= devel
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt5-core/Makefile b/devel/qt5-core/Makefile
index d46aee2f0515..61fa76aec44a 100644
--- a/devel/qt5-core/Makefile
+++ b/devel/qt5-core/Makefile
@@ -2,6 +2,7 @@
PORTNAME= core
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= devel
PKGNAMEPREFIX= qt5-