aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Data-Validate/Makefile25
-rw-r--r--devel/p5-Data-Validate/distinfo3
-rw-r--r--devel/p5-Data-Validate/pkg-descr6
-rw-r--r--devel/p5-Data-Validate/pkg-plist23
5 files changed, 58 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5491e2847965..bd222213b220 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1030,6 +1030,7 @@
SUBDIR += p5-Data-TreeDumper
SUBDIR += p5-Data-Types
SUBDIR += p5-Data-UUID
+ SUBDIR += p5-Data-Validate
SUBDIR += p5-Data-Visitor
SUBDIR += p5-Date-Calc
SUBDIR += p5-Date-DayOfWeek
diff --git a/devel/p5-Data-Validate/Makefile b/devel/p5-Data-Validate/Makefile
new file mode 100644
index 000000000000..5892f91e9b6c
--- /dev/null
+++ b/devel/p5-Data-Validate/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: devel/p5-Data-Validate
+# Date created: 06 August 2007
+# Whom: Steven Kreuzer <skreuzer@exit2shell.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Validate
+PORTVERSION= 0.08
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skreuzer@exit2shell.com
+COMMENT= Common data validation methods
+
+BUILD_DEPENDS= ${SITE_PERL}/Math/BigInt.pm:${PORTSDIR}/math/p5-Math-BigInt
+RUN_DEPENDS= ${SITE_PERL}/Math/BigInt.pm:${PORTSDIR}/math/p5-Math-BigInt
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Validate.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Data-Validate/distinfo b/devel/p5-Data-Validate/distinfo
new file mode 100644
index 000000000000..643fe3ba5a1b
--- /dev/null
+++ b/devel/p5-Data-Validate/distinfo
@@ -0,0 +1,3 @@
+MD5 (Data-Validate-0.08.tar.gz) = 2ca2c8d5750b5a0725f6b483442e6bc7
+SHA256 (Data-Validate-0.08.tar.gz) = 34a9836c7b6447be97cb940ed082f73d4bffba4bb147cef7e0a1c86e62609a29
+SIZE (Data-Validate-0.08.tar.gz) = 12591
diff --git a/devel/p5-Data-Validate/pkg-descr b/devel/p5-Data-Validate/pkg-descr
new file mode 100644
index 000000000000..914d9b852f32
--- /dev/null
+++ b/devel/p5-Data-Validate/pkg-descr
@@ -0,0 +1,6 @@
+This module collects common validation routines to make input validation,
+and untainting easier and more readable. Most of the functions are not
+much shorter than their direct perl equivalent, but their names make it
+clear what you're trying to test for.
+
+WWW: http://search.cpan.org/~sonnen/Data-Validate-0.08/
diff --git a/devel/p5-Data-Validate/pkg-plist b/devel/p5-Data-Validate/pkg-plist
new file mode 100644
index 000000000000..c0ad920d2dc6
--- /dev/null
+++ b/devel/p5-Data-Validate/pkg-plist
@@ -0,0 +1,23 @@
+%%SITE_PERL%%/Data/Validate.pm
+%%SITE_PERL%%/auto/Data/Validate/autosplit.ix
+%%SITE_PERL%%/auto/Data/Validate/is_alphanumeric.al
+%%SITE_PERL%%/auto/Data/Validate/is_between.al
+%%SITE_PERL%%/auto/Data/Validate/is_equal_to.al
+%%SITE_PERL%%/auto/Data/Validate/is_even.al
+%%SITE_PERL%%/auto/Data/Validate/is_greater_than.al
+%%SITE_PERL%%/auto/Data/Validate/is_hex.al
+%%SITE_PERL%%/auto/Data/Validate/is_integer.al
+%%SITE_PERL%%/auto/Data/Validate/is_less_than.al
+%%SITE_PERL%%/auto/Data/Validate/is_numeric.al
+%%SITE_PERL%%/auto/Data/Validate/is_oct.al
+%%SITE_PERL%%/auto/Data/Validate/is_odd.al
+%%SITE_PERL%%/auto/Data/Validate/is_printable.al
+%%SITE_PERL%%/auto/Data/Validate/length_is_between.al
+%%SITE_PERL%%/auto/Data/Validate/new.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Validate/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Validate
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto
+@dirrmtry %%SITE_PERL%%/auto/Data/Validate
+@dirrmtry %%SITE_PERL%%/auto/Data
+@dirrmtry %%SITE_PERL%%/Data