aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Log-Dispatch-Colorful/Makefile26
-rw-r--r--devel/p5-Log-Dispatch-Colorful/distinfo3
-rw-r--r--devel/p5-Log-Dispatch-Colorful/pkg-descr3
-rw-r--r--devel/p5-Log-Dispatch-Colorful/pkg-plist5
5 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 414aef054fde..2fb1701bab5a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1487,6 +1487,7 @@
SUBDIR += p5-Log-Agent
SUBDIR += p5-Log-Agent-Logger
SUBDIR += p5-Log-Dispatch
+ SUBDIR += p5-Log-Dispatch-Colorful
SUBDIR += p5-Log-Dispatch-Config
SUBDIR += p5-Log-Dispatch-Configurator-YAML
SUBDIR += p5-Log-Dispatch-Email-EmailSend
diff --git a/devel/p5-Log-Dispatch-Colorful/Makefile b/devel/p5-Log-Dispatch-Colorful/Makefile
new file mode 100644
index 000000000000..5ad04de7ba4f
--- /dev/null
+++ b/devel/p5-Log-Dispatch-Colorful/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Log::Dispatch::Colorful
+# Date created: 22 Jan 2009
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Log-Dispatch-Colorful
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for logging to screen
+
+RUN_DEPENDS= \
+ p5-Log-Dispatch>0:${PORTSDIR}/devel/p5-Log-Dispatch \
+ p5-Params-Validate>0:${PORTSDIR}/devel/p5-Params-Validate
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Log::Dispatch::Colorful.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Log-Dispatch-Colorful/distinfo b/devel/p5-Log-Dispatch-Colorful/distinfo
new file mode 100644
index 000000000000..04abfbf21edf
--- /dev/null
+++ b/devel/p5-Log-Dispatch-Colorful/distinfo
@@ -0,0 +1,3 @@
+MD5 (Log-Dispatch-Colorful-0.01.tar.gz) = c1386de71ba733a7c36583e6f52d80bf
+SHA256 (Log-Dispatch-Colorful-0.01.tar.gz) = e53e98958d49d21f40d734b38ff04347ac58519482fe8171db6a04dc562784ef
+SIZE (Log-Dispatch-Colorful-0.01.tar.gz) = 40147
diff --git a/devel/p5-Log-Dispatch-Colorful/pkg-descr b/devel/p5-Log-Dispatch-Colorful/pkg-descr
new file mode 100644
index 000000000000..bb8a8298907f
--- /dev/null
+++ b/devel/p5-Log-Dispatch-Colorful/pkg-descr
@@ -0,0 +1,3 @@
+Log::Dispatch::Colorful provides an object for logging to the screen.
+
+WWW: http://search.cpan.org/dist/Log-Dispatch-Colorful/
diff --git a/devel/p5-Log-Dispatch-Colorful/pkg-plist b/devel/p5-Log-Dispatch-Colorful/pkg-plist
new file mode 100644
index 000000000000..db2ea9574fb4
--- /dev/null
+++ b/devel/p5-Log-Dispatch-Colorful/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Log/Dispatch/Colorful.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Dispatch/Colorful/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Dispatch/Colorful
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Dispatch
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Log