aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/bonobo-activation/Makefile2
-rw-r--r--devel/bonobo-activation/distinfo2
-rw-r--r--devel/bonobo-activation/files/patch-bonobo-activation::bonobo-activation-fork-server.c12
-rw-r--r--devel/bonobo-activation/files/patch-server::Makefile.in22
-rw-r--r--devel/bonobo-activation/files/patch-server::activation-server-main.c18
-rw-r--r--devel/bonobo-activation/files/patch-temp15
6 files changed, 31 insertions, 40 deletions
diff --git a/devel/bonobo-activation/Makefile b/devel/bonobo-activation/Makefile
index aa1ae7a1266a..815818894223 100644
--- a/devel/bonobo-activation/Makefile
+++ b/devel/bonobo-activation/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bonobo-activation
-PORTVERSION= 1.0.3
+PORTVERSION= 1.0.4
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME}
diff --git a/devel/bonobo-activation/distinfo b/devel/bonobo-activation/distinfo
index 6e72ac85a55e..12555f159da1 100644
--- a/devel/bonobo-activation/distinfo
+++ b/devel/bonobo-activation/distinfo
@@ -1 +1 @@
-MD5 (gnome2/bonobo-activation-1.0.3.tar.bz2) = 79b65c0e35fa22eb2b73346b7490f25f
+MD5 (gnome2/bonobo-activation-1.0.4.tar.bz2) = 2b68d7a94d195cbcca15fcb63e55fb6a
diff --git a/devel/bonobo-activation/files/patch-bonobo-activation::bonobo-activation-fork-server.c b/devel/bonobo-activation/files/patch-bonobo-activation::bonobo-activation-fork-server.c
index 103422530c6f..e3db3eedc374 100644
--- a/devel/bonobo-activation/files/patch-bonobo-activation::bonobo-activation-fork-server.c
+++ b/devel/bonobo-activation/files/patch-bonobo-activation::bonobo-activation-fork-server.c
@@ -1,11 +1,11 @@
---- bonobo-activation/bonobo-activation-fork-server.c.orig Wed Jul 24 16:46:27 2002
-+++ bonobo-activation/bonobo-activation-fork-server.c Wed Jul 24 16:47:00 2002
-@@ -349,6 +349,8 @@
+--- bonobo-activation/bonobo-activation-fork-server.c.orig Fri Nov 8 03:19:52 2002
++++ bonobo-activation/bonobo-activation-fork-server.c Fri Nov 8 03:20:04 2002
+@@ -396,6 +396,8 @@
} else if ((childpid = fork ())) {
_exit (0); /* de-zombifier process, just exit */
} else {
+ sigprocmask (SIG_SETMASK, &omask, NULL);
+
- if (display != NULL) {
- bonobo_activation_setenv ("DISPLAY", display);
- }
+ if (display)
+ bonobo_activation_setenv ("DISPLAY", display);
+ if (session_manager)
diff --git a/devel/bonobo-activation/files/patch-server::Makefile.in b/devel/bonobo-activation/files/patch-server::Makefile.in
index 49683926cdff..aad85b8a56c8 100644
--- a/devel/bonobo-activation/files/patch-server::Makefile.in
+++ b/devel/bonobo-activation/files/patch-server::Makefile.in
@@ -1,11 +1,11 @@
---- server/Makefile.in.orig Wed Jul 24 16:56:33 2002
-+++ server/Makefile.in Wed Jul 24 16:56:52 2002
-@@ -147,7 +147,7 @@
- bin_PROGRAMS = activation-client
- libexec_PROGRAMS = bonobo-activation-server
-
--INCLUDES = -I$(top_srcdir) -I$(top_builddir) -I$(top_builddir)/bonobo-activation -I$(top_srcdir)/bonobo-activation -DSERVERINFODIR=\"$(prefix)/libdata/bonobo/servers\" -DSERVER_LOCALEDIR=\""${prefix}/${DATADIRNAME}/locale"\" $(SERVER_CFLAGS) -DSERVER_CONFDIR=\"$(sysconfdir)\" -DG_DISABLE_DEPRECATED $(NULL)
-+INCLUDES = -I$(top_srcdir) -I$(top_builddir) -I$(top_builddir)/bonobo-activation -I$(top_srcdir)/bonobo-activation -DSERVERINFODIR=\"$(prefix)/libdata/bonobo/servers:${X11BASE}/libdata/bonobo/servers:${LOCALBASE}/libdata/bonobo/servers\" -DSERVER_LOCALEDIR=\""${prefix}/${DATADIRNAME}/locale"\" $(SERVER_CFLAGS) -DSERVER_CONFDIR=\"$(sysconfdir)\" -DG_DISABLE_DEPRECATED $(NULL)
-
-
- bonobo_activation_server_SOURCES = activation-server-corba-extensions.c activation-server-corba-extensions.h activation-context-query.h activation-context-query.c activation-context-query-lexer.c activation-context-query-parser.c activation-context-query-parser.h activation-context-corba.c object-directory-corba.c object-directory-load.c object-directory-activate.c object-directory-config-file.c object-directory-config-file.h activation-server-main.c server.h
+--- server/Makefile.in.orig Fri Nov 8 03:18:57 2002
++++ server/Makefile.in Fri Nov 8 03:19:22 2002
+@@ -154,7 +154,7 @@
+ -I$(top_builddir) \
+ -I$(top_builddir)/bonobo-activation \
+ -I$(top_srcdir)/bonobo-activation \
+- -DSERVERINFODIR=\"$(prefix)/libdata/bonobo/servers\" \
++ -DSERVERINFODIR=\"$(prefix)/libdata/bonobo/servers:${X11BASE}/libdata/bonobo/servers:${LOCALBASE}/libdata/bonobo/servers\" \
+ -DSERVER_LOCALEDIR=\""${prefix}/${DATADIRNAME}/locale"\" \
+ $(SERVER_CFLAGS) \
+ -DSERVER_CONFDIR=\"$(sysconfdir)\" \
diff --git a/devel/bonobo-activation/files/patch-server::activation-server-main.c b/devel/bonobo-activation/files/patch-server::activation-server-main.c
index 730d9d6cfe26..8aedba380e43 100644
--- a/devel/bonobo-activation/files/patch-server::activation-server-main.c
+++ b/devel/bonobo-activation/files/patch-server::activation-server-main.c
@@ -1,9 +1,6 @@
-
-$FreeBSD$
-
---- server/activation-server-main.c.orig Tue May 14 04:51:55 2002
-+++ server/activation-server-main.c Mon May 27 13:36:25 2002
-@@ -127,7 +127,7 @@
+--- server/activation-server-main.c.orig Tue Oct 29 05:51:19 2002
++++ server/activation-server-main.c Fri Nov 8 03:21:04 2002
+@@ -131,7 +131,7 @@
g_string_append (gnome_od_source_dir,
gnome_dirs[i]);
g_string_append (gnome_od_source_dir,
@@ -12,3 +9,12 @@ $FreeBSD$
}
g_strfreev (gnome_dirs);
g_string_append_c (real_od_source_dir, ':');
+@@ -197,6 +197,8 @@
+ * terminal, etc.
+ */
+ setsid ();
++
++ unsetenv ("SESSION_MANAGER");
+
+ /* internationalization. */
+ setlocale (LC_ALL, "");
diff --git a/devel/bonobo-activation/files/patch-temp b/devel/bonobo-activation/files/patch-temp
deleted file mode 100644
index e9ea286d8d78..000000000000
--- a/devel/bonobo-activation/files/patch-temp
+++ /dev/null
@@ -1,15 +0,0 @@
-This patch corrects an incompatibility problem with bison 1.50 and above.
-It was taken from bonobo-activation CVS, and can be removed in the next release
-of the port.
-
---- server/activation-context-query-parser.y.orig Sat Oct 26 16:51:45 2002
-+++ server/activation-context-query-parser.y Sat Oct 26 16:52:00 2002
-@@ -155,7 +155,7 @@
- stringlist: P_CONST_STRING { $$ = g_slist_prepend (NULL, $1); }
- | stringlist COMMA P_CONST_STRING { $$ = g_slist_append ($1, $3); };
-
--expr_variable: P_DOLLAR P_CONST_ID { $$ = qexp_variable_new ($2); }
-+expr_variable: P_DOLLAR P_CONST_ID { $$ = qexp_variable_new ($2); };
-
- expr_function: P_CONST_ID LPAREN exprlist RPAREN { $$ = qexp_function_new ($1, $3); }
- | P_CONST_ID LPAREN RPAREN { $$ = qexp_function_new ($1, NULL); }