aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/aros-sdk/Makefile3
-rw-r--r--devel/asmutils/Makefile2
-rw-r--r--devel/avr-libc/Makefile4
-rw-r--r--devel/binutils/Makefile4
-rw-r--r--devel/c-unit/Makefile2
-rw-r--r--devel/cross-binutils/Makefile3
-rw-r--r--devel/cross-gcc/Makefile4
-rw-r--r--devel/e4graph/Makefile2
-rw-r--r--devel/eieio/Makefile2
-rw-r--r--devel/elf/Makefile2
-rw-r--r--devel/entity/Makefile3
-rw-r--r--devel/ffcall/Makefile2
-rw-r--r--devel/google-gdata/Makefile2
-rw-r--r--devel/ifd-test/Makefile3
-rw-r--r--devel/jzmq/Makefile3
-rw-r--r--devel/libdsp/Makefile2
-rw-r--r--devel/libowfat/Makefile3
-rw-r--r--devel/mingw32-pdcurses/Makefile2
-rw-r--r--devel/mingw32-pthreads/Makefile2
-rw-r--r--devel/monotone-viz/Makefile2
-rw-r--r--devel/mpatrol/Makefile2
-rw-r--r--devel/ocaml-annexlib/Makefile2
-rw-r--r--devel/ocaml-camomile/Makefile3
-rw-r--r--devel/ocaml-cppo/Makefile2
-rw-r--r--devel/ocaml-deriving-ocsigen/Makefile2
-rw-r--r--devel/ocaml-event/Makefile2
-rw-r--r--devel/ocaml-ounit/Makefile2
-rw-r--r--devel/ocaml-sdl/Makefile2
-rw-r--r--devel/ocaml-sem/Makefile3
-rw-r--r--devel/ocaml-xstr/Makefile2
-rw-r--r--devel/ocaml-xstrp4/Makefile2
-rw-r--r--devel/ocfpcsc/Makefile2
-rw-r--r--devel/omniNotify/Makefile2
-rw-r--r--devel/open-usp-tukubai/Makefile3
-rw-r--r--devel/openwince-include/Makefile3
-rw-r--r--devel/p5-Sepia/Makefile3
-rw-r--r--devel/php-java-bridge/Makefile2
-rw-r--r--devel/prepstools/Makefile1
-rw-r--r--devel/psptoolchain-binutils/Makefile3
-rw-r--r--devel/psptoolchain-gcc-stage1/Makefile3
-rw-r--r--devel/psptoolchain-newlib/Makefile3
-rw-r--r--devel/psptoolchain-pspsdk-stage1/Makefile2
-rw-r--r--devel/publib/Makefile2
-rw-r--r--devel/semantic/Makefile2
-rw-r--r--devel/sfslite/Makefile3
-rw-r--r--devel/stlport/Makefile4
-rw-r--r--devel/tigcc/Makefile4
-rw-r--r--devel/ustl/Makefile3
-rw-r--r--devel/vtg/Makefile3
49 files changed, 49 insertions, 75 deletions
diff --git a/devel/aros-sdk/Makefile b/devel/aros-sdk/Makefile
index b60960f31b03..6ec562fac339 100644
--- a/devel/aros-sdk/Makefile
+++ b/devel/aros-sdk/Makefile
@@ -10,8 +10,7 @@ DISTNAME= AROS-20060207-i386-all-sdk
MAINTAINER= ports@FreeBSD.org
COMMENT= The Software development kit (SDK) for the AROS Operating System
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
NO_STAGE= yes
.include <bsd.port.pre.mk>
diff --git a/devel/asmutils/Makefile b/devel/asmutils/Makefile
index afa6c0806606..167c8cb488e5 100644
--- a/devel/asmutils/Makefile
+++ b/devel/asmutils/Makefile
@@ -16,7 +16,7 @@ ONLY_FOR_ARCHS= i386
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
-USE_GMAKE= yes
+USES= gmake
MAKE_ARGS= OS=${OPSYS:tu} KERNEL=${OSREL:S/.//g}
# This will play merry hell with portlint(1)
diff --git a/devel/avr-libc/Makefile b/devel/avr-libc/Makefile
index 5a8c714c32d9..e5954e040882 100644
--- a/devel/avr-libc/Makefile
+++ b/devel/avr-libc/Makefile
@@ -38,9 +38,7 @@ BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen \
jpegtopnm:${PORTSDIR}/graphics/netpbm
.endif
-USE_BZIP2= yes
-USE_GMAKE= yes
-USES= gettext:build
+USES= gettext:build tar:bzip2 gmake
HAS_CONFIGURE= yes
CONFLICTS= avr-libc-devel-[0-9]*
diff --git a/devel/binutils/Makefile b/devel/binutils/Makefile
index 1396e660f9b5..a7288d3aa716 100644
--- a/devel/binutils/Makefile
+++ b/devel/binutils/Makefile
@@ -23,9 +23,7 @@ OPTIONS_DEFINE= NLS
LICENSE_FILE_GPLv3= ${WRKSRC}/COPYING3
LICENSE_FILE_LGPL3= ${WRKSRC}/COPYING3.LIB
-USES= bison
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= bison tar:bzip2 gmake
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
diff --git a/devel/c-unit/Makefile b/devel/c-unit/Makefile
index 5f363236a89e..2bca33172d4e 100644
--- a/devel/c-unit/Makefile
+++ b/devel/c-unit/Makefile
@@ -12,7 +12,7 @@ COMMENT= Unit testing framework for C
CONFLICTS= cunit-[0-9]*
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
USE_AUTOTOOLS= autoheader
USE_LDCONFIG= yes
diff --git a/devel/cross-binutils/Makefile b/devel/cross-binutils/Makefile
index 948d4eed8f6d..ce30811fcb06 100644
--- a/devel/cross-binutils/Makefile
+++ b/devel/cross-binutils/Makefile
@@ -15,8 +15,7 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= christoph.mallon@gmx.de
COMMENT= GNU binutils port for cross-target development
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= tar:bzip2 gmake
GNU_CONFIGURE= yes
ALL_TARGET= all info
MAKE_JOBS_UNSAFE= yes
diff --git a/devel/cross-gcc/Makefile b/devel/cross-gcc/Makefile
index e9153f3e0f4c..8b9ff4b2d6cb 100644
--- a/devel/cross-gcc/Makefile
+++ b/devel/cross-gcc/Makefile
@@ -27,9 +27,7 @@ LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
BUILD_DEPENDS?= ${OURTARGET}-as:${PORTSDIR}/devel/cross-binutils
RUN_DEPENDS?= ${OURTARGET}-as:${PORTSDIR}/devel/cross-binutils
-USE_BZIP2= yes
-USE_GMAKE= yes
-USES= bison iconv
+USES= bison iconv gmake tar:bzip2
STRIP= #empty
GNU_CONFIGURE= yes
ALL_TARGET= all info
diff --git a/devel/e4graph/Makefile b/devel/e4graph/Makefile
index 875cdd1e6c1b..039184b3e778 100644
--- a/devel/e4graph/Makefile
+++ b/devel/e4graph/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= mk4.0:${PORTSDIR}/databases/metakit \
WRKSRC= ${WRKDIR}/${DISTNAME}/all
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-metakit=${LOCALBASE} \
--with-tcl=${LOCALBASE}/lib/tcl${TCL_VER} --enable-tcl \
diff --git a/devel/eieio/Makefile b/devel/eieio/Makefile
index a80f4da37a66..e5f870321a27 100644
--- a/devel/eieio/Makefile
+++ b/devel/eieio/Makefile
@@ -23,7 +23,7 @@ PORTNAMESUFFIX= ${PKGNAMESUFFIX}
BUILD_DEPENDS= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/speedbar/speedbar.el:${PORTSDIR}/editors/speedbar${PORTNAMESUFFIX}
-USE_GMAKE= yes
+USES= gmake
CONFLICTS= cedet*
INFO= eieio
diff --git a/devel/elf/Makefile b/devel/elf/Makefile
index 4a1a60a77097..6d62df9dd9f9 100644
--- a/devel/elf/Makefile
+++ b/devel/elf/Makefile
@@ -14,7 +14,7 @@ COMMENT= A commandline based ELF header analyzer
MAN1= elf.1
MANCOMPRESSED= no
PLIST_FILES= bin/elf
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
NO_STAGE= yes
diff --git a/devel/entity/Makefile b/devel/entity/Makefile
index 46b8ebaeda56..3916b00646fc 100644
--- a/devel/entity/Makefile
+++ b/devel/entity/Makefile
@@ -16,9 +16,8 @@ RUN_DEPENDS= python:${PORTSDIR}/lang/python
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-tcl=no
-USES= perl5
+USES= perl5 gmake
USE_AUTOTOOLS= libtool
-USE_GMAKE= yes
USE_GNOME= gtk12
USE_LDCONFIG= ${PREFIX}/lib/entity/clib
MAKE_JOBS_UNSAFE= yes
diff --git a/devel/ffcall/Makefile b/devel/ffcall/Makefile
index 881974e5265d..cf56730654a7 100644
--- a/devel/ffcall/Makefile
+++ b/devel/ffcall/Makefile
@@ -14,7 +14,7 @@ COMMENT= Foreign function call libraries
LICENSE= GPLv2
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/devel/google-gdata/Makefile b/devel/google-gdata/Makefile
index 048c3f8cdb96..5b7090bf1958 100644
--- a/devel/google-gdata/Makefile
+++ b/devel/google-gdata/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS= gmcs:${PORTSDIR}/lang/mono
# google-gdata depends on _THIS_ version of zlib so make them happy.
ZLIB_VERSION= 1.2.3
-USE_GMAKE= yes
+USES= gmake
NO_STAGE= yes
pre-configure:
diff --git a/devel/ifd-test/Makefile b/devel/ifd-test/Makefile
index c771083f43f8..e09b97e4b2b5 100644
--- a/devel/ifd-test/Makefile
+++ b/devel/ifd-test/Makefile
@@ -12,8 +12,7 @@ COMMENT= IFD Test Suite for PC/SC Lite
LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
-USE_GMAKE= yes
-
+USES= gmake
NOMAN=
PLIST_FILES= sbin/ifdtest
MAKE_ENV= LIBS="-L${PREFIX}/lib -lpcsclite"
diff --git a/devel/jzmq/Makefile b/devel/jzmq/Makefile
index 7c0a4ccad74d..c90596fe683f 100644
--- a/devel/jzmq/Makefile
+++ b/devel/jzmq/Makefile
@@ -12,9 +12,8 @@ COMMENT= Java bindings for ZeroMQ
LIB_DEPENDS= zmq.1:${PORTSDIR}/net/libzmq2
-USES= pkgconfig
+USES= pkgconfig gmake
USE_AUTOTOOLS= autoconf:env libtool automake:env
-USE_GMAKE= yes
USE_JAVA= 1.4+
USE_LDCONFIG= yes
diff --git a/devel/libdsp/Makefile b/devel/libdsp/Makefile
index 62d192a8b0a1..b3ffb78d77d7 100644
--- a/devel/libdsp/Makefile
+++ b/devel/libdsp/Makefile
@@ -15,7 +15,7 @@ COMMENT= C++ class library of common digital signal processing functions
WRKSRC= ${WRKDIR}/libdsp-src-${PORTVERSION}/${PORTNAME:S/dsp/DSP/}-${PORTVERSION}
USE_AUTOTOOLS= libtool:env
-USE_GMAKE= yes
+USES= gmake
MAKE_ENV= MKDIR="${MKDIR}" INLINE_VER="${INLINE_VER}"
MAKEFILE= Makefile.BSD
USE_LDCONFIG= yes
diff --git a/devel/libowfat/Makefile b/devel/libowfat/Makefile
index 4580f0d840fb..614bec9014ae 100644
--- a/devel/libowfat/Makefile
+++ b/devel/libowfat/Makefile
@@ -9,8 +9,7 @@ MASTER_SITES= http://dl.fefe.de/
MAINTAINER= lx@FreeBSD.org
COMMENT= A general purpose library based on code by D. J. Bernstein
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
ALL_TARGET= dep all
MAKEFILE= GNUmakefile
diff --git a/devel/mingw32-pdcurses/Makefile b/devel/mingw32-pdcurses/Makefile
index a314b8983b53..7a3630c8c224 100644
--- a/devel/mingw32-pdcurses/Makefile
+++ b/devel/mingw32-pdcurses/Makefile
@@ -14,7 +14,7 @@ COMMENT= Curses and Panel terminal library for Windows
BUILD_DEPENDS= ${PKGNAMEPREFIX}gcc:${PORTSDIR}/devel/${PKGNAMEPREFIX}gcc \
mingwm10.dll:${PORTSDIR}/devel/mingw32-bin-msvcrt
-USE_GMAKE= yes
+USES= gmake
MAKEFILE= gccwin32.mak
WRKSRC= ${WRKDIR}/${DISTNAME}/win32
MAKE_ARGS+= CC=${PKGNAMEPREFIX}gcc LIBEXE=${PKGNAMEPREFIX}ar
diff --git a/devel/mingw32-pthreads/Makefile b/devel/mingw32-pthreads/Makefile
index 8918a5065643..9480409318e0 100644
--- a/devel/mingw32-pthreads/Makefile
+++ b/devel/mingw32-pthreads/Makefile
@@ -14,7 +14,7 @@ COMMENT= POSIX threads library for Windows compiled with MinGW32
BUILD_DEPENDS= ${PKGNAMEPREFIX}gcc:${PORTSDIR}/devel/${PKGNAMEPREFIX}gcc \
mingwm10.dll:${PORTSDIR}/devel/mingw32-bin-msvcrt
-USE_GMAKE= yes
+USES= gmake
NO_STAGE= yes
do-build:
diff --git a/devel/monotone-viz/Makefile b/devel/monotone-viz/Makefile
index 1becd5f68cf7..28bb26c6e1ab 100644
--- a/devel/monotone-viz/Makefile
+++ b/devel/monotone-viz/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS+= dot:${PORTSDIR}/graphics/graphviz \
mtn:${PORTSDIR}/devel/monotone \
lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
-USE_GMAKE= yes
+USES= gmake
USE_OCAML= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --without-local-lablgtk
diff --git a/devel/mpatrol/Makefile b/devel/mpatrol/Makefile
index 95dbbd7f5f96..d114f14d47b9 100644
--- a/devel/mpatrol/Makefile
+++ b/devel/mpatrol/Makefile
@@ -18,7 +18,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}/build/unix
ONLY_FOR_ARCHS= i386 amd64
USE_LDCONFIG= yes
-USE_GMAKE= yes
+USES= gmake
MAN1= hexwords.1 mleak.1 mpatrol.1 mprof.1 \
mpsym.1 mptrace.1 mpedit.1
diff --git a/devel/ocaml-annexlib/Makefile b/devel/ocaml-annexlib/Makefile
index 41d0cef368e4..0246db23b086 100644
--- a/devel/ocaml-annexlib/Makefile
+++ b/devel/ocaml-annexlib/Makefile
@@ -14,7 +14,7 @@ COMMENT= OCaml subroutines collection
BUILD_DEPENDS= ${SA_DIR}/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre
RUN_DEPENDS= ${SA_DIR}/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre
-USE_GMAKE= yes
+USES= gmake
USE_OCAML= yes
USE_OCAML_FINDLIB=yes
USE_OCAML_LDCONFIG=yes
diff --git a/devel/ocaml-camomile/Makefile b/devel/ocaml-camomile/Makefile
index 7099957874c7..ad40856ae5ee 100644
--- a/devel/ocaml-camomile/Makefile
+++ b/devel/ocaml-camomile/Makefile
@@ -10,8 +10,7 @@ PKGNAMEPREFIX= ocaml-
MAINTAINER= michael.grunewald@laposte.net
COMMENT= A comprehensive Unicode library for objective caml language
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
USE_OCAML= yes
USE_OCAML_FINDLIB=yes
USE_OCAML_LDCONFIG=yes
diff --git a/devel/ocaml-cppo/Makefile b/devel/ocaml-cppo/Makefile
index 98723e7b42be..66a8c97db644 100644
--- a/devel/ocaml-cppo/Makefile
+++ b/devel/ocaml-cppo/Makefile
@@ -10,7 +10,7 @@ PKGNAMEPREFIX= ocaml-
MAINTAINER= michael.grunewald@laposte.net
COMMENT= A simple preprocessor for OCaml
-USE_GMAKE= yes
+USES= gmake
USE_OCAML= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/devel/ocaml-deriving-ocsigen/Makefile b/devel/ocaml-deriving-ocsigen/Makefile
index 8855e41a5930..271c085eebda 100644
--- a/devel/ocaml-deriving-ocsigen/Makefile
+++ b/devel/ocaml-deriving-ocsigen/Makefile
@@ -15,7 +15,7 @@ USE_OCAML_FINDLIB= yes
USE_OCAMLFIND_PLIST= yes
USE_OCAML_LDCONFIG= yes
-USE_GMAKE= yes
+USES= gmake
NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/devel/ocaml-event/Makefile b/devel/ocaml-event/Makefile
index 8adf5fa02b67..9139a5c7b379 100644
--- a/devel/ocaml-event/Makefile
+++ b/devel/ocaml-event/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
LIB_DEPENDS= event-1.4:${PORTSDIR}/devel/libevent
ALL_TARGET= all allopt
-USE_GMAKE= yes
+USES= gmake
.ifndef(NOPORTDOCS)
ALL_TARGET+= doc
diff --git a/devel/ocaml-ounit/Makefile b/devel/ocaml-ounit/Makefile
index 075934a14799..d570aefcccd1 100644
--- a/devel/ocaml-ounit/Makefile
+++ b/devel/ocaml-ounit/Makefile
@@ -14,7 +14,7 @@ COMMENT= OCaml unit test framework
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
ocamlfind:${PORTSDIR}/devel/ocaml-findlib
-USE_GMAKE= yes
+USES= gmake
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
PORTDOCS= README style.css *.html
diff --git a/devel/ocaml-sdl/Makefile b/devel/ocaml-sdl/Makefile
index d2a38fad7fb4..90dde70f2040 100644
--- a/devel/ocaml-sdl/Makefile
+++ b/devel/ocaml-sdl/Makefile
@@ -27,8 +27,8 @@ USE_OCAML_FINDLIB=yes
USE_OCAMLFIND_PLIST=yes
USE_OCAML_LDCONFIG=yes
+USES= gmake
USE_SDL= sdl
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-lablgldir=${LOCALBASE} \
--with-sdl-prefix=${LOCALBASE} \
diff --git a/devel/ocaml-sem/Makefile b/devel/ocaml-sem/Makefile
index ecf437e8dcf2..8945b465df3a 100644
--- a/devel/ocaml-sem/Makefile
+++ b/devel/ocaml-sem/Makefile
@@ -28,8 +28,7 @@ ALL_TARGET= all
PORTDOCS= html README
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bizp2
PKGDEINSTALL= ${PKGINSTALL}
diff --git a/devel/ocaml-xstr/Makefile b/devel/ocaml-xstr/Makefile
index dfb5ae05df01..a26ca14bf504 100644
--- a/devel/ocaml-xstr/Makefile
+++ b/devel/ocaml-xstr/Makefile
@@ -20,7 +20,7 @@ USE_OCAML= yes
USE_OCAML_FINDLIB=yes
USE_OCAMLFIND_PLIST=yes
-USE_GMAKE= yes
+USES= gmake
ALL_TARGET= all opt
NO_STAGE= yes
diff --git a/devel/ocaml-xstrp4/Makefile b/devel/ocaml-xstrp4/Makefile
index 82d761eaeaae..c31c0348ad8d 100644
--- a/devel/ocaml-xstrp4/Makefile
+++ b/devel/ocaml-xstrp4/Makefile
@@ -15,7 +15,7 @@ LICENSE= MIT
OPTIONS_DEFINE= EXAMPLES
-USE_GMAKE= yes
+USES= gmake
USE_OCAML= yes
USE_OCAML_FINDLIB=yes
USE_OCAMLFIND_PLIST=yes
diff --git a/devel/ocfpcsc/Makefile b/devel/ocfpcsc/Makefile
index 470827302a0d..afbf5782c457 100644
--- a/devel/ocfpcsc/Makefile
+++ b/devel/ocfpcsc/Makefile
@@ -13,7 +13,7 @@ COMMENT= Open Card Framework to PC/SC bridge
LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
-USE_GMAKE= yes
+USES= gmake
USE_JAVA= 1.2+
USE_LDCONFIG= yes
diff --git a/devel/omniNotify/Makefile b/devel/omniNotify/Makefile
index ccadbb9b8fae..d32d83d114c4 100644
--- a/devel/omniNotify/Makefile
+++ b/devel/omniNotify/Makefile
@@ -22,8 +22,8 @@ BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
OMNIORB_WRKSRC!= cd ${.CURDIR}/../omniORB && ${MAKE} -V WRKSRC
+USES= gmake
USE_PYTHON= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
MAKEFILE= GNUmakefile
USE_LDCONFIG= yes
diff --git a/devel/open-usp-tukubai/Makefile b/devel/open-usp-tukubai/Makefile
index 791963c79ac4..db035a20e33a 100644
--- a/devel/open-usp-tukubai/Makefile
+++ b/devel/open-usp-tukubai/Makefile
@@ -9,8 +9,7 @@ MASTER_SITES= https://uec.usp-lab.com/TUKUBAI/DOWNLOAD/
MAINTAINER= daichi@FreeBSD.org
COMMENT= Open usp Tukubai is OSS version of Tukubai commands set
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
USE_PYTHON= yes
NO_BUILD= yes
diff --git a/devel/openwince-include/Makefile b/devel/openwince-include/Makefile
index 7ac9869b643e..ee9b85a45747 100644
--- a/devel/openwince-include/Makefile
+++ b/devel/openwince-include/Makefile
@@ -10,8 +10,7 @@ PKGNAMEPREFIX= openwince-
MAINTAINER= ports@FreeBSD.org
COMMENT= A collection of the useful include files for embedded developers
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
GNU_CONFIGURE= yes
NO_STAGE= yes
diff --git a/devel/p5-Sepia/Makefile b/devel/p5-Sepia/Makefile
index 1d93321e4495..78787954fcf4 100644
--- a/devel/p5-Sepia/Makefile
+++ b/devel/p5-Sepia/Makefile
@@ -20,10 +20,9 @@ BUILD_DEPENDS= p5-Devel-Size>=0:${PORTSDIR}/devel/p5-Devel-Size \
p5-BSD-Resource>=0:${PORTSDIR}/devel/p5-BSD-Resource
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= perl5
+USES= perl5 gmake
USE_PERL5= configure
USE_EMACS= yes
-USE_GMAKE= yes
INFO= sepia
diff --git a/devel/php-java-bridge/Makefile b/devel/php-java-bridge/Makefile
index ef562928d1ed..4e078a1ca45e 100644
--- a/devel/php-java-bridge/Makefile
+++ b/devel/php-java-bridge/Makefile
@@ -13,7 +13,7 @@ COMMENT= PHP module wich connects the PHP object with the Java/ECMA 335 object
USE_AUTOTOOLS= autoconf:env automake:env libtool:env
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
USE_JAVA= yes
JAVA_BUILD= jdk
diff --git a/devel/prepstools/Makefile b/devel/prepstools/Makefile
index 0ea642577108..1ae036ee821f 100644
--- a/devel/prepstools/Makefile
+++ b/devel/prepstools/Makefile
@@ -17,7 +17,6 @@ LICENSE= GPLv2
USE_AUTOTOOLS= libtool
USE_PGSQL= yes
USES= gmake pkgconfig
-USE_GMAKE= yes
USE_GNOME= gtk20 gconf2 glib20 libgnomeui
GNU_CONFIGURE= yes
diff --git a/devel/psptoolchain-binutils/Makefile b/devel/psptoolchain-binutils/Makefile
index 3b9b88c2bf54..040440499705 100644
--- a/devel/psptoolchain-binutils/Makefile
+++ b/devel/psptoolchain-binutils/Makefile
@@ -12,9 +12,8 @@ PKGNAMEPREFIX= psptoolchain-
MAINTAINER= tphilipp@potion-studios.com
COMMENT= PlayStation Portable development toolchain ${PORTNAME}
-USE_BZIP2= yes
+USES= gmake tar:bzip2
USE_GCC= any
-USE_GMAKE= yes
HAS_CONFIGURE= yes
CONFIGURE_TARGET= ${ARCH:S/amd64/x86_64/}-unknown-freebsd${OSREL}
diff --git a/devel/psptoolchain-gcc-stage1/Makefile b/devel/psptoolchain-gcc-stage1/Makefile
index e3aeb65ee447..3ea9dafeaeec 100644
--- a/devel/psptoolchain-gcc-stage1/Makefile
+++ b/devel/psptoolchain-gcc-stage1/Makefile
@@ -35,9 +35,8 @@ BUILD_DEPENDS+= psp-addr2line:${PORTSDIR}/devel/psptoolchain-binutils \
psp-strings:${PORTSDIR}/devel/psptoolchain-binutils \
psp-strip:${PORTSDIR}/devel/psptoolchain-binutils
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
diff --git a/devel/psptoolchain-newlib/Makefile b/devel/psptoolchain-newlib/Makefile
index 8b0a646478b8..f9355d56e4a5 100644
--- a/devel/psptoolchain-newlib/Makefile
+++ b/devel/psptoolchain-newlib/Makefile
@@ -21,8 +21,7 @@ BUILD_DEPENDS+= ${LOCALBASE}/${PSP_SDK_STAGE_PREFIX}/sdk/include/pspsdk.h:${POR
psp-ld:${PORTSDIR}/devel/psptoolchain-binutils \
${LOCALBASE}/${PSP_GCC_STAGE_PREFIX}/bin/psp-gcc:${PORTSDIR}/devel/psptoolchain-gcc-stage1
-USE_GMAKE= yes
-
+USES= gmake
HAS_CONFIGURE= yes
CONFIGURE_ENV= PATH=${LOCALBASE}/${PSP_GCC_STAGE_PREFIX}/bin:${PATH}
MAKE_ENV= PATH=${LOCALBASE}/${PSP_GCC_STAGE_PREFIX}/bin:${PATH}
diff --git a/devel/psptoolchain-pspsdk-stage1/Makefile b/devel/psptoolchain-pspsdk-stage1/Makefile
index 89bf5022760f..9e30cf56e933 100644
--- a/devel/psptoolchain-pspsdk-stage1/Makefile
+++ b/devel/psptoolchain-pspsdk-stage1/Makefile
@@ -14,8 +14,8 @@ COMMENT= PlayStation Portable development toolchain ${PORTNAME}
PSP_SDK_STAGE_PREFIX= psp/stage1
USE_AUTOTOOLS= libtool:env aclocal:env autoheader:env automake:env autoconf:env
-USE_GMAKE= yes
HAS_CONFIGURE= yes
+USES= gmake
CONFIGURE_ARGS?= --prefix=${PREFIX}/${PSP_SDK_STAGE_PREFIX} \
--with-pspdev="${LOCALBASE}/${PSP_SDK_STAGE_PREFIX}"
diff --git a/devel/publib/Makefile b/devel/publib/Makefile
index b95ced390531..e982ea09c79a 100644
--- a/devel/publib/Makefile
+++ b/devel/publib/Makefile
@@ -16,7 +16,7 @@ BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
CONFIGURE_SCRIPT= ../framework/configure
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
MAN3= dynarr.3 \
diff --git a/devel/semantic/Makefile b/devel/semantic/Makefile
index 2cc308f9ac38..28b9931bc38e 100644
--- a/devel/semantic/Makefile
+++ b/devel/semantic/Makefile
@@ -25,7 +25,7 @@ BUILD_DEPENDS= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/eieio/eieio.el:${PORTS
${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/speedbar/speedbar.el:${PORTSDIR}/editors/speedbar${PORTNAMESUFFIX}
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_GMAKE= yes
+USES= gmake
MAKE_ARGS= LOADPATH=
CONFLICTS= cedet*
INFO= semantic
diff --git a/devel/sfslite/Makefile b/devel/sfslite/Makefile
index 739d7490eb1d..cd0db5211efa 100644
--- a/devel/sfslite/Makefile
+++ b/devel/sfslite/Makefile
@@ -15,11 +15,10 @@ LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
CONFIGURE_ARGS= --with-gmp=${LOCALBASE}
GNU_CONFIGURE= yes
-USE_GMAKE= yes
#
# rpcc does not work with byacc, so just require BISON
#
-USES= bison
+USES= bison gmake
#
# Map X.Y.Z.Q => X.Y
diff --git a/devel/stlport/Makefile b/devel/stlport/Makefile
index 28a6d2bc8967..610d2e646130 100644
--- a/devel/stlport/Makefile
+++ b/devel/stlport/Makefile
@@ -11,11 +11,11 @@ DISTNAME= STLport-${PORTVERSION:S/.b/-b/}
MAINTAINER= ports@FreeBSD.org
COMMENT= Adaptation of SGI\'s Standard Template Library
-USE_BZIP2= yes
WRKSRC= ${WRKDIR}/STLport-${PORTVERSION:S/.b/b/}/build/lib
PATCH_WRKSRC= ${WRKDIR}/STLport-${PORTVERSION:S/.b/b/}
-USE_GMAKE= yes
+
+USES= gmake tar:bzip2
USE_GCC= any
COMPILER?= gcc
MAKEFILE= ${COMPILER}.mak
diff --git a/devel/tigcc/Makefile b/devel/tigcc/Makefile
index c646b1dc710c..27a226aadbff 100644
--- a/devel/tigcc/Makefile
+++ b/devel/tigcc/Makefile
@@ -17,9 +17,7 @@ DISTFILES= gcc-core-4.1-20060728.tar.bz2:gcc \
MAINTAINER= ports@FreeBSD.org
COMMENT= C compiler for the TI89, 92, and 92+ calculators
-USE_BZIP2= yes
-USE_GMAKE= yes
-USES= bison
+USES= bison tar:bzip2 gmake
NO_WRKSUBDIR= yes
NO_STAGE= yes
diff --git a/devel/ustl/Makefile b/devel/ustl/Makefile
index 0faec0317f79..2fe7fd9f639c 100644
--- a/devel/ustl/Makefile
+++ b/devel/ustl/Makefile
@@ -10,8 +10,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:R}-${PORTVERSION:E}
MAINTAINER= perl@FreeBSD.org
COMMENT= Codespace-frugal STL implementation
-USE_BZIP2= yes
-USE_GMAKE= yes
+USE= gmake tar:bzip2
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
HAS_CONFIGURE= yes
diff --git a/devel/vtg/Makefile b/devel/vtg/Makefile
index 401f1ed1b965..61e8bd940fad 100644
--- a/devel/vtg/Makefile
+++ b/devel/vtg/Makefile
@@ -21,8 +21,7 @@ IGNORE= doesn't build with vala 0.18+
CONFIGURE_ARGS= --disable-vtg-plugin --disable-gen-project
CPPFLAGS= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
USE_GNOME= gnomehack glib20 intltool
USE_LDCONFIG= yes