aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-IPC-Run3/Makefile27
-rw-r--r--devel/p5-IPC-Run3/distinfo2
-rw-r--r--devel/p5-IPC-Run3/pkg-descr5
-rw-r--r--devel/p5-IPC-Run3/pkg-plist10
5 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 69bb2ca3f88d..c61e6712ce21 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -778,6 +778,7 @@
SUBDIR += p5-IPC-Locker
SUBDIR += p5-IPC-MM
SUBDIR += p5-IPC-Run
+ SUBDIR += p5-IPC-Run3
SUBDIR += p5-IPC-ShareLite
SUBDIR += p5-IPC-Shareable
SUBDIR += p5-IPC-SharedCache
diff --git a/devel/p5-IPC-Run3/Makefile b/devel/p5-IPC-Run3/Makefile
new file mode 100644
index 000000000000..a7b612531fe1
--- /dev/null
+++ b/devel/p5-IPC-Run3/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: devel/p5-IPC-Run3
+# Date created: Apr 27 2004
+# Whom: Autrijus Tang <autrijus@autrijus.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IPC-Run3
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/R/RB/RBS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= autrijus@autrijus.org
+COMMENT= Run a subprocess in batch mode
+
+PERL_CONFIGURE= yes
+
+MAN3= IPC::Run3.3 \
+ IPC::Run3::ProfArrayBuffer.3 \
+ IPC::Run3::ProfLogger.3 \
+ IPC::Run3::ProfLogReader.3 \
+ IPC::Run3::ProfPP.3 \
+ IPC::Run3::ProfReporter.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-IPC-Run3/distinfo b/devel/p5-IPC-Run3/distinfo
new file mode 100644
index 000000000000..e2be1cb35d9b
--- /dev/null
+++ b/devel/p5-IPC-Run3/distinfo
@@ -0,0 +1,2 @@
+MD5 (IPC-Run3-0.01.tar.gz) = d518846b8fdd1ec7188f384e9bb900e3
+SIZE (IPC-Run3-0.01.tar.gz) = 12177
diff --git a/devel/p5-IPC-Run3/pkg-descr b/devel/p5-IPC-Run3/pkg-descr
new file mode 100644
index 000000000000..79158a118cc0
--- /dev/null
+++ b/devel/p5-IPC-Run3/pkg-descr
@@ -0,0 +1,5 @@
+This module allows you to run a subprocess and redirect stdin, stdout,
+and/or stderr to files and perl data structures. It aims to satisfy
+99% of the need for using system()/qx``/open3() with a simple,
+extremely Perlish API and none of the bloat and rarely used features of
+IPC::Run.
diff --git a/devel/p5-IPC-Run3/pkg-plist b/devel/p5-IPC-Run3/pkg-plist
new file mode 100644
index 000000000000..e28e817c38c1
--- /dev/null
+++ b/devel/p5-IPC-Run3/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/IPC/Run3.pm
+%%SITE_PERL%%/IPC/Run3/ProfArrayBuffer.pm
+%%SITE_PERL%%/IPC/Run3/ProfLogReader.pm
+%%SITE_PERL%%/IPC/Run3/ProfLogger.pm
+%%SITE_PERL%%/IPC/Run3/ProfPP.pm
+%%SITE_PERL%%/IPC/Run3/ProfReporter.pm
+@dirrm %%SITE_PERL%%/IPC/Run3
+@dirrm %%SITE_PERL%%/IPC
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/IPC/Run3 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/IPC 2>/dev/null || true