aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/motor/Makefile8
-rw-r--r--devel/py-kqueue/Makefile5
-rw-r--r--devel/uclmmbase/Makefile9
3 files changed, 4 insertions, 18 deletions
diff --git a/devel/motor/Makefile b/devel/motor/Makefile
index 7244ced93b1c..729fdfcf7e7e 100644
--- a/devel/motor/Makefile
+++ b/devel/motor/Makefile
@@ -30,12 +30,6 @@ PLIST_SUB= NLS="@comment "
MAN1= motor.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 400010
-LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|zxvf|&o|' ${WRKSRC}/share/Makefile.in
@@ -45,4 +39,4 @@ post-install:
@(cd ${WRKSRC} ; ${INSTALL_DATA} FAQ README ${DOCSDIR})
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/py-kqueue/Makefile b/devel/py-kqueue/Makefile
index 6f5789174ad6..68a2f1651b1b 100644
--- a/devel/py-kqueue/Makefile
+++ b/devel/py-kqueue/Makefile
@@ -15,7 +15,7 @@ DISTNAME= PyKQueue-${PORTVERSION}
EXTRACT_SUFX= .tbz
MAINTAINER= ports2@dclg.ca
-COMMENT= Python interface to kqueue(2) and kevent(2) system calls
+COMMENT= Python interface to kqueue(2) and kevent(2) system calls
USE_BZIP2= yes
USE_PYTHON= yes
@@ -25,9 +25,6 @@ MAKE_ENV= MAINCC=${CC}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 400018
-IGNORE="requires new kqueue API"
-.endif
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500010
IGNORE="requires new kqueue API"
.endif
diff --git a/devel/uclmmbase/Makefile b/devel/uclmmbase/Makefile
index be31746d0869..3060c90dd97a 100644
--- a/devel/uclmmbase/Makefile
+++ b/devel/uclmmbase/Makefile
@@ -17,6 +17,7 @@ COMMENT= Common subroutines for UCL mbone applications
WRKSRC= ${WRKDIR}/common
GNU_CONFIGURE= yes
USE_OPENSSL= yes
+CONFIGURE_ARGS= --enable-ipv6
post-configure:
@for f in ${FILESDIR}/*.bsd ; do \
@@ -34,10 +35,4 @@ post-build test:
do-install:
cd ${WRKSRC}/src && ${MAKE_ENV} ${MAKE} install
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 400014
-CONFIGURE_ARGS+= --enable-ipv6
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>