aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/cppadvio/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/devel/cppadvio/Makefile b/devel/cppadvio/Makefile
index 9c452d7a9bd9..04c3feb54ae7 100644
--- a/devel/cppadvio/Makefile
+++ b/devel/cppadvio/Makefile
@@ -21,6 +21,12 @@ ALL_TARGET= lib
USE_GMAKE= yes
USE_GCC= 2.95
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
+BROKEN= "Does not compile on alpha 4.x"
+.endif
+
post-patch:
@( cd ${WRKSRC}; ${MV} c++ c++.orig; \
${SED} -e 's|^ *gcc|${CXX} ${CXXFLAGS}|' c++.orig > c++; ${CHMOD} +x c++ )
@@ -45,4 +51,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/cppadvio
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>