aboutsummaryrefslogtreecommitdiff
path: root/dns/bind911
diff options
context:
space:
mode:
Diffstat (limited to 'dns/bind911')
-rw-r--r--dns/bind911/Makefile4
-rw-r--r--dns/bind911/distinfo6
-rw-r--r--dns/bind911/files/extrapatch-bind-min-override-ttl12
-rw-r--r--dns/bind911/files/patch-configure12
-rw-r--r--dns/bind911/pkg-plist1
5 files changed, 18 insertions, 17 deletions
diff --git a/dns/bind911/Makefile b/dns/bind911/Makefile
index c0727229dde3..75466a96133c 100644
--- a/dns/bind911/Makefile
+++ b/dns/bind911/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bind
PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
-PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= dns net
MASTER_SITES= ISC/bind9/${ISCVERSION}
PKGNAMESUFFIX= 911
@@ -24,7 +24,7 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
USES= cpe libedit pkgconfig
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.11.23
+ISCVERSION= 9.11.24
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind911/distinfo b/dns/bind911/distinfo
index 74b21e525e80..33a0682577a1 100644
--- a/dns/bind911/distinfo
+++ b/dns/bind911/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1600870608
-SHA256 (bind-9.11.23.tar.gz) = 6e194d2f2a4c9fc18f5989b7a28b71161d1703c0d9b2c0fb8c0a545cc05ad2e1
-SIZE (bind-9.11.23.tar.gz) = 8257821
+TIMESTAMP = 1603640264
+SHA256 (bind-9.11.24.tar.gz) = f261587c5d37c7f14e8393547c4556faefa701a646930f1b6408d71519a30428
+SIZE (bind-9.11.24.tar.gz) = 8273237
diff --git a/dns/bind911/files/extrapatch-bind-min-override-ttl b/dns/bind911/files/extrapatch-bind-min-override-ttl
index 3bf0b96f66a3..815ee5d1f108 100644
--- a/dns/bind911/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind911/files/extrapatch-bind-min-override-ttl
@@ -1,7 +1,7 @@
- Add the min-cache-ttl config knob.
- Add the override-cache-ttl config knob.
---- bin/named/config.c.orig 2020-06-10 18:00:37 UTC
+--- bin/named/config.c.orig 2020-10-13 11:00:08 UTC
+++ bin/named/config.c
@@ -182,6 +182,8 @@ options {\n\
" max-acache-size 16M;\n\
@@ -12,7 +12,7 @@
max-clients-per-query 100;\n\
max-ncache-ttl 10800; /* 3 hours */\n\
max-recursion-depth 7;\n\
---- bin/named/server.c.orig 2020-06-10 18:00:37 UTC
+--- bin/named/server.c.orig 2020-10-13 11:00:08 UTC
+++ bin/named/server.c
@@ -3720,6 +3720,16 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
@@ -31,7 +31,7 @@
result = ns_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2020-06-10 18:00:37 UTC
+--- lib/dns/include/dns/view.h.orig 2020-10-13 11:00:08 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,8 @@ struct dns_view {
bool requestnsid;
@@ -42,9 +42,9 @@
dns_ttl_t maxncachettl;
uint32_t nta_lifetime;
uint32_t nta_recheck;
---- lib/dns/resolver.c.orig 2020-06-10 18:00:37 UTC
+--- lib/dns/resolver.c.orig 2020-10-13 11:00:08 UTC
+++ lib/dns/resolver.c
-@@ -5549,6 +5549,18 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
+@@ -5572,6 +5572,18 @@ cache_name(fetchctx_t *fctx, dns_message_t *rmessage,
}
/*
@@ -63,7 +63,7 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2020-06-10 18:00:37 UTC
+--- lib/isccfg/namedconf.c.orig 2020-10-13 11:00:08 UTC
+++ lib/isccfg/namedconf.c
@@ -1773,6 +1773,8 @@ view_clauses[] = {
#endif
diff --git a/dns/bind911/files/patch-configure b/dns/bind911/files/patch-configure
index 70a2b858c3e0..22c47c328542 100644
--- a/dns/bind911/files/patch-configure
+++ b/dns/bind911/files/patch-configure
@@ -3,9 +3,9 @@
- Make sure only json-c is detected.
- Cleanup the BDB discovery code to find more recent versions.
---- configure.orig 2020-07-03 13:08:06 UTC
+--- configure.orig 2020-10-13 11:00:08 UTC
+++ configure
-@@ -15655,27 +15655,9 @@ done
+@@ -15692,27 +15692,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -35,7 +35,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -15718,47 +15700,7 @@ $as_echo "no" >&6; } ;;
+@@ -15755,47 +15737,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -84,7 +84,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -18595,7 +18537,7 @@ case "$use_libjson" in
+@@ -18662,7 +18604,7 @@ case "$use_libjson" in
auto|yes)
for d in /usr /usr/local /opt/local
do
@@ -93,7 +93,7 @@
then
if test ${d} != /usr
then
-@@ -18603,29 +18545,16 @@ case "$use_libjson" in
+@@ -18670,29 +18612,16 @@ case "$use_libjson" in
LIBS="$LIBS -L${d}/lib"
fi
have_libjson="yes"
@@ -124,7 +124,7 @@
have_libjson_c="yes"
else
as_fn_error $? "$use_libjson/include/json{,-c}/json.h not found." "$LINENO" 5
-@@ -24839,7 +24768,7 @@ $as_echo "" >&6; }
+@@ -24967,7 +24896,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).
diff --git a/dns/bind911/pkg-plist b/dns/bind911/pkg-plist
index 3d665426fc04..86422256566d 100644
--- a/dns/bind911/pkg-plist
+++ b/dns/bind911/pkg-plist
@@ -132,6 +132,7 @@ include/isc/bind9.h
include/isc/boolean.h
include/isc/buffer.h
include/isc/bufferlist.h
+include/isc/cmocka.h
include/isc/commandline.h
include/isc/condition.h
include/isc/counter.h