aboutsummaryrefslogtreecommitdiff
path: root/dns/bind912/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/bind912/Makefile')
-rw-r--r--dns/bind912/Makefile32
1 files changed, 12 insertions, 20 deletions
diff --git a/dns/bind912/Makefile b/dns/bind912/Makefile
index f64b8affb185..e66385a923ac 100644
--- a/dns/bind912/Makefile
+++ b/dns/bind912/Makefile
@@ -29,13 +29,11 @@ COMMENT= BIND DNS suite with updated DNSSEC and DNS64
LICENSE= MPL20
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
-BROKEN_powerpc64= fails to link: /usr/bin/ld: cannot find -latomic
-
LIB_DEPENDS= libxml2.so:textproc/libxml2
-USES= cpe libedit
+USES= compiler:c11 cpe libedit
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.12.2-P2
+ISCVERSION= 9.12.3-P1
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
@@ -45,11 +43,11 @@ CPE_UPDATE= ${ISCVERSION:C/.*-//:tl}
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps \
- --disable-symtable \
--with-randomdev=/dev/random \
--with-libxml2=${LOCALBASE} \
--with-readline="-L${LOCALBASE}/lib -ledit" \
--with-dlopen=yes \
+ --with-gost=no \
--sysconfdir=${ETCDIR}
ETCDIR= ${PREFIX}/etc/namedb
@@ -72,9 +70,8 @@ OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE JSON PYTHON
OPTIONS_DEFINE= IDN LARGE_FILE PYTHON JSON \
FIXED_RRSET SIGCHASE IPV6 THREADS
-OPTIONS_RADIO= CRYPTO GOSTDEF
+OPTIONS_RADIO= CRYPTO
OPTIONS_RADIO_CRYPTO= SSL NATIVE_PKCS11
-OPTIONS_RADIO_GOSTDEF= GOST GOST_ASN1
.if !defined(BIND_TOOLS_SLAVE)
OPTIONS_DEFAULT+= DLZ_FILESYSTEM LMDB RPZ_NSDNAME RPZ_NSIP TCP_FASTOPEN
@@ -101,9 +98,6 @@ DLZ_STUB_DESC= DLZ stub driver
DNSTAP_DESC= Provides fast passive logging of DNS messages
FIXED_RRSET_DESC= Enable fixed rrset ordering
GEOIP_DESC= Allow geographically based ACL.
-GOSTDEF_DESC= Enable GOST ciphers, needs SSL
-GOST_ASN1_DESC= GOST using ASN.1
-GOST_DESC= GOST raw keys (new default)
GSSAPI_BASE_DESC= Using Heimdal in base
GSSAPI_HEIMDAL_DESC= Using security/heimdal
GSSAPI_MIT_DESC= Using security/krb5
@@ -150,10 +144,6 @@ FIXED_RRSET_CONFIGURE_ENABLE= fixed-rrset
GEOIP_CONFIGURE_WITH= geoip
GEOIP_LIB_DEPENDS= libGeoIP.so:net/GeoIP
-GOST_ASN1_CONFIGURE_ON= --with-gost=asn1
-
-GOST_CONFIGURE_ON= --with-gost
-
GSSAPI_BASE_CONFIGURE_ON=\
--with-gssapi=${GSSAPIBASEDIR} KRB5CONFIG="${KRB5CONFIG}"
GSSAPI_BASE_USES= gssapi
@@ -220,14 +210,16 @@ TUNING_LARGE_CONFIGURE_OFF= --with-tuning=default
.include <bsd.port.pre.mk>
-.if !${PORT_OPTIONS:MGOST} && !${PORT_OPTIONS:MGOST_ASN1}
-CONFIGURE_ARGS+= --without-gost
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-symtable
+.else
+CONFIGURE_ARGS+= --disable-symtable
.endif
-.if ( ${PORT_OPTIONS:MGOST} || ${PORT_OPTIONS:MGOST_ASN1} ) && ${SSL_DEFAULT} == base
-BROKEN= OpenSSL from the base system does not support GOST, add \
- DEFAULT_VERSIONS+=ssl=openssl to your /etc/make.conf and rebuild everything \
- that needs SSL.
+.if ${SSL_DEFAULT} == base
+SUB_LIST+= ENGINES=/usr/lib/engines
+.else
+SUB_LIST+= ENGINES=${LOCALBASE}/lib/engines
.endif
post-patch: