aboutsummaryrefslogtreecommitdiff
path: root/dns/bind913/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/bind913/Makefile')
-rw-r--r--dns/bind913/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/dns/bind913/Makefile b/dns/bind913/Makefile
index 40bbf13e8f14..2e63ccfc1e01 100644
--- a/dns/bind913/Makefile
+++ b/dns/bind913/Makefile
@@ -31,9 +31,9 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
LIB_DEPENDS= libxml2.so:textproc/libxml2
-USES= cpe libedit ssl
+USES= compiler:c11 cpe libedit ssl
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.13.3
+ISCVERSION= 9.13.5
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
@@ -43,7 +43,6 @@ CPE_UPDATE= ${ISCVERSION:C/.*-//:tl}
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps \
- --disable-symtable \
--with-libxml2=${LOCALBASE} \
--with-readline="-L${LOCALBASE}/lib -ledit" \
--with-dlopen=yes \
@@ -199,6 +198,18 @@ TUNING_LARGE_CONFIGURE_OFF= --with-tuning=default
.include <bsd.port.pre.mk>
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-symtable
+.else
+CONFIGURE_ARGS+= --disable-symtable
+.endif
+
+.if ${SSL_DEFAULT} == base
+SUB_LIST+= ENGINES=/usr/lib/engines
+.else
+SUB_LIST+= ENGINES=${LOCALBASE}/lib/engines
+.endif
+
post-patch:
.if defined(BIND_TOOLS_SLAVE)
@${REINPLACE_CMD} -e 's#^SUBDIRS.*#SUBDIRS = lib bin#' \