aboutsummaryrefslogtreecommitdiff
path: root/dns/c-ares/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/c-ares/Makefile')
-rw-r--r--dns/c-ares/Makefile19
1 files changed, 16 insertions, 3 deletions
diff --git a/dns/c-ares/Makefile b/dns/c-ares/Makefile
index dc03727015a6..29354fccedd9 100644
--- a/dns/c-ares/Makefile
+++ b/dns/c-ares/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= c-ares
-PORTVERSION= 1.6.0
+PORTVERSION= 1.7.0
CATEGORIES= dns
MASTER_SITES= http://c-ares.haxx.se/
@@ -15,6 +15,7 @@ COMMENT= An asynchronous DNS resolver library
OPTIONS= CONFIG_INFO "Add the ares_config_info patch" ON \
DEBUG "Build with debug information" OFF \
+ HIDE_SYMBOLS "Hide internal library symbols" ON \
OPTIMIZED_CFLAGS "Build with compiler optimizations" OFF
CONFLICTS= ares-1.*
@@ -32,6 +33,11 @@ CONFIGURE_ARGS+= --enable-debug
.else
CONFIGURE_ARGS+= --disable-debug
.endif
+.if defined(WITH_HIDE_SYMBOLS)
+CONFIGURE_ARGS+= --enable-symbol-hiding
+.else
+CONFIGURE_ARGS+= --disable-symbol-hiding
+.endif
.if defined(WITH_OPTIMIZED_CFLAGS)
CONFIGURE_ARGS+= --enable-optimize
.else
@@ -45,19 +51,21 @@ MAKE_ENV= SHLIB_VER="${SHLIB_VER}"
PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-shared
+CONFIGURE_ARGS+= --enable-shared
MAN3= ares_cancel.3 \
ares_destroy.3 ares_dup.3 \
ares_expand_name.3 ares_expand_string.3 \
ares_fds.3 \
- ares_free_hostent.3 ares_free_string.3 \
+ ares_free_data.3 ares_free_hostent.3 ares_free_string.3 \
ares_gethostbyaddr.3 ares_gethostbyname.3 ares_gethostbyname_file.3 \
ares_getnameinfo.3 \
ares_getsock.3 \
ares_init.3 ares_init_options.3 \
+ ares_library_cleanup.3 ares_library_init.3 \
ares_mkquery.3 \
ares_parse_a_reply.3 ares_parse_aaaa_reply.3 ares_parse_ptr_reply.3 \
+ ares_parse_srv_reply.3 ares_parse_txt_reply.3 \
ares_process.3 \
ares_query.3 \
ares_search.3 \
@@ -69,4 +77,9 @@ MAN3= ares_cancel.3 \
ares_destroy_options.3 \
ares_save_options.3
+PROGRAMS= acountry adig ahost
+
+post-install:
+ ${INSTALL_PROGRAM} ${PROGRAMS:S@^@${WRKSRC}/.libs/@} ${PREFIX}/bin/
+
.include <bsd.port.post.mk>