aboutsummaryrefslogtreecommitdiff
path: root/dns/dnsdist/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/dnsdist/Makefile')
-rw-r--r--dns/dnsdist/Makefile48
1 files changed, 25 insertions, 23 deletions
diff --git a/dns/dnsdist/Makefile b/dns/dnsdist/Makefile
index 450f186886cb..1b8ac49b9ffc 100644
--- a/dns/dnsdist/Makefile
+++ b/dns/dnsdist/Makefile
@@ -2,13 +2,11 @@
# $FreeBSD$
PORTNAME= dnsdist
-DISTVERSION= 1.3.3
-PORTREVISION= 13
+DISTVERSION= 1.4.0
CATEGORIES= dns net
-MASTER_SITES= https://downloads.powerdns.com/releases/ \
- LOCAL/cpm
+MASTER_SITES= https://downloads.powerdns.com/releases/
-MAINTAINER= cpm@FreeBSD.org
+MAINTAINER= tremere@cainites.net
COMMENT= Highly DNS-, DoS- and abuse-aware loadbalancer
LICENSE= GPLv2 UNLICENSE
@@ -18,54 +16,58 @@ LICENSE_FILE_UNLICENSE= ${WRKSRC}/ext/incbin/UNLICENSE
BUILD_DEPENDS= ${LOCALBASE}/lib/libatomic_ops.a:devel/libatomic_ops
LIB_DEPENDS= libboost_serialization.so:devel/boost-libs \
+ libh2o-evloop.so:www/h2o \
libprotobuf.so:devel/protobuf \
libre2.so:devel/re2 \
libsodium.so:security/libsodium
-GNU_CONFIGURE= yes
USES= bison compiler:c++14-lang cpe gmake libedit libtool localbase \
pkgconfig tar:bz2
+USE_RC_SUBR= dnsdist
+
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --bindir=${PREFIX}/sbin \
+ --enable-dns-over-https \
--enable-dns-over-tls \
--enable-dnscrypt \
- --enable-libsodium \
- --enable-re2
+ --sysconfdir=${ETCDIR} \
+ --with-libsodium \
+ --with-re2
INSTALL_TARGET= install-strip
USERS= _dnsdist
GROUPS= _dnsdist
-USE_RC_SUBR= dnsdist
-
-OPTIONS_DEFINE= FSTRM LUAJIT SNMP
+OPTIONS_DEFINE= DNSTAP LUAJIT SNMP
OPTIONS_DEFAULT= GNUTLS OPENSSL
OPTIONS_MULTI= TLS
OPTIONS_MULTI_TLS= GNUTLS OPENSSL
-FSTRM_DESC= dnstap support (see dnstap.info)
-LUAJIT_DESC= Use LuaJIT instead of Lua
+DNSTAP_DESC= dnstap support (see dnstap.info)
+LUAJIT_DESC= Use LuaJIT instead of Lua
-FSTRM_LIB_DEPENDS= libfstrm.so:devel/fstrm
-FSTRM_CONFIGURE_ENABLE= fstrm
+DNSTAP_LIB_DEPENDS= libfstrm.so:devel/fstrm
+DNSTAP_CONFIGURE_ENABLE= fstrm
-GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
-GNUTLS_CONFIGURE_ENABLE=gnutls
+GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
+GNUTLS_CONFIGURE_ENABLE= gnutls
-LUAJIT_LIB_DEPENDS= libluajit-5.1.so:lang/luajit
+LUAJIT_LIB_DEPENDS= libluajit-5.1.so:lang/luajit-openresty
LUAJIT_USES_OFF= lua
-LUAJIT_CONFIGURE_ON= --with-lua=luajit
LUAJIT_CONFIGURE_OFF= --with-lua=lua-${LUA_VER}
+LUAJIT_CONFIGURE_ON= --with-lua=luajit
OPENSSL_USES= ssl
-OPENSSL_CONFIGURE_ENABLE=libssl
-OPENSSL_CONFIGURE_ON= LIBSSL_CFLAGS=-I${OPENSSLINC} LIBSSL_LIBS="-L${OPENSSLLIB} -lssl"
+OPENSSL_CONFIGURE_ON= LIBSSL_CFLAGS=-I${OPENSSLINC} \
+ LIBSSL_LIBS="-L${OPENSSLLIB} -lssl"
+OPENSSL_CONFIGURE_WITH= libssl
SNMP_LIB_DEPENDS= libnetsnmp.so:net-mgmt/net-snmp
SNMP_CONFIGURE_WITH= net-snmp
post-install:
- ${INSTALL_DATA} ${FILESDIR}/dnsdist.conf.sample \
- ${STAGEDIR}${PREFIX}/etc
+ @${MKDIR} ${STAGEDIR}${ETCDIR}
+ ${INSTALL_DATA} ${FILESDIR}/dnsdist.conf.sample ${STAGEDIR}${ETCDIR}
.include <bsd.port.mk>