aboutsummaryrefslogtreecommitdiff
path: root/dns/dnsperf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/dnsperf/Makefile')
-rw-r--r--dns/dnsperf/Makefile24
1 files changed, 8 insertions, 16 deletions
diff --git a/dns/dnsperf/Makefile b/dns/dnsperf/Makefile
index 6831fa1eab8d..cb710b0808f3 100644
--- a/dns/dnsperf/Makefile
+++ b/dns/dnsperf/Makefile
@@ -2,11 +2,9 @@
# $FreeBSD$
PORTNAME= dnsperf
-PORTVERSION= 2.1.0.0
-PORTREVISION= 2
+PORTVERSION= 2.2.1
+DISTVERSIONPREFIX=v
CATEGORIES= dns benchmarks net
-MASTER_SITES= ftp://ftp.nominum.com/pub/nominum/${PORTNAME}/${PORTVERSION}/
-DISTNAME= ${PORTNAME}-src-${PORTVERSION}-1
MAINTAINER= hrs@FreeBSD.org
COMMENT= Performance measurement of Domain Name System (DNS) servers
@@ -15,10 +13,13 @@ LICENSE= ISCL
BUILD_DEPENDS= isc-config.sh:dns/bind912
LIB_DEPENDS= liblmdb.so:databases/lmdb \
- libjson-c.so:devel/json-c
+ libjson-c.so:devel/json-c \
+ libxml2.so:textproc/libxml2
-USES= iconv ssl
-USE_GNOME= libxml2
+USES= autoreconf gnome iconv libtool ssl
+USE_GITHUB= yes
+
+GH_ACCOUNT= DNS-OARC
GNU_CONFIGURE= yes
MAKE_ENV= INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
@@ -29,14 +30,5 @@ PLIST_FILES= bin/dnsperf \
bin/resperf-report \
man/man1/dnsperf.1.gz \
man/man1/resperf.1.gz
-PORTDOCS= caching-dns-performance.pdf \
- dnsperf.pdf \
- resperf.pdf
-
-OPTIONS_DEFINE= DOCS
-
-post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>