aboutsummaryrefslogtreecommitdiff
path: root/dns/fastresolve/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/fastresolve/Makefile')
-rw-r--r--dns/fastresolve/Makefile58
1 files changed, 0 insertions, 58 deletions
diff --git a/dns/fastresolve/Makefile b/dns/fastresolve/Makefile
deleted file mode 100644
index f374c39a69b2..000000000000
--- a/dns/fastresolve/Makefile
+++ /dev/null
@@ -1,58 +0,0 @@
-# New ports collection makefile for: fastresolve
-# Date created: 11 June 2002
-# Whom: verm@drunkmonk.net
-#
-# $FreeBSD$
-#
-
-PORTNAME= fastresolve
-PORTVERSION= 2.10
-PORTREVISION= 1
-CATEGORIES= sysutils
-MASTER_SITES= http://www.djmnet.org/sw/dist/
-
-MAINTAINER= martin@tradex.sk
-COMMENT= Programs that process web logs to get DNS and domain ownership info
-
-LIB_DEPENDS= adns.1:${PORTSDIR}/dns/adns
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/BerkeleyDB.pm:${PORTSDIR}/databases/p5-BerkeleyDB
-
-USE_BZIP2= yes
-USE_PERL5= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
- CXXFLAGS="-I${LOCALBASE}/include" \
- PERL=${PERL}
-USE_AUTOMAKE_VER= 14
-
-# Default to db3
-WITH_BDB_VER?= 3
-
-.if ${WITH_BDB_VER} == 3
-LIB_DEPENDS+= db3.3:${PORTSDIR}/databases/db3
-CONFIGURE_ARGS= --with-bdb-lib=-ldb3_cxx --with-bdb-incdir=${LOCALBASE}/include/db3
-.elif ${WITH_BDB_VER} == 4
-LIB_DEPENDS+= db4.0:${PORTSDIR}/databases/db4
-CONFIGURE_ARGS= --with-bdb-lib=-ldb4_cxx --with-bdb-incdir=${LOCALBASE}/include/db4
-.elif ${WITH_BDB_VER} == 41
-LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
-CONFIGURE_ARGS= --with-bdb-lib=-ldb41_cxx --with-bdb-incdir=${LOCALBASE}/include/db41
-.else
-.error WITH_BDB_VER must be one between 3, 4 and 41
-.endif
-
-MAN1= dns-terror.1 btree-dump.1 convert-dom-db.1 convert-ip-db.1 \
- expire-ip-db.1 getdominfo.1 rebuild-dom-db.1 rebuild-ip-db.1 \
- reresolve.1 make-report.1
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for f in AUTHORS COPYING ChangeLog INSTALL NEWS README
- @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
- @${INSTALL_DATA} ${WRKSRC}/doc/TODO ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/timings ${DOCSDIR}
-.endif
-
-.include <bsd.port.mk>