aboutsummaryrefslogtreecommitdiff
path: root/dns/hs-dns
diff options
context:
space:
mode:
Diffstat (limited to 'dns/hs-dns')
-rw-r--r--dns/hs-dns/Makefile8
-rw-r--r--dns/hs-dns/distinfo6
-rw-r--r--dns/hs-dns/files/patch-dns.cabal34
3 files changed, 7 insertions, 41 deletions
diff --git a/dns/hs-dns/Makefile b/dns/hs-dns/Makefile
index 8bb869a99883..fd1826e32b07 100644
--- a/dns/hs-dns/Makefile
+++ b/dns/hs-dns/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= dns
-PORTVERSION= 2.0.10
-PORTREVISION= 1
+PORTVERSION= 3.0.2
CATEGORIES= dns haskell
MAINTAINER= haskell@FreeBSD.org
@@ -10,8 +9,9 @@ COMMENT= DNS library in Haskell
LICENSE= BSD3CLAUSE
-USE_CABAL= attoparsec blaze-builder conduit>=1.1 conduit-extra>=1.1 \
- iproute>=1.2.4 mtl network>=2.3 random resourcet safe
+USE_CABAL= attoparsec auto-update base64-bytestring blaze-builder \
+ conduit>=1.1 conduit-extra>=1.1 cryptonite iproute>=1.2.4 \
+ mtl network>=2.3 psqueues random resourcet safe
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/dns/hs-dns/distinfo b/dns/hs-dns/distinfo
index 599dc196d340..2fb3f865d69d 100644
--- a/dns/hs-dns/distinfo
+++ b/dns/hs-dns/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1499620675
-SHA256 (cabal/dns-2.0.10.tar.gz) = ba03bc8fe25b58fd066588569eb5707a245cb098181e2d5cca72c239849aa6a3
-SIZE (cabal/dns-2.0.10.tar.gz) = 24142
+TIMESTAMP = 1524597697
+SHA256 (cabal/dns-3.0.2.tar.gz) = f1a895a136e1b5a77ca0d00ff627993ee3fd2f4bbd7db7de80717668e53172a4
+SIZE (cabal/dns-3.0.2.tar.gz) = 37022
diff --git a/dns/hs-dns/files/patch-dns.cabal b/dns/hs-dns/files/patch-dns.cabal
deleted file mode 100644
index deed89903df0..000000000000
--- a/dns/hs-dns/files/patch-dns.cabal
+++ /dev/null
@@ -1,34 +0,0 @@
---- dns.cabal.orig 2017-07-11 15:30:47 UTC
-+++ dns.cabal
-@@ -30,7 +30,6 @@ Library
- , attoparsec
- , binary
- , bytestring
-- , bytestring-builder
- , conduit >= 1.1
- , conduit-extra >= 1.1
- , containers
-@@ -45,7 +44,6 @@ Library
- , attoparsec
- , binary
- , bytestring
-- , bytestring-builder
- , conduit >= 1.1
- , conduit-extra >= 1.1
- , containers
-@@ -67,7 +65,6 @@ Test-Suite network
- Build-Depends: dns
- , base
- , bytestring
-- , bytestring-builder
- , hspec
-
- Test-Suite spec
-@@ -82,7 +79,6 @@ Test-Suite spec
- , attoparsec
- , binary
- , bytestring
-- , bytestring-builder
- , conduit >= 1.1
- , conduit-extra >= 1.1
- , containers