aboutsummaryrefslogtreecommitdiff
path: root/dns/libasr/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/libasr/Makefile')
-rw-r--r--dns/libasr/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/dns/libasr/Makefile b/dns/libasr/Makefile
new file mode 100644
index 000000000000..45bf89f367f6
--- /dev/null
+++ b/dns/libasr/Makefile
@@ -0,0 +1,24 @@
+# Created by: Ashish SHUKLA <ashish@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libasr
+PORTVERSION= 1.0.1
+CATEGORIES= dns
+MASTER_SITES= http://www.opensmtpd.org/archives/ \
+ http://distfiles.pirateparty.in/ashish/
+
+MAINTAINER= ashish@FreeBSD.org
+COMMENT= Asynchronous DNS resolver library
+
+LICENSE= ISCL BSD4CLAUSE BSD3CLAUSE BSD2CLAUSE
+LICENSE_COMB= multi
+LICENSE_FILE= ${WRKSRC}/LICENCE
+
+CONFLICTS= libasr-devel-[0-9]*
+GNU_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>