aboutsummaryrefslogtreecommitdiff
path: root/dns/p5-BIND-Config-Parser/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/p5-BIND-Config-Parser/Makefile')
-rw-r--r--dns/p5-BIND-Config-Parser/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/dns/p5-BIND-Config-Parser/Makefile b/dns/p5-BIND-Config-Parser/Makefile
new file mode 100644
index 000000000000..11195c2f512d
--- /dev/null
+++ b/dns/p5-BIND-Config-Parser/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: dns/p5-BIND-Config-Parser
+# Date created: 05 May 2010
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= BIND-Config-Parser
+PORTVERSION= 0.01
+CATEGORIES= dns perl5
+MASTER_SITES= CPAN/../../authors/id/M/MA/MATTD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Parse BIND Config files
+
+BUILD_DEPENDS= ${SITE_PERL}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= BIND::Config::Parser.3
+
+.include <bsd.port.mk>