aboutsummaryrefslogtreecommitdiff
path: root/dns/p5-POE-Component-Server-DNS/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/p5-POE-Component-Server-DNS/Makefile')
-rw-r--r--dns/p5-POE-Component-Server-DNS/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/dns/p5-POE-Component-Server-DNS/Makefile b/dns/p5-POE-Component-Server-DNS/Makefile
new file mode 100644
index 000000000000..24fe4527c09a
--- /dev/null
+++ b/dns/p5-POE-Component-Server-DNS/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-POE-Component-Server-DNS
+# Date created: 2007-02-23
+# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-Server-DNS
+PORTVERSION= 0.05
+CATEGORIES= dns perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tjs@cdpa.nsysu.edu.tw
+COMMENT= Non-blocking, concurrent DNS server component
+
+RUN_DEPENDS= p5-POE>=0.38:${PORTSDIR}/devel/p5-POE \
+ p5-Net-DNS>=0.58:${PORTSDIR}/dns/p5-Net-DNS \
+ p5-POE-Component-Client-DNS>=1.00:${PORTSDIR}/dns/p5-POE-Component-Client-DNS \
+ p5-POE-Component-Generic>=0.09.10:${PORTSDIR}/net/p5-POE-Component-Generic
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::Server::DNS.3
+
+.include <bsd.port.mk>