aboutsummaryrefslogtreecommitdiff
path: root/dns/powerdns-devel
diff options
context:
space:
mode:
Diffstat (limited to 'dns/powerdns-devel')
-rw-r--r--dns/powerdns-devel/Makefile7
-rw-r--r--dns/powerdns-devel/files/pdns.sh.sample7
2 files changed, 8 insertions, 6 deletions
diff --git a/dns/powerdns-devel/Makefile b/dns/powerdns-devel/Makefile
index 606b9642e264..64333597c989 100644
--- a/dns/powerdns-devel/Makefile
+++ b/dns/powerdns-devel/Makefile
@@ -1,3 +1,4 @@
+# New ports collection makefile for: powerdns
# Date Created: 14.Jan 2003
# Whom: dirk.meyer@dinoex.sub.org
#
@@ -6,6 +7,7 @@
PORTNAME= powerdns
PORTVERSION= 2.9.16
+PORTREVISION= 1
CATEGORIES= dns ipv6
MASTER_SITES= http://downloads.powerdns.com/releases/
DISTNAME= pdns-${PORTVERSION}
@@ -127,7 +129,10 @@ post-install:
.endif
.if !exists(${STARTUP_SCRIPT})
${ECHO_MSG} "Installing ${STARTUP_SCRIPT} startup file."
- ${INSTALL_SCRIPT} ${FILESDIR}/pdns.sh.sample ${STARTUP_SCRIPT}
+ ${SED} -e "s=%%PREFIX%%=${PREFIX}=" \
+ ${FILESDIR}/pdns.sh.sample \
+ > ${WRKSRC}/pdns.sh.sample
+ ${INSTALL_SCRIPT} ${WRKSRC}/pdns.sh.sample ${STARTUP_SCRIPT}
.endif
.include <bsd.port.post.mk>
diff --git a/dns/powerdns-devel/files/pdns.sh.sample b/dns/powerdns-devel/files/pdns.sh.sample
index d19be1bfd061..b5899e363ee1 100644
--- a/dns/powerdns-devel/files/pdns.sh.sample
+++ b/dns/powerdns-devel/files/pdns.sh.sample
@@ -2,11 +2,7 @@
rc_file=${0##*/}
-if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/${rc_file}\$"); then
- echo "${rc_file}: Cannot determine PREFIX." >&2
- echo "Please use the complete pathname." >&2
- exit 64
-fi
+PREFIX=%%PREFIX%%
pdns=${PREFIX}/sbin/pdns_server
pdnscontrol=${PREFIX}/bin/pdns_control
@@ -18,6 +14,7 @@ if [ "x$1" = "x" -o "x$1" = "xstart" ]; then
if [ -f $pdns ]; then
echo -n ' PowerDNS'
if [ -f $pdnsrecursor ]; then
+ rm $recursorpid >/dev/null 2>&1
$pdnsrecursor >/dev/null 2>&1
fi
$pdns