aboutsummaryrefslogtreecommitdiff
path: root/dns/powerdns/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/powerdns/Makefile')
-rw-r--r--dns/powerdns/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/dns/powerdns/Makefile b/dns/powerdns/Makefile
index 5515bf40ac8c..a15970b8cacd 100644
--- a/dns/powerdns/Makefile
+++ b/dns/powerdns/Makefile
@@ -75,14 +75,16 @@ describe:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500000 && defined(POWERDNS_WITH_RECURSOR)
+.if defined(POWERDNS_WITH_RECURSOR)
+USE_GCC=3.2
CONFIGURE_ARGS+= --enable-recursor
PLIST_SUB+= RECURSOR=""
.else
PLIST_SUB+= RECURSOR="@comment "
.endif
-.if ${OSVERSION} >= 500043 && defined(WITH_LDAP)
+.if defined(WITH_LDAP)
+USE_GCC=3.2
LIB_DEPENDS+= ldap.2:${PORTSDIR}/${LDAP_PORT}
LIB_DEPENDS+= lber.2:${PORTSDIR}/${LDAP_PORT}
CONFIGURE_MODULES+= "ldap"