aboutsummaryrefslogtreecommitdiff
path: root/dns/py-adns
diff options
context:
space:
mode:
Diffstat (limited to 'dns/py-adns')
-rw-r--r--dns/py-adns/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/dns/py-adns/Makefile b/dns/py-adns/Makefile
index 795a7fcb628f..242602098e3c 100644
--- a/dns/py-adns/Makefile
+++ b/dns/py-adns/Makefile
@@ -18,11 +18,12 @@ LIB_DEPENDS= adns.1:${PORTSDIR}/net/adns
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+USE_REINPLACE= yes
PLIST_SUB+= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S/^${LOCALBASE}\///g}
post-patch:
- @${PERL} -pi -e 's|^(include_dirs = ).*$$|\1\["${LOCALBASE}/include"\]|g; \
- s|^(library_dirs = ).*$$|\1\["${LOCALBASE}/lib"\]|g' \
+ @${REINPLACE_CMD} -e 's|^\(include_dirs = \).*$$|\1\["${LOCALBASE}/include"\]|g' \
+ -e 's|^\(library_dirs = \).*$$|\1\["${LOCALBASE}/lib"\]|g' \
${WRKSRC}/setup.py
.include <bsd.port.mk>