aboutsummaryrefslogtreecommitdiff
path: root/dns/py-dnspython/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/py-dnspython/Makefile')
-rw-r--r--dns/py-dnspython/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/dns/py-dnspython/Makefile b/dns/py-dnspython/Makefile
new file mode 100644
index 000000000000..9158a3d4f8a7
--- /dev/null
+++ b/dns/py-dnspython/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: dnspython
+# Date created: Sun Dec 26 09:58:59 UTC 2004
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dnspython
+PORTVERSION= 1.3.2
+CATEGORIES= dns python
+MASTER_SITES= http://www.dnspython.org/kits/stable/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= A DNS toolkit for Python
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PORTDOCS= \
+ ChangeLog \
+ README \
+ TODO
+EXAMPLE_FILES= \
+ mx.py \
+ name.py \
+ reverse.py \
+ xfr.py
+
+poast-extract:
+ @${CHMOD} -Rf u+w ${WRKSRC}
+
+post-install:
+# docs
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+# examples
+ @${MKDIR} ${EXAMPLESDIR}
+.for file in ${EXAMPLE_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/examples/${file} ${EXAMPLESDIR}
+.endfor
+
+.include <bsd.port.mk>