aboutsummaryrefslogtreecommitdiff
path: root/dns/totd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/totd/Makefile')
-rw-r--r--dns/totd/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/dns/totd/Makefile b/dns/totd/Makefile
index 38121c0f656e..95fce5477284 100644
--- a/dns/totd/Makefile
+++ b/dns/totd/Makefile
@@ -16,9 +16,13 @@ MAN8= totd.8
USE_RC_SUBR= YES
GNU_CONFIGURE= YES
+USE_REINPLACE= YES
RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
+post-patch:
+ @${REINPLACE_CMD} -e 's/%zd/%d/g' ${WRKSRC}/*.c
+
post-install:
${INSTALL_DATA} ${FILESDIR}/totd.conf.sample ${PREFIX}/etc
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \