aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
Diffstat (limited to 'dns')
-rw-r--r--dns/autotrust/Makefile3
-rw-r--r--dns/dhisd/Makefile1
-rw-r--r--dns/fastresolve/Makefile6
-rw-r--r--dns/ldapdns/Makefile1
-rw-r--r--dns/libidn/Makefile4
-rw-r--r--dns/posadis/Makefile3
6 files changed, 8 insertions, 10 deletions
diff --git a/dns/autotrust/Makefile b/dns/autotrust/Makefile
index 276210995767..9063063236bf 100644
--- a/dns/autotrust/Makefile
+++ b/dns/autotrust/Makefile
@@ -18,9 +18,8 @@ LIB_DEPENDS+= ldns.1:${PORTSDIR}/dns/ldns \
unbound.2:${PORTSDIR}/dns/unbound
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
CFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
MAN8= autotrust.8
diff --git a/dns/dhisd/Makefile b/dns/dhisd/Makefile
index 3a60c77646db..87e9461aff60 100644
--- a/dns/dhisd/Makefile
+++ b/dns/dhisd/Makefile
@@ -18,7 +18,6 @@ LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
CFLAGS+= -I${PREFIX}/include
LDFLAGS+= -L${PREFIX}/lib
-MAKE_ENV= LDFLAGS="${LDFLAGS}"
DOCFILES= CONTRIBUTORS COPYRIGHT INSTALL MODULES README
diff --git a/dns/fastresolve/Makefile b/dns/fastresolve/Makefile
index 17087e6440ab..1119c1559a27 100644
--- a/dns/fastresolve/Makefile
+++ b/dns/fastresolve/Makefile
@@ -24,9 +24,9 @@ USE_BZIP2= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
- CXXFLAGS="-I${LOCALBASE}/include" \
- PERL=${PERL}
+CONFIGURE_ENV= PERL=${PERL}
+LDFLAGS+= -L${LOCALBASE}/lib
+CXXFLAGS+= -I${LOCALBASE}/include
USE_AUTOTOOLS= aclocal14 automake14 autoconf213
USE_BDB= yes
diff --git a/dns/ldapdns/Makefile b/dns/ldapdns/Makefile
index 76aeec0efd6d..0d809f507902 100644
--- a/dns/ldapdns/Makefile
+++ b/dns/ldapdns/Makefile
@@ -21,7 +21,6 @@ LICENSE= GPLv2
USE_OPENLDAP= yes
HAS_CONFIGURE= yes
-CONFIGURE_ENV= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --prefix=${PREFIX}
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/dns/libidn/Makefile b/dns/libidn/Makefile
index 9bccfdc5236a..75af052a6a8b 100644
--- a/dns/libidn/Makefile
+++ b/dns/libidn/Makefile
@@ -19,8 +19,8 @@ USE_ICONV= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_PERL5_BUILD= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
INFO= libidn
diff --git a/dns/posadis/Makefile b/dns/posadis/Makefile
index 9418010ff914..982816c08b78 100644
--- a/dns/posadis/Makefile
+++ b/dns/posadis/Makefile
@@ -18,7 +18,8 @@ LIB_DEPENDS= poslib.0:${PORTSDIR}/devel/poslib
USE_AUTOTOOLS= autoconf libltdl libtool
USE_LDCONFIG= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.if defined(WITH_FAM) || exists(${LOCALBASE}/lib/libfam.so)
CONFIGURE_ARGS= --enable-fam