aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/p5-Net-DNSBL-MultiDaemon/Makefile28
-rw-r--r--dns/p5-Net-DNSBL-MultiDaemon/distinfo3
-rw-r--r--dns/p5-Net-DNSBL-MultiDaemon/pkg-descr21
-rw-r--r--dns/p5-Net-DNSBL-MultiDaemon/pkg-plist29
5 files changed, 82 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 2e4d1e3270b3..026c5bb54838 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -84,6 +84,7 @@
SUBDIR += p5-Net-DNS-ZoneCheck
SUBDIR += p5-Net-DNS-ZoneFile
SUBDIR += p5-Net-DNS-ZoneFile-Fast
+ SUBDIR += p5-Net-DNSBL-MultiDaemon
SUBDIR += p5-Net-Domain-ExpireDate
SUBDIR += p5-Net-Domain-TLD
SUBDIR += p5-Net-LibIDN
diff --git a/dns/p5-Net-DNSBL-MultiDaemon/Makefile b/dns/p5-Net-DNSBL-MultiDaemon/Makefile
new file mode 100644
index 000000000000..5fa97c2a4ea9
--- /dev/null
+++ b/dns/p5-Net-DNSBL-MultiDaemon/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: mail/p5-Net-DNSBL-MultiDaemon
+# Date created: 17 August 2007
+# Whom: Andrew Greenwood <greenwood.andy@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-DNSBL-MultiDaemon
+PORTVERSION= 0.18
+CATEGORIES= dns mail perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= greenwood.andy@gmail.com
+COMMENT= Net::DNSBL::MultiDaemon - multi DNSBL prioritization
+
+BUILD_DEPENDS= ${SITE_PERL}/mach/Unix/Syslog.pm:${PORTSDIR}/sysutils/p5-Unix-Syslog \
+ ${SITE_PERL}/Geo/IP/PurePerl.pm:${PORTSDIR}/net/p5-Geo-IP-PurePerl \
+ ${SITE_PERL}/mach/NetAddr/IP.pm:${PORTSDIR}/net-mgmt/p5-NetAddr-IP \
+ ${SITE_PERL}/Net/DNS/Codes.pm:${PORTSDIR}/dns/p5-Net-DNS-Codes \
+ ${SITE_PERL}/mach/Net/DNS/ToolKit.pm:${PORTSDIR}/dns/p5-Net-DNS-ToolKit
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::DNSBL::MultiDaemon.3 Net::DNSBL::Utilities.3
+
+.include <bsd.port.mk>
diff --git a/dns/p5-Net-DNSBL-MultiDaemon/distinfo b/dns/p5-Net-DNSBL-MultiDaemon/distinfo
new file mode 100644
index 000000000000..a5afa442c3d2
--- /dev/null
+++ b/dns/p5-Net-DNSBL-MultiDaemon/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-DNSBL-MultiDaemon-0.18.tar.gz) = 7822d4c33316b164773d3c3f6d351cd4
+SHA256 (Net-DNSBL-MultiDaemon-0.18.tar.gz) = 3b332589d6c69a0b4039474113d4d6e4551f32aeece49d780f9cfc20114d36b6
+SIZE (Net-DNSBL-MultiDaemon-0.18.tar.gz) = 44593
diff --git a/dns/p5-Net-DNSBL-MultiDaemon/pkg-descr b/dns/p5-Net-DNSBL-MultiDaemon/pkg-descr
new file mode 100644
index 000000000000..1fb15867970b
--- /dev/null
+++ b/dns/p5-Net-DNSBL-MultiDaemon/pkg-descr
@@ -0,0 +1,21 @@
+Net::DNSBL::MultiDaemon is the Perl module that implements the multi_dnsbl
+daemon.
+
+multi_dnsbl is a DNS emulator daemon that increases the efficacy of DNSBL
+look-ups in a mail system. multi_dnsbl may be used as a stand-alone DNSBL or as
+a plug-in for a standard BIND 9 installation. multi_dnsbl shares a common
+configuration file format with the Mail::SpamCannibal sc_BLcheck.pl script so
+that DNSBL's can be maintained in a common configuration file for an entire
+mail installation.
+
+Because DNSBL usefulness is dependent on the nature and source of spam sent to
+a specific site and because sometimes DNSBL's may provide intermittant service,
+multi_dnsbl interrogates them sorted in the order of greatest successful hits.
+DNSBL's that do not respond within the configured timeout period are not
+interrogated at all after 6 consecutive failures, and thereafter will be
+retried not more often than once every hour until they come back online. This
+eliminates the need to place DNSBL's in a particular order in your MTA's config
+file or periodically monitor the DNSBL statistics and/or update the MTA config
+file.
+
+WWW: http://search.cpan.org/~miker/Net-DNSBL-MultiDaemon-0.18/MultiDaemon.pm
diff --git a/dns/p5-Net-DNSBL-MultiDaemon/pkg-plist b/dns/p5-Net-DNSBL-MultiDaemon/pkg-plist
new file mode 100644
index 000000000000..6612a331344b
--- /dev/null
+++ b/dns/p5-Net-DNSBL-MultiDaemon/pkg-plist
@@ -0,0 +1,29 @@
+%%SITE_PERL%%/Net/DNSBL/MultiDaemon.pm
+%%SITE_PERL%%/Net/DNSBL/Utilities.pm
+%%SITE_PERL%%/auto/Net/DNSBL/Utilities/A1271.al
+%%SITE_PERL%%/auto/Net/DNSBL/Utilities/A1272.al
+%%SITE_PERL%%/auto/Net/DNSBL/Utilities/A1273.al
+%%SITE_PERL%%/auto/Net/DNSBL/Utilities/A1274.al
+%%SITE_PERL%%/auto/Net/DNSBL/Utilities/A1275.al
+%%SITE_PERL%%/auto/Net/DNSBL/Utilities/A1276.al
+%%SITE_PERL%%/auto/Net/DNSBL/Utilities/DO.al
+%%SITE_PERL%%/auto/Net/DNSBL/Utilities/_loadSocket.al
+%%SITE_PERL%%/auto/Net/DNSBL/Utilities/autosplit.ix
+%%SITE_PERL%%/auto/Net/DNSBL/Utilities/bystat.al
+%%SITE_PERL%%/auto/Net/DNSBL/Utilities/cntinit.al
+%%SITE_PERL%%/auto/Net/DNSBL/Utilities/list2NetAddr.al
+%%SITE_PERL%%/auto/Net/DNSBL/Utilities/list2hash.al
+%%SITE_PERL%%/auto/Net/DNSBL/Utilities/list_countries.al
+%%SITE_PERL%%/auto/Net/DNSBL/Utilities/matchNetAddr.al
+%%SITE_PERL%%/auto/Net/DNSBL/Utilities/not_found.al
+%%SITE_PERL%%/auto/Net/DNSBL/Utilities/open_udpNB.al
+%%SITE_PERL%%/auto/Net/DNSBL/Utilities/s_response.al
+%%SITE_PERL%%/auto/Net/DNSBL/Utilities/statinit.al
+%%SITE_PERL%%/auto/Net/DNSBL/Utilities/write_stats.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DNSBL/MultiDaemon/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DNSBL/MultiDaemon
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DNSBL
+@dirrm %%SITE_PERL%%/auto/Net/DNSBL/Utilities
+@dirrm %%SITE_PERL%%/auto/Net/DNSBL
+@dirrm %%SITE_PERL%%/auto/Net
+@dirrm %%SITE_PERL%%/Net/DNSBL