aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile2
-rw-r--r--dns/nsec3walker/Makefile34
-rw-r--r--dns/nsec3walker/distinfo3
-rw-r--r--dns/nsec3walker/files/patch-Makefile12
-rw-r--r--dns/nsec3walker/files/patch-collect20
-rw-r--r--dns/nsec3walker/files/patch-unhash11
-rw-r--r--dns/nsec3walker/pkg-descr5
-rw-r--r--dns/sshfp/Makefile41
-rw-r--r--dns/sshfp/distinfo3
-rw-r--r--dns/sshfp/files/patch-sshfp29
-rw-r--r--dns/sshfp/pkg-descr6
-rw-r--r--dns/sshfp/pkg-plist5
12 files changed, 0 insertions, 171 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 264f02c419c2..181a4d660048 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -110,7 +110,6 @@
SUBDIR += nextdns
SUBDIR += noip
SUBDIR += nsd
- SUBDIR += nsec3walker
SUBDIR += nslint
SUBDIR += nsnotifyd
SUBDIR += nsping
@@ -219,7 +218,6 @@
SUBDIR += scavenge
SUBDIR += sheerdns
SUBDIR += sleuth
- SUBDIR += sshfp
SUBDIR += subfinder
SUBDIR += tinystats
SUBDIR += totd
diff --git a/dns/nsec3walker/Makefile b/dns/nsec3walker/Makefile
deleted file mode 100644
index 129ec246fe6c..000000000000
--- a/dns/nsec3walker/Makefile
+++ /dev/null
@@ -1,34 +0,0 @@
-# Created by: Piotr Kubaj <pkubaj@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= nsec3walker
-PORTVERSION= 20101223
-CATEGORIES= dns
-MASTER_SITES= https://dnscurve.org/
-
-MAINTAINER= pkubaj@FreeBSD.org
-COMMENT= Walk NSEC3 secured DNSSEC zones
-
-DEPRECATED= Uses deprecated version of python
-EXPIRATION_DATE= 2020-09-15
-
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bsddb>0:databases/py-bsddb@${PY_FLAVOR} \
- dig:dns/bind-tools
-
-USES= python:2.7 shebangfix ssl
-
-SHEBANG_FILES= ${WRKSRC}/collect ${WRKSRC}/unhash
-PLIST_FILES= bin/collect \
- bin/dicthashes \
- bin/query \
- bin/randomhashes \
- bin/unhash
-
-do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/collect ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/dicthashes ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/query ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/randomhashes ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/unhash ${STAGEDIR}${PREFIX}/bin
-
-.include <bsd.port.mk>
diff --git a/dns/nsec3walker/distinfo b/dns/nsec3walker/distinfo
deleted file mode 100644
index 19265a9006c9..000000000000
--- a/dns/nsec3walker/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1484146216
-SHA256 (nsec3walker-20101223.tar.gz) = 74d873b93d67634d9c1c16c938818ecb90dc6ad391ca6dc57b421c627eeb2e30
-SIZE (nsec3walker-20101223.tar.gz) = 3658
diff --git a/dns/nsec3walker/files/patch-Makefile b/dns/nsec3walker/files/patch-Makefile
deleted file mode 100644
index 0db50c420fdc..000000000000
--- a/dns/nsec3walker/files/patch-Makefile
+++ /dev/null
@@ -1,12 +0,0 @@
---- Makefile.orig 2010-12-24 09:49:40 UTC
-+++ Makefile
-@@ -1,7 +1,7 @@
- all: dicthashes randomhashes
-
- dicthashes: dicthashes.c
-- gcc -O3 -o dicthashes dicthashes.c -lcrypto -lm
-+ cc -O3 -o dicthashes dicthashes.c -lcrypto -lm
-
- randomhashes: randomhashes.c
-- gcc -O3 -o randomhashes randomhashes.c -lcrypto -lm
-+ cc -O3 -o randomhashes randomhashes.c -lcrypto -lm
diff --git a/dns/nsec3walker/files/patch-collect b/dns/nsec3walker/files/patch-collect
deleted file mode 100644
index d834dbe1394d..000000000000
--- a/dns/nsec3walker/files/patch-collect
+++ /dev/null
@@ -1,20 +0,0 @@
---- collect.orig 2010-12-24 09:49:40 UTC
-+++ collect
-@@ -71,7 +71,7 @@ while len(todo) > 0 or len(nexthash) ==
- print "querying",guess,h
- numqueries += 1
- server = servers[r.randrange(len(servers))]
-- query = subprocess.Popen(["./query",guess,server],stdout=subprocess.PIPE).stdout
-+ query = subprocess.Popen(["query",guess,server],stdout=subprocess.PIPE).stdout
- for x in query:
- y = x.strip().split(' ')
- if y[0] == "ns":
-@@ -84,7 +84,7 @@ while len(todo) > 0 or len(nexthash) ==
- print "iterations",y[4]
- salt = binascii.a2b_hex(y[3])
- iterations = int(y[4])
-- hashprocess = subprocess.Popen(["./randomhashes",domain,y[4],y[3]],stdout=subprocess.PIPE)
-+ hashprocess = subprocess.Popen(["randomhashes",domain,y[4],y[3]],stdout=subprocess.PIPE)
- hashes = hashprocess.stdout
- if salt != binascii.a2b_hex(y[3]):
- print "newsalt",binascii.a2b_hex(y[3])
diff --git a/dns/nsec3walker/files/patch-unhash b/dns/nsec3walker/files/patch-unhash
deleted file mode 100644
index da962575af0e..000000000000
--- a/dns/nsec3walker/files/patch-unhash
+++ /dev/null
@@ -1,11 +0,0 @@
---- unhash.orig 2017-01-13 09:05:36 UTC
-+++ unhash
-@@ -35,7 +35,7 @@ print "names:",numnames
-
- if domain and salt and numnames:
- dictprocess = subprocess.Popen(["cat",dictionary],stdout=subprocess.PIPE)
-- hashprocess = subprocess.Popen(["./dicthashes",domain,iterations,salt],stdin=dictprocess.stdout,stdout=subprocess.PIPE)
-+ hashprocess = subprocess.Popen(["dicthashes",domain,iterations,salt],stdin=dictprocess.stdout,stdout=subprocess.PIPE)
- for line in hashprocess.stdout:
- numhashes += 1
- x = line.strip().split()
diff --git a/dns/nsec3walker/pkg-descr b/dns/nsec3walker/pkg-descr
deleted file mode 100644
index ea5752218646..000000000000
--- a/dns/nsec3walker/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-Installing current DNSSEC (NSEC3) exposes private DNS data to low-cost
-DNS database espionage. The nsec3walker tool allows administrators and users
-to see how much private information is being given away by DNSSEC.
-
-WWW: https://dnscurve.org/nsec3walker.html
diff --git a/dns/sshfp/Makefile b/dns/sshfp/Makefile
deleted file mode 100644
index 6d840fa2e7de..000000000000
--- a/dns/sshfp/Makefile
+++ /dev/null
@@ -1,41 +0,0 @@
-# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= sshfp
-PORTVERSION= 1.2.2
-PORTREVISION= 5
-CATEGORIES= dns security
-
-MAINTAINER= ehaupt@FreeBSD.org
-COMMENT= Generate SSHFP DNS records from knownhosts files or ssh-keyscan
-
-LICENSE= GPLv2
-
-DEPRECATED= Uses deprecated version of python
-EXPIRATION_DATE= 2020-09-15
-
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/dns/__init__.py:dns/py-dnspython@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}ipcalc>=0.6:net-mgmt/py-ipcalc@${PY_FLAVOR} \
- ${PYTHON_SITELIBDIR}/ldns.py:dns/py-ldns@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
-
-USES= python:2.7 shebangfix
-USE_GITHUB= yes
-
-GH_ACCOUNT= xelerance
-
-NO_ARCH= yes
-NO_BUILD= yes
-
-PY_FILES= sshfp dane
-SHEBANG_FILES= daneldnsx.py ${PY_FILES}
-
-do-install:
-.for f in ${PY_FILES}
- ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${f}.1 ${STAGEDIR}${MANPREFIX}/man/man1
-.endfor
- @${MKDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/daneldnsx.py ${STAGEDIR}${PYTHON_SITELIBDIR}
-
-.include <bsd.port.mk>
diff --git a/dns/sshfp/distinfo b/dns/sshfp/distinfo
deleted file mode 100644
index 5ebe5195f449..000000000000
--- a/dns/sshfp/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1555502822
-SHA256 (xelerance-sshfp-1.2.2_GH0.tar.gz) = b951f13de5e4cafaca6c5aafbd8c98234516004171bd7fb14623ddf83dec1ed6
-SIZE (xelerance-sshfp-1.2.2_GH0.tar.gz) = 34690
diff --git a/dns/sshfp/files/patch-sshfp b/dns/sshfp/files/patch-sshfp
deleted file mode 100644
index e3d1ec8f510e..000000000000
--- a/dns/sshfp/files/patch-sshfp
+++ /dev/null
@@ -1,29 +0,0 @@
---- sshfp.orig 2016-01-21 09:01:28 UTC
-+++ sshfp
-@@ -129,7 +129,7 @@ def sshfp_from_file(khfile, wantedHosts)
- fingerprints.append(process_records(data, wantedHosts))
- return "\n".join(fingerprints)
-
--def check_keytype(keytype):
-+def check_keytype(keytype, hostname):
- global algos
- for algo in algos:
- if "ssh-%s" % algo[:-1] == keytype[:-1]:
-@@ -141,7 +141,7 @@ def check_keytype(keytype):
- def process_record(record, hostname):
- (host, keytype, key) = record.split(" ")
- key = key.rstrip()
-- if check_keytype(keytype):
-+ if check_keytype(keytype, hostname):
- record = create_sshfp(hostname, keytype, key)
- return record
- return ""
-@@ -168,7 +168,7 @@ def process_records(data, hostnames):
- if "," in host:
- host = host.split(",")[0]
- if all_hosts or host in hostnames or host == hostnames:
-- if not check_keytype(keytype):
-+ if not check_keytype(keytype, host):
- continue
- all_records.append(create_sshfp(host, keytype, key))
- if all_records:
diff --git a/dns/sshfp/pkg-descr b/dns/sshfp/pkg-descr
deleted file mode 100644
index 6c8176dd6bc9..000000000000
--- a/dns/sshfp/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-sshfp generates DNS SSHFP records from SSH public keys. sshfp can take public
-keys from a knownhosts file or from scanning the host's sshd daemon. The ssh
-client can use these SSHFP records if you set "VerifyHostKeyDNS yes" in the file
-/etc/ssh/ssh_config.
-
-WWW: https://github.com/xelerance/sshfp
diff --git a/dns/sshfp/pkg-plist b/dns/sshfp/pkg-plist
deleted file mode 100644
index 5f144cd05162..000000000000
--- a/dns/sshfp/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-bin/dane
-bin/sshfp
-man/man1/dane.1.gz
-man/man1/sshfp.1.gz
-%%PYTHON_SITELIBDIR%%/daneldnsx.py