aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
Diffstat (limited to 'dns')
-rw-r--r--dns/powerdns-devel/Makefile8
-rw-r--r--dns/powerdns/Makefile8
2 files changed, 12 insertions, 4 deletions
diff --git a/dns/powerdns-devel/Makefile b/dns/powerdns-devel/Makefile
index 493ac6f1ecf6..89a438959c50 100644
--- a/dns/powerdns-devel/Makefile
+++ b/dns/powerdns-devel/Makefile
@@ -30,6 +30,12 @@ MAN8= pdns_control.8 pdns_server.8 zone2sql.8
STARTUP_SCRIPT= ${PREFIX}/etc/rc.d/pdns.sh.sample
LIBMAP_CONF= /etc/libmap.conf
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 600000
+BROKEN= Doesn't compile on FreeBSD 6.0
+.endif
+
# use user config if possible
.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
@@ -84,8 +90,6 @@ PLIST_SUB+= RECURSOR=""
PLIST_SUB+= RECURSOR="@comment "
.endif
-.include <bsd.port.pre.mk>
-
.if defined(POWERDNS_WITH_RECURSOR)
.if exists(/usr/include/ucontext.h) && ${OSVERSION} >= 500000
UCONTEXT!= ${AWK} '/setcontext/ { print "YES" }' \
diff --git a/dns/powerdns/Makefile b/dns/powerdns/Makefile
index 493ac6f1ecf6..89a438959c50 100644
--- a/dns/powerdns/Makefile
+++ b/dns/powerdns/Makefile
@@ -30,6 +30,12 @@ MAN8= pdns_control.8 pdns_server.8 zone2sql.8
STARTUP_SCRIPT= ${PREFIX}/etc/rc.d/pdns.sh.sample
LIBMAP_CONF= /etc/libmap.conf
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 600000
+BROKEN= Doesn't compile on FreeBSD 6.0
+.endif
+
# use user config if possible
.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
@@ -84,8 +90,6 @@ PLIST_SUB+= RECURSOR=""
PLIST_SUB+= RECURSOR="@comment "
.endif
-.include <bsd.port.pre.mk>
-
.if defined(POWERDNS_WITH_RECURSOR)
.if exists(/usr/include/ucontext.h) && ${OSVERSION} >= 500000
UCONTEXT!= ${AWK} '/setcontext/ { print "YES" }' \