aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/dnsproxy/Makefile24
-rw-r--r--dns/dnsproxy/distinfo1
-rw-r--r--dns/dnsproxy/pkg-descr6
-rw-r--r--dns/dnsproxy/pkg-plist1
5 files changed, 33 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index eeda5ecfd768..3acf204677b5 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -18,6 +18,7 @@
SUBDIR += dns_balance
SUBDIR += dnsflood
SUBDIR += dnsmasq
+ SUBDIR += dnsproxy
SUBDIR += dnssecwalker
SUBDIR += dnstop
SUBDIR += dnstracer
diff --git a/dns/dnsproxy/Makefile b/dns/dnsproxy/Makefile
new file mode 100644
index 000000000000..2ab482e18f70
--- /dev/null
+++ b/dns/dnsproxy/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: dnsproxy
+# Date created: 14 January 2004
+# Whom: Clement Laforet <clement@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dnsproxy
+PORTVERSION= 1.13
+CATEGORIES= dns
+MASTER_SITES= http://www.wolfermann.org/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A proxy for DNS queries
+
+GNU_CONFIGURE= YES
+
+MAN1= dnsproxy.1
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/dnsproxy ${PREFIX}/sbin
+ @${INSTALL_MAN} ${WRKSRC}/dnsproxy.1 ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/dns/dnsproxy/distinfo b/dns/dnsproxy/distinfo
new file mode 100644
index 000000000000..56ae96b1618e
--- /dev/null
+++ b/dns/dnsproxy/distinfo
@@ -0,0 +1 @@
+MD5 (dnsproxy-1.13.tar.gz) = 9d7d10ec7a0efcfdd83cbde125f6c681
diff --git a/dns/dnsproxy/pkg-descr b/dns/dnsproxy/pkg-descr
new file mode 100644
index 000000000000..1f5f72428eb9
--- /dev/null
+++ b/dns/dnsproxy/pkg-descr
@@ -0,0 +1,6 @@
+The dnsproxy daemon is a proxy for DNS queries. It forwards these
+queries to two previously configured nameservers: one for authoritative
+queries and another for recursive queries. The received answers are sent
+back to the client unchanged. No local caching is done.
+
+WWW: http://www.wolfermann.org/dnsproxy.html
diff --git a/dns/dnsproxy/pkg-plist b/dns/dnsproxy/pkg-plist
new file mode 100644
index 000000000000..17a96ad92124
--- /dev/null
+++ b/dns/dnsproxy/pkg-plist
@@ -0,0 +1 @@
+sbin/dnsproxy