aboutsummaryrefslogtreecommitdiff
path: root/editors/abiword
diff options
context:
space:
mode:
Diffstat (limited to 'editors/abiword')
-rw-r--r--editors/abiword/Makefile4
-rw-r--r--editors/abiword/files/patch-src_af_util_xp_ut_png.cpp11
-rw-r--r--editors/abiword/files/patch-src_wp_impexp_gtk_ie_impGraphic_GdkPixbuf.cpp20
3 files changed, 33 insertions, 2 deletions
diff --git a/editors/abiword/Makefile b/editors/abiword/Makefile
index bc6164976eca..bee43a93a248 100644
--- a/editors/abiword/Makefile
+++ b/editors/abiword/Makefile
@@ -8,7 +8,7 @@
PORTNAME= abiword
PORTVERSION= 2.8.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= editors
MASTER_SITES= http://www.abisource.com/downloads/%SUBDIR%/${PORTVERSION}/source/
MASTER_SITE_SUBDIR= abiword
@@ -18,7 +18,7 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= An open-source, cross-platform WYSIWYG word processor
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
- png.6:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
wv-1.2:${PORTSDIR}/textproc/wv \
jpeg.11:${PORTSDIR}/graphics/jpeg \
fribidi.3:${PORTSDIR}/converters/fribidi \
diff --git a/editors/abiword/files/patch-src_af_util_xp_ut_png.cpp b/editors/abiword/files/patch-src_af_util_xp_ut_png.cpp
new file mode 100644
index 000000000000..89b99694aacd
--- /dev/null
+++ b/editors/abiword/files/patch-src_af_util_xp_ut_png.cpp
@@ -0,0 +1,11 @@
+--- src/af/util/xp/ut_png.cpp.orig 2010-04-14 23:50:11.000000000 +0200
++++ src/af/util/xp/ut_png.cpp 2012-04-28 06:58:49.000000000 +0200
+@@ -71,7 +71,7 @@
+ * the normal method of doing things with libpng). REQUIRED unless you
+ * set up your own error handlers in the png_create_read_struct() earlier.
+ */
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_read_struct(&png_ptr, &info_ptr, static_cast<png_infopp>(NULL));
diff --git a/editors/abiword/files/patch-src_wp_impexp_gtk_ie_impGraphic_GdkPixbuf.cpp b/editors/abiword/files/patch-src_wp_impexp_gtk_ie_impGraphic_GdkPixbuf.cpp
new file mode 100644
index 000000000000..3c3cf410290c
--- /dev/null
+++ b/editors/abiword/files/patch-src_wp_impexp_gtk_ie_impGraphic_GdkPixbuf.cpp
@@ -0,0 +1,20 @@
+--- src/wp/impexp/gtk/ie_impGraphic_GdkPixbuf.cpp.orig 2010-04-14 23:50:13.000000000 +0200
++++ src/wp/impexp/gtk/ie_impGraphic_GdkPixbuf.cpp 2012-04-28 07:25:54.000000000 +0200
+@@ -185,7 +185,7 @@
+ /** needed for the stejmp context */
+ UT_Error IE_ImpGraphic_GdkPixbuf::_png_write(GdkPixbuf * pixbuf)
+ {
+- if (setjmp(m_pPNG->jmpbuf))
++ if (setjmp(png_jmpbuf(m_pPNG)))
+ {
+ DELETEP(m_pPngBB);
+ png_destroy_write_struct(&m_pPNG, &m_pPNGInfo);
+@@ -446,7 +446,7 @@
+ * the normal method of doing things with libpng). REQUIRED unless you
+ * set up your own error handlers in the png_create_read_struct() earlier.
+ */
+- if (setjmp(m_pPNG->jmpbuf))
++ if (setjmp(png_jmpbuf(m_pPNG)))
+ {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_write_struct(&m_pPNG, &m_pPNGInfo);