aboutsummaryrefslogtreecommitdiff
path: root/editors/abiword
diff options
context:
space:
mode:
Diffstat (limited to 'editors/abiword')
-rw-r--r--editors/abiword/Makefile104
-rw-r--r--editors/abiword/files/patch-..::wv::magick::Makefile.in14
-rw-r--r--editors/abiword/files/patch-GNUmakefile.in (renamed from editors/abiword/files/patch-GNUmakefile.am)33
-rw-r--r--editors/abiword/files/patch-an27
-rw-r--r--editors/abiword/files/patch-ap23
-rw-r--r--editors/abiword/files/patch-aq13
-rw-r--r--editors/abiword/files/patch-autogen.sh57
-rw-r--r--editors/abiword/files/patch-ax10
-rw-r--r--editors/abiword/pkg-plist158
9 files changed, 261 insertions, 178 deletions
diff --git a/editors/abiword/Makefile b/editors/abiword/Makefile
index def4418f9e85..d1b83d514f38 100644
--- a/editors/abiword/Makefile
+++ b/editors/abiword/Makefile
@@ -7,46 +7,53 @@
PORTNAME= AbiWord2
PORTVERSION= 2.0.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.abisource.com/downloads/Version-${PORTVERSION}/lf/
MASTER_SITE_SUBDIR= abiword
DISTNAME= abiword-${PORTVERSION}
+DIST_SUBDIR= AbiWord
MAINTAINER= gnome@FreeBSD.org
COMMENT= An open-source, cross-platform WYSIWYG word processor
# unzip is needed during the installation process
BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
- fribidi.0:${PORTSDIR}/converters/fribidi \
- popt.0:${PORTSDIR}/devel/popt
-
-DIST_SUBDIR= AbiWord
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
+ png.5:${PORTSDIR}/graphics/png \
+ wv-1.0.0:${PORTSDIR}/textproc/wv \
+ fribidi.0:${PORTSDIR}/converters/fribidi
WRKSRC= ${WRKDIR}/abiword-${PORTVERSION}/abi
USE_BZIP2= yes
-USE_X_PREFIX= yes
-USE_AUTOMAKE_VER=14
-USE_AUTOCONF_VER=213
USE_GMAKE= yes
-USE_REINPLACE= yes
USE_ICONV= yes
USE_GNOME= gnomehier libglade2 libxml2
WANT_GNOME= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -liconv"
-CONFIGURE_ARGS= --enable-xft
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-xft \
+ --with-sys-wv \
+ --with-popt=${LOCALBASE} \
+ --with-zlib=${LOCALBASE} \
+ --with-libpng=${LOCALBASE} \
+ --with-libiconv=${LOCALBASE} \
+ --with-libjpeg-prefix=${LOCALBASE} \
+ --disable-peer-config \
+ --enable-cmap=no
MAKEFILE= GNUmakefile
-.include <bsd.port.pre.mk>
-
-.if exists(${LOCALBASE}/include/wv.h)
-BROKEN= "This port cannot be built when textproc/wv is installed because of a header conflict. Please remove textproc/wv, and resume the build. If textproc/wv is no longer installed, please remove ${LOCALBASE}/include/wv.h, and resume the AbiWord2 build"
+.ifndef(WITHOUT_HELP_DOCS)
+PLIST_SUB+= HELPDOCS:=""
+.else
+PLIST_SUB+= HELPDOCS:="@comment "
.endif
+.include <bsd.port.pre.mk>
+
.if ${HAVE_GNOME:Mnautilus2}!="" && ${HAVE_GNOME:Mlibgnomeprintui}!=""
USE_GNOME+= nautilus2 libgnomeprintui
CONFIGURE_ARGS+= --enable-gnome
@@ -54,48 +61,50 @@ PKGNAMESUFFIX= -gnome
GNOME_ENABLED= yes
.endif
-#.if defined(WITH_GUCHARMAP) || exists(${X11BASE}/libdata/pkgconfig/gucharmap.pc)
-#LIB_DEPENDS+= gucharmap.3:${PORTSDIR}/deskutils/gucharmap
-#.else
-CONFIGURE_ARGS+= --enable-cmap=no
-#.endif
-
-.if defined(WITH_ENCHANT) || exists(${LOCALBASE}/lib/libenchant.so)
+.ifndef(WITHOUT_GTKSPELL)
+. if defined(WITH_ENCHANT) || exists(${LOCALBASE}/lib/libenchant.so) && !defined(WITH_ASPELL)
LIB_DEPENDS+= enchant.2:${PORTSDIR}/textproc/enchant
-.elif exists(${LOCALBASE}/lib/libaspell.so)
+CONFIGURE_ARGS+= --disable-pspell
+. elif defined(WITH_ASPELL) || exists(${LOCALBASE}/lib/libaspell.so) && !defined(WITH_ENCHANT)
LIB_DEPENDS+= aspell.15:${PORTSDIR}/textproc/aspell
-.else
+CONFIGURE_ARGS+= --with-pspell=${LOCALBASE} \
+ --disable-enchant
+. else
LIB_DEPENDS+= enchant.2:${PORTSDIR}/textproc/enchant
+CONFIGURE_ARGS+= --disable-pspell
+. endif
+PLIST_SUB+= DICT:="@comment "
+.else
+CONFIGURE_ARGS+= --disable-enchant --disable-pspell
+PLIST_SUB+= DICT:=""
.endif
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "AbiWord2 has the following tunable option(s):"
-# @${ECHO_MSG} " WITH_GUCHARMAP=yes Enable use of Gucharmap as the symbol insertion tool (default: auto)"
+ @${ECHO_MSG} " WITHOUT_HELP_DOCS=yes Disable install the AbiWord HTML Help docs"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "AbiWord2 has the following spell choices: (Enchant is default)"
+ @${ECHO_MSG} " WITH_ASPELL=yes Enable use of the Aspell dictionary backend (default: auto)"
@${ECHO_MSG} " WITH_ENCHANT=yes Enable use of the Enchant dictionary backend broker (default: auto)"
+ @${ECHO_MSG} " WITHOUT_GTKSPELL=yes Don't use either Enchant or Aspell, but still"
+ @${ECHO_MSG} " has spell enable and install dictionary."
@${ECHO_MSG} ""
post-patch:
- @${REINPLACE_CMD} -e 's|%%AUTOMAKE%%|${AUTOMAKE}|g ; \
- s|%%ACLOCAL%%|${ACLOCAL}|g ; \
- s|%%AUTOCONF%%|${AUTOCONF}|g' ${WRKSRC}/autogen.sh
- @${FIND} ${WRKSRC}/ac-helpers -name "*.m4" | ${XARGS} ${REINPLACE_CMD} \
- 's|-ansi||g ; \
- s|-pedantic||g'
+ @${REINPLACE_CMD} -e 's|-ansi||g ; s|-pedantic||g' \
+ ${WRKSRC}/configure
+.ifndef(WITHOUT_HELP_DOCS)
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' \
+ ${WRKDIR}/${DISTNAME}/abiword-docs/Makefile
+.endif
@${FIND} ${WRKSRC}/src/config/platforms -name "*.mk" | ${XARGS} \
- ${REINPLACE_CMD} 's|-ansi||g ; \
- s|-pedantic||g'
- @${RM} -rf ${WRKSRC}/autom4te.cache
-
-pre-configure:
- @cd ${WRKSRC} && ${TOUCH} NEWS README AUTHORS ChangeLog INSTALL
- @cd ${WRKSRC}/ac-helpers && ${RM} -f install-sh mkinstalldirs missing
- @${RM} -f ${WRKSRC}/configure.ac
- @cd ${WRKSRC} && ./autogen.sh && ${TRUE}
+ ${REINPLACE_CMD} 's|-ansi||g ; s|-pedantic||g'
@${FIND} ${WRKSRC} -name GNUmakefile.in | ${XARGS} ${REINPLACE_CMD} -e \
- 's|[(]libdir[)]/@PACKAGE@|(datadir)/@PACKAGE@|g ; \
- s|[(]libdir[)]/bonobo/servers|(prefix)/libdata/bonobo/servers|g; \
- s|@DEFS@|-I${WRKSRC}/../libiconv/include @DEFS@|g' && ${TRUE}
+ 's|@.*PEER.*@||g ; \
+ s|WV_INCLUDES = |#WV_INCLUDES = |g ; \
+ s|[(]libdir[)]/@PACKAGE@|(datadir)/@PACKAGE@|g ; \
+ s|[(]libdir[)]/bonobo/servers|(prefix)/libdata/bonobo/servers|g'
post-install:
.if defined(GNOME_ENABLED)
@@ -103,10 +112,13 @@ post-install:
${PREFIX}/share/gnome/apps/Applications/abiword.desktop
@${LN} -sf ${PREFIX}/share/AbiSuite-2.0/icons/abiword_48.png \
${PREFIX}/share/gnome/pixmaps/abiword_48.png
- @${LN} -sf ${PREFIX}/share/AbiSuite-2.0/GNOME_AbiWord_Control_2_0.server\
+ @${LN} -sf ${PREFIX}/share/AbiSuite-2.0/GNOME_AbiWord_Control_2_0.server \
${PREFIX}/libdata/bonobo/servers/GNOME_AbiWord_Control_2_0.server
@${LN} -sf ${PREFIX}/share/AbiSuite-2.0/abi-nautilus-view-file.xml \
${PREFIX}/share/gnome/gnome-2.0/ui/abi-nautilus-view-file.xml
.endif
+.ifndef(WITHOUT_HELP_DOCS)
+ @cd ${WRKDIR}/${DISTNAME}/abiword-docs && ${MAKE}
+.endif
.include <bsd.port.post.mk>
diff --git a/editors/abiword/files/patch-..::wv::magick::Makefile.in b/editors/abiword/files/patch-..::wv::magick::Makefile.in
deleted file mode 100644
index bfba3a8beb67..000000000000
--- a/editors/abiword/files/patch-..::wv::magick::Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- ../wv/magick/Makefile.in 2001/08/08 11:44:02 1.1
-+++ ../wv/magick/Makefile.in 2001/08/08 11:44:13
-@@ -40,7 +40,7 @@
- all: $(MAGICKOBJECTS)
-
- %.$(OBJEXT): $(srcdir)/%.c
-- $(CC) $(CFLAGS) -c $(srcdir)/$*.c
-+ $(CC) @CPPFLAGS@ $(CFLAGS) -c $(srcdir)/$*.c
-
- clean:
- rm -rf *.$(OBJEXT) core a.$(OBJEXT)ut *.a
diff --git a/editors/abiword/files/patch-GNUmakefile.am b/editors/abiword/files/patch-GNUmakefile.in
index 5aa14570ff3d..fe5958dbc4a8 100644
--- a/editors/abiword/files/patch-GNUmakefile.am
+++ b/editors/abiword/files/patch-GNUmakefile.in
@@ -1,8 +1,19 @@
---- GNUmakefile.am.orig Fri Sep 12 09:18:10 2003
-+++ GNUmakefile.am Thu May 20 01:35:58 2004
-@@ -7,11 +7,11 @@
- libpng_peerdir=@LIBPNG_PEERDIR@
- libpopt_peerdir=$(top_builddir)/../popt
+--- GNUmakefile.in.orig Mon Jun 7 14:59:52 2004
++++ GNUmakefile.in Mon Jun 7 15:01:41 2004
+@@ -156,17 +156,17 @@
+
+ SUBDIRS = src
+
+-expat_peerdir = $(top_builddir)/../expat
+-wv_peerdir = $(top_builddir)/../wv
+-libiconv_peerdir = $(top_builddir)/../libiconv
+-libpng_peerdir = @LIBPNG_PEERDIR@
+-libpopt_peerdir = $(top_builddir)/../popt
++#expat_peerdir = $(top_builddir)/../expat
++#wv_peerdir = $(top_builddir)/../wv
++#libiconv_peerdir = $(top_builddir)/../libiconv
++#libpng_peerdir = @LIBPNG_PEERDIR@
++#libpopt_peerdir = $(top_builddir)/../popt
-desktop_DATA = abiword.desktop
-desktopdir = $(datadir)/applications
@@ -10,13 +21,13 @@
+#desktopdir = $(datadir)/applications
-icon_DATA = abiword_48.png
--icondir= $(datadir)/icons
+-icondir = $(datadir)/icons
+#icon_DATA = abiword_48.png
-+#icondir= $(datadir)/icons
++#icondir = $(datadir)/icons
- # Hack: make sure that the PEERS stuff is build first
- # We can not use the all target, because on parallel builds there is no
-@@ -82,7 +82,6 @@
+ @BIGENDIAN_TRUE@dictionary = $(top_srcdir)/../abidistfiles/dictionary/BigEndian32.american.hash
+ @BIGENDIAN_FALSE@dictionary = $(top_srcdir)/../abidistfiles/dictionary/LittleEndian32.american.hash
+@@ -586,7 +586,6 @@
# Install the datafiles. This is quick-and-dirty.
install-data-local:
@@ -24,7 +35,7 @@
if test -d $(top_srcdir)/../abidistfiles ; then \
for dir in `cd $(top_srcdir)/../abidistfiles; find . -type d ! -name CVS` ; do \
$(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/$$dir ;\
-@@ -95,11 +94,7 @@
+@@ -599,11 +598,7 @@
for file in $(top_srcdir)/../abidistfiles/$$dir/* ; do \
if test -f $$file ; then \
sfile=`echo "$$file" | sed 's/\.[^.]*$$//'`; \
diff --git a/editors/abiword/files/patch-an b/editors/abiword/files/patch-an
index f2e91bdd806e..1048c7ae0a2b 100644
--- a/editors/abiword/files/patch-an
+++ b/editors/abiword/files/patch-an
@@ -1,9 +1,9 @@
$FreeBSD$
---- src/Makefile.orig Thu May 30 17:51:53 2002
-+++ src/Makefile Wed Jun 5 15:47:41 2002
-@@ -48,6 +48,7 @@
+--- src/Makefile.orig Mon Jun 7 00:15:08 2004
++++ src/Makefile Mon Jun 7 00:51:56 2004
+@@ -52,6 +52,7 @@
## Set the following to a list of pathnames to be copied to $(CANONDIR)
CANON_TOPLEVELFILES= $(ABI_ROOT)/COPYING $(ABI_ROOT)/user/wp/readme.txt
@@ -11,7 +11,7 @@ $FreeBSD$
## Set the following to a list of directories (probably a subset of DIRS)
## that have work to do.
-@@ -58,6 +59,9 @@
+@@ -62,6 +63,9 @@
@for k in $(CANON_TOPLEVELFILES); do \
$(ABICOPY) $$k $(CANONDIR); \
done
@@ -21,21 +21,26 @@ $FreeBSD$
@for k in $(CANON_SubDirs); do \
$(MAKE) ABI_ROOT=$(ABI_ROOT) -C $$k canonical; \
done
-@@ -72,6 +76,7 @@
- cp $$k american.hash; \
- rm $$k ; \
+@@ -73,9 +77,10 @@
+ @$(ABICOPY) $(ABI_ROOT)/../abidistfiles/dictionary/$(OS_ENDIAN).*.hash $(CANONDIR)/dictionary
+ @(cd $(CANONDIR)/dictionary; \
+ for k in *.hash; do \
+- cp $$k american.hash; \
+- rm $$k ; \
++ $(ABICOPY) $$k american.hash; \
++ $(ABIRM) $$k ; \
done)
+ @(cd $(CANONDIR)/dictionary; $(ABICHMOD) ugo=r *)
# We currently only ship american.hash, so the above and below aren't logical.
- # For same reason, this will only copy american.hash-encoding once in place. The rest is in abispell.
- @$(ABICOPY) $(ABI_ROOT)/../abidistfiles/dictionary/*.hash-encoding $(CANONDIR)/dictionary
-@@ -112,10 +117,12 @@
+ @$(ABICOPY) $(ABI_ROOT)/../abidistfiles/dictionary/*.xml $(CANONDIR)/dictionary
+ endif
+@@ -115,10 +120,12 @@
fi
# icons for X window manager use
@$(subst xxxx,$(CANONDIR)/icons,$(VERIFY_DIRECTORY))
- (cd $(ABI_ROOT)/../abidistfiles/icons; cp abi* $(CANONDIR)/icons)
+ (cd $(ABI_ROOT)/../abidistfiles/icons; $(ABICOPY) abi* $(CANONDIR)/icons)
-+ @(cd $(CANONDIR)/icons; $(ABICHMOD) ugo=r *_48*)
++ @(cd $(CANONDIR)/icons; $(ABICHMOD) ugo=r abi*)
# font stuff for installation
@$(subst xxxx,$(CANONDIR)/fonts,$(VERIFY_DIRECTORY))
- (cd $(ABI_ROOT)/../unixfonts/fonts ; cp *.* $(CANONDIR)/fonts)
diff --git a/editors/abiword/files/patch-ap b/editors/abiword/files/patch-ap
deleted file mode 100644
index 76fbc4554e65..000000000000
--- a/editors/abiword/files/patch-ap
+++ /dev/null
@@ -1,23 +0,0 @@
---- src/wp/Makefile.orig Sat Apr 13 07:22:38 2002
-+++ src/wp/Makefile Fri Apr 19 23:30:57 2002
-@@ -44,8 +44,18 @@
- @$(subst xxxx,$(CANON_AppDir),$(VERIFY_DIRECTORY))
- @$(subst xxxx,$(CANON_AppDir)/strings,$(VERIFY_DIRECTORY))
- @$(subst xxxx,$(CANON_AppDir)/help,$(VERIFY_DIRECTORY))
-+ @$(subst xxxx,$(CANON_AppDir)/help/en-US,$(VERIFY_DIRECTORY))
-+ @$(subst xxxx,$(CANON_AppDir)/help/en-US/howto,$(VERIFY_DIRECTORY))
-+ @$(subst xxxx,$(CANON_AppDir)/help/en-US/howto/howtoweb.xhtml_data,$(VERIFY_DIRECTORY))
-+ @$(subst xxxx,$(CANON_AppDir)/help/en-US/howto/howtoword.xhtml_data,$(VERIFY_DIRECTORY))
-+ @$(subst xxxx,$(CANON_AppDir)/help/en-US/info,$(VERIFY_DIRECTORY))
-+ @$(subst xxxx,$(CANON_AppDir)/help/en-US/interface,$(VERIFY_DIRECTORY))
-+ @$(subst xxxx,$(CANON_AppDir)/help/en-US/interface/dialogreplace.xhtml_data,$(VERIFY_DIRECTORY))
-+ @$(subst xxxx,$(CANON_AppDir)/help/en-US/interface/menufile.xhtml_data,$(VERIFY_DIRECTORY))
-+ @$(subst xxxx,$(CANON_AppDir)/help/en-US/interface/workspace.xhtml_data,$(VERIFY_DIRECTORY))
-+ @$(subst xxxx,$(CANON_AppDir)/help/en-US/problems,$(VERIFY_DIRECTORY))
-+ @$(subst xxxx,$(CANON_AppDir)/help/en-US/tutorial,$(VERIFY_DIRECTORY))
-+ @$(subst xxxx,$(CANON_AppDir)/help/images,$(VERIFY_DIRECTORY))
- @$(ABICOPY) $(USERDIR)/wp/readme.txt $(CANON_AppDir)
- @$(ABICOPY) $(USERDIR)/wp/system.profile* $(CANON_AppDir)
- @$(ABICOPY) $(USERDIR)/wp/strings/*.strings $(CANON_AppDir)/strings
-- (cd $(USERDIR)/wp/help; tar cf - images ./*.* $(CANON_Lang)/*.* $(CANON_Lang)/*/*.*) | (cd $(CANON_AppDir)/help; tar xf -)
-- @$(ABICOPY) $(ABI_ROOT)/CREDITS.TXT $(CANON_AppDir)/help/en-US/credits.txt
diff --git a/editors/abiword/files/patch-aq b/editors/abiword/files/patch-aq
index ed0324f287e6..4ceb3a27cd99 100644
--- a/editors/abiword/files/patch-aq
+++ b/editors/abiword/files/patch-aq
@@ -1,24 +1,25 @@
---- src/config/abi_defs.mk Fri Jun 9 15:48:49 2000
-+++ src/config/abi_defs.mk.new Thu Jun 22 16:32:03 2000
-@@ -124,11 +124,11 @@
+--- src/config/abi_defs.mk.orig Mon Jun 7 00:43:15 2004
++++ src/config/abi_defs.mk Mon Jun 7 00:47:55 2004
+@@ -213,11 +213,11 @@
## INSTALL program...
define MAKE_OBJDIR
-if test ! -d $(@D); then rm -rf $(@D); mkdir -p $(@D); fi
-+if test ! -d $(@D); then rm -rf $(@D); $(ABIMKDIR) -p $(@D); fi
++if test ! -d $(@D); then $(ABIRM) -rf $(@D); $(ABIMKDIR) -p $(@D); fi
endef
define VERIFY_DIRECTORY
-if test ! -d xxxx; then rm -rf xxxx; mkdir -p xxxx; fi
-+if test ! -d xxxx; then rm -rf xxxx; $(ABIMKDIR) -p xxxx; fi
++if test ! -d xxxx; then $(ABIRM) -rf xxxx; $(ABIMKDIR) -p xxxx; fi
endef
ifeq ($(OS_NAME), WIN32)
-@@ -160,7 +160,9 @@
+@@ -262,7 +262,10 @@
##################################################################
##################################################################
-ABICOPY=cp
++ABIRM = rm
+ABICOPY = cp
+ABICHMOD = chmod
+ABIMKDIR = mkdir -m u=rwx,go=rx
diff --git a/editors/abiword/files/patch-autogen.sh b/editors/abiword/files/patch-autogen.sh
deleted file mode 100644
index 666294e14182..000000000000
--- a/editors/abiword/files/patch-autogen.sh
+++ /dev/null
@@ -1,57 +0,0 @@
---- autogen.sh.orig Fri Feb 20 08:29:23 2004
-+++ autogen.sh Sat Mar 6 03:36:00 2004
-@@ -10,7 +10,7 @@
-
- rm -f autogen.err
-
--automake --version | perl -ne 'if (/\(GNU automake\) ([0-9].[0-9])/) {print; if ($1 < 1.4) {exit 1;}}'
-+%%AUTOMAKE%% --version | perl -ne 'if (/\(GNU automake\) ([0-9].[0-9])/) {print; if ($1 < 1.4) {exit 1;}}'
-
- if [ $? -ne 0 ]; then
- echo "Error: you need automake 1.4 or later. Please upgrade."
-@@ -19,9 +19,9 @@
-
- # Produce aclocal.m4, so autoconf gets the automake macros it needs
- #
--echo "Creating aclocal.m4: aclocal -I ac-helpers $ACLOCAL_FLAGS"
-+echo "Creating aclocal.m4: %%ACLOCAL%% -I ac-helpers $ACLOCAL_FLAGS"
-
--aclocal -I ac-helpers $ACLOCAL_FLAGS 2>> autogen.err
-+%%ACLOCAL%% -I ac-helpers $ACLOCAL_FLAGS 2>> autogen.err
-
- if test -f autom4te.cache/requests; then
- echo "Checking for PKG_CHECK_MODULES in autom4te.cache/requests ..."
-@@ -32,9 +32,9 @@
- fi
-
- if test "x$pkgcheckdef" = "x"; then
-- echo "Running aclocal -I ac-helpers -I ac-helpers/pkg-config $ACLOCAL_FLAGS"
-- (aclocal -I ac-helpers -I ac-helpers/pkg-config $ACLOCAL_FLAGS 2>> autogen.err) || {
-- echo "aclocal failed! Unable to continue."
-+ echo "Running %%ACLOCAL%% -I ac-helpers -I ac-helpers/pkg-config $ACLOCAL_FLAGS"
-+ (%%ACLOCAL%% -I ac-helpers -I ac-helpers/pkg-config $ACLOCAL_FLAGS 2>> autogen.err) || {
-+ echo "%%ACLOCAL%% failed! Unable to continue."
- exit 1
- }
- if test -f autom4te.cache/requests; then
-@@ -62,9 +62,9 @@
- # Produce all the `GNUmakefile.in's and create neat missing things
- # like `install-sh', etc.
- #
--echo "automake --add-missing --copy --foreign"
-+echo "%%AUTOMAKE%% --add-missing --copy --foreign"
-
--automake --add-missing --copy --foreign 2>> autogen.err || {
-+%%AUTOMAKE%% --add-missing --copy --foreign 2>> autogen.err || {
- echo ""
- echo "* * * warning: possible errors while running automake - check autogen.err"
- echo ""
-@@ -80,7 +80,7 @@
- #
- echo "Creating configure..."
-
--autoconf 2>> autogen.err || {
-+%%AUTOCONF%% 2>> autogen.err || {
- echo ""
- echo "* * * warning: possible errors while running automake - check autogen.err"
- echo ""
diff --git a/editors/abiword/files/patch-ax b/editors/abiword/files/patch-ax
deleted file mode 100644
index 91ab0177588d..000000000000
--- a/editors/abiword/files/patch-ax
+++ /dev/null
@@ -1,10 +0,0 @@
---- ../wv/libole2/ms-ole.h Sun Oct 6 20:18:41 2002
-+++ ../wv/libole2/ms-ole.h.new Sun Oct 6 20:18:48 2002
-@@ -20,6 +20,7 @@
- #if defined(__QNXNTO__)
- # include <sys/types.h>
- #endif
-+# include <sys/types.h>
- # include <fcntl.h> /* for mode_t */
- #else
- # include <stdlib.h>
diff --git a/editors/abiword/pkg-plist b/editors/abiword/pkg-plist
index 10cf0ceeb05e..5f02c8dfb439 100644
--- a/editors/abiword/pkg-plist
+++ b/editors/abiword/pkg-plist
@@ -25,6 +25,147 @@ share/AbiSuite-2.0/AbiWord/glade/xap_UnixDlg_Password.glade
share/AbiSuite-2.0/AbiWord/glade/xap_UnixDlg_PluginManager.glade
share/AbiSuite-2.0/AbiWord/glade/xap_UnixDlg_WindowMore.glade
share/AbiSuite-2.0/AbiWord/glade/xap_UnixDlg_Zoom.glade
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/aboutos.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/azindex.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/credits.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/fdl.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/histyle.css
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/howto/howtodocs.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/howto/howtodocument.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/howto/howtodocument.html_files/exit_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/howto/howtodocument.html_files/savewarning_1.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/howto/howtolists.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/howto/howtomailmerge.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/howto/howtomailmerge.html_files/mergefielddlg1_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/howto/howtomailmerge.html_files/mergesample2_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/howto/howtonormaltemplate.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/howto/howtoprefs.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/howto/howtotables.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/howto/howtotranslation.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/howto/howtoweb.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/howto/howtoweb.html_files/ruler_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/howto/howtoword.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/howto/howtoword.html_files/gettingstarted_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/howto/index.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/index.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/info/index.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/info/infoformats.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/info/infomsdi.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/info/inforequirements.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/info/infosections.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/info/infospelling.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogbackgroundcolor.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogbookmark.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogbreak.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogchangecase.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogcolumns.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogdateandtime.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogfield.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogfind.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogfont.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogformatfootnotes.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogformatheaderfooters.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogformattable.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialoggoto.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialoghtmlexport.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialoghyperlink.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogimageproperties.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialoginserttable.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialoglanguage.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialoglists.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogmailmerge.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogmailmergetool.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogmarkrevisions.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogmergecells.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogmodifystyle.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialognew.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialognewstyle.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogopenlinux.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogpagenumbers.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogpagesetup.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogparagraph.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogplugins.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogpreferences.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogprint.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogproperties.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogreplace.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogsavelinux.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogscreencolor.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogselectrevision.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogspelling.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogstyles.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogsymbol.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogtabs.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogviewdocument.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogwordcount.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/dialogzoom.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/index.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/menucontextual.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/menuedit.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/menufile.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/menuformat.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/menuhelp.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/menuinsert.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/menutable.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/menutools.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/menuview.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/menuwindow.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/rulers.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/rulers.html_files/rulers_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/rulers.html_files/rulerscentertab_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/rulers.html_files/rulersdecimaltab_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/rulers.html_files/rulersfirstindent_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/rulers.html_files/rulersindent_1.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/rulers.html_files/rulersleftindent_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/rulers.html_files/rulerslefttab_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/rulers.html_files/rulerslinetab_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/rulers.html_files/rulersmargins_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/rulers.html_files/rulersrighttab_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/rulers.html_files/rulerstab_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/toolbarextra.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/toolbarformatting.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/toolbarstandard.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/toolbartable.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/workspace.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/workspace.html_files/full_window_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/workspace.html_files/functionbars_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/workspace.html_files/functionbars_hiding_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/workspace.html_files/grabbar_shaded_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/workspace.html_files/ruler_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/workspace.html_files/statusbar_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/workspace.html_files/statusbar_quickhelp_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/interface/workspace.html_files/titlebar_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/introduction.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/plugins/index.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/problems/index.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/problems/problemsbugs.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/problems/problemsfaq.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/problems/problemshelp.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/search.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/style.css
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/tutorial/index.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/tutorial/intro.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/tutorial/window.html
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/tutorial/window.html_files/image_10_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/tutorial/window.html_files/image_11_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/tutorial/window.html_files/image_12_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/tutorial/window.html_files/image_13_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/tutorial/window.html_files/image_14_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/tutorial/window.html_files/image_15_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/tutorial/window.html_files/image_16_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/tutorial/window.html_files/image_17_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/tutorial/window.html_files/image_18_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/tutorial/window.html_files/image_19_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/tutorial/window.html_files/image_1_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/tutorial/window.html_files/image_20_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/tutorial/window.html_files/image_2_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/tutorial/window.html_files/image_3_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/tutorial/window.html_files/image_4_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/tutorial/window.html_files/image_5_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/tutorial/window.html_files/image_6_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/tutorial/window.html_files/image_7_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/tutorial/window.html_files/image_8_0.png
+%%HELPDOCS:%%share/AbiSuite-2.0/AbiWord/help/en-US/tutorial/window.html_files/image_9_0.png
share/AbiSuite-2.0/AbiWord/readme.txt
share/AbiSuite-2.0/AbiWord/scripts/abw2html.pl
share/AbiSuite-2.0/AbiWord/strings/am-ET.strings
@@ -179,6 +320,8 @@ share/AbiSuite-2.0/clipart/tree.png
share/AbiSuite-2.0/clipart/tux_bordelais.png
share/AbiSuite-2.0/clipart/weather.png
share/AbiSuite-2.0/clipart/write.png
+%%DICT:%%share/AbiSuite-2.0/dictionary/american.hash
+%%DICT:%%share/AbiSuite-2.0/dictionary/ispell_dictionary_list.xml
share/AbiSuite-2.0/icons/abiword_16.xpm
share/AbiSuite-2.0/icons/abiword_48.png
share/AbiSuite-2.0/icons/abiword_48.tif
@@ -262,6 +405,21 @@ share/AbiSuite-2.0/templates/normal.awt-zh_TW
@dirrm share/AbiSuite-2.0/clipart
@dirrm share/AbiSuite-2.0/AbiWord/strings
@dirrm share/AbiSuite-2.0/AbiWord/scripts
+%%HELPDOCS:%%@dirrm share/AbiSuite-2.0/AbiWord/help/en-US/tutorial/window.html_files
+%%HELPDOCS:%%@dirrm share/AbiSuite-2.0/AbiWord/help/en-US/tutorial
+%%HELPDOCS:%%@dirrm share/AbiSuite-2.0/AbiWord/help/en-US/problems
+%%HELPDOCS:%%@dirrm share/AbiSuite-2.0/AbiWord/help/en-US/plugins
+%%HELPDOCS:%%@dirrm share/AbiSuite-2.0/AbiWord/help/en-US/interface/workspace.html_files
+%%HELPDOCS:%%@dirrm share/AbiSuite-2.0/AbiWord/help/en-US/interface/rulers.html_files
+%%HELPDOCS:%%@dirrm share/AbiSuite-2.0/AbiWord/help/en-US/interface
+%%HELPDOCS:%%@dirrm share/AbiSuite-2.0/AbiWord/help/en-US/info
+%%HELPDOCS:%%@dirrm share/AbiSuite-2.0/AbiWord/help/en-US/howto/howtoword.html_files
+%%HELPDOCS:%%@dirrm share/AbiSuite-2.0/AbiWord/help/en-US/howto/howtoweb.html_files
+%%HELPDOCS:%%@dirrm share/AbiSuite-2.0/AbiWord/help/en-US/howto/howtomailmerge.html_files
+%%HELPDOCS:%%@dirrm share/AbiSuite-2.0/AbiWord/help/en-US/howto/howtodocument.html_files
+%%HELPDOCS:%%@dirrm share/AbiSuite-2.0/AbiWord/help/en-US/howto
+%%HELPDOCS:%%@dirrm share/AbiSuite-2.0/AbiWord/help/en-US
+%%HELPDOCS:%%@dirrm share/AbiSuite-2.0/AbiWord/help
@dirrm share/AbiSuite-2.0/AbiWord/glade
@dirrm share/AbiSuite-2.0/AbiWord
@dirrm share/AbiSuite-2.0