aboutsummaryrefslogtreecommitdiff
path: root/editors/bless/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/bless/Makefile')
-rw-r--r--editors/bless/Makefile19
1 files changed, 7 insertions, 12 deletions
diff --git a/editors/bless/Makefile b/editors/bless/Makefile
index d7aea5851d37..d5fc0e30e74e 100644
--- a/editors/bless/Makefile
+++ b/editors/bless/Makefile
@@ -17,28 +17,23 @@ COMMENT= A high quality, full featured hex editor
USE_GNOME= gnomehack gnomeprefix gnometarget gnomedocutils gtksharp20
USE_GMAKE= yes
-INSTALLS_OMF= yes
GNU_CONFIGURE= yes
-DOCS= AUTHORS COPYING ChangeLog NEWS README
+.if !defined(NOPORTDOCS)
+INSTALLS_OMF= yes
+.endif
post-patch:
- @${REINPLACE_CMD} -e 's|data tests|data|g' \
+ @${REINPLACE_CMD} -e 's|tests$$||g' \
${WRKSRC}/Makefile.in
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|$$(datadir)/doc/$$(PACKAGE_NAME)-$$(PACKAGE_VERSION)|${DOCSDIR}|g'
.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -e 's|src doc|src|g' \
+ @${REINPLACE_CMD} -e 's|data doc|data|g' \
+ -e '/^install-data-local:/,/^$$/d' \
+ -e 's|install-data-local||' \
${WRKSRC}/Makefile.in
.endif
-.ifndef (NOPORTDOCS)
-post-install:
- @${MKDIR} ${DOCSDIR}
-.for i in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
-.endif
-
.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.mk>