aboutsummaryrefslogtreecommitdiff
path: root/editors/elvis/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/elvis/Makefile')
-rw-r--r--editors/elvis/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/editors/elvis/Makefile b/editors/elvis/Makefile
new file mode 100644
index 000000000000..2d81d4c4ee74
--- /dev/null
+++ b/editors/elvis/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: elvis
+# Version required: 2.1.3
+# Date created: 1999-09-01
+# Whom: Christian Weisgerber <naddy@unix-ag.uni-kl.de>
+#
+# $FreeBSD$
+#
+
+DISTNAME= elvis-2.1_3
+PKGNAME= elvis-2.1.3
+CATEGORIES= editors
+MASTER_SITES= ftp://ftp.cs.pdx.edu/pub/elvis/ \
+ ftp://ftp.false.com/pub/elvis/ \
+ ftp://ftp.fh-wedel.de/pub/elvis/
+
+MAINTAINER= ports@freebsd.org
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --bindir=${PREFIX}/bin --datadir=${PREFIX}/share/elvis
+MAN1= elvis.1 elvtags.1 ref.1
+
+# Support building on systems with or without X11 installed.
+.if defined(NO_X11)
+CONFIGURE_ARGS+= --with-x=no
+.else
+USE_XLIB= yes
+
+pre-fetch:
+ @${ECHO_MSG} "To build this port without X11, define \"NO_X11\"."
+.endif
+
+do-install:
+.for file in elvis elvtags ref
+ ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/lib/${file}.man ${PREFIX}/man/man1/${file}.1
+.endfor
+ @${MKDIR} ${PREFIX}/share/elvis
+ ${INSTALL_DATA} ${WRKSRC}/lib/* ${PREFIX}/share/elvis
+
+.include <bsd.port.mk>