aboutsummaryrefslogtreecommitdiff
path: root/editors/flim-emacs20-current
diff options
context:
space:
mode:
Diffstat (limited to 'editors/flim-emacs20-current')
-rw-r--r--editors/flim-emacs20-current/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/editors/flim-emacs20-current/Makefile b/editors/flim-emacs20-current/Makefile
index 1fe17fd3faf6..7656141fa0cd 100644
--- a/editors/flim-emacs20-current/Makefile
+++ b/editors/flim-emacs20-current/Makefile
@@ -3,7 +3,7 @@
# Date created: 23 September 1998
# Whom: Shigeyuki FUKUSHIMA <shige@kuis.kyoto-u.ac.jp>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1999/01/16 01:36:55 kuriyama Exp $
#
DISTNAME= flim-${FLIM_VER}
@@ -37,13 +37,21 @@ EMACS_VER= 20.3
EMACS_LIBDIR= share/${EMACS_NAME}
EMACS_CMD= ${PREFIX}/bin/${EMACS_NAME}-${EMACS_VER}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 300006
+MAKEINFO= makeinfo --no-split --force
+.else
+MAKEINFO= makeinfo --no-split
+.endif
+
post-build:
@(cd ${WRKSRC} ; \
for i in mime-en.texi mime-ja.texi; do \
${MV} $${i} $${i}.jis ; \
${CAT} $${i}.jis | nkf -e > $${i} ; \
${ECHO} "===> Please ignore the following errors." ; \
- makeinfo --no-split $${i} || ${TRUE} ; \
+ ${MAKEINFO} $${i} || ${TRUE} ; \
done)
post-install:
@@ -59,4 +67,4 @@ post-install:
done
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>